aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2017-08-19 12:32:55 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-19 14:43:47 +0200
commit209e7e6dd8e23bc6501ada7d7b4caa99e449de6a (patch)
treee9e4b493a3fbf717d0747bafcba5e0604a238692
parentd9f4b6e55e02458e6bd4b66188cb87d8a7c474fc (diff)
qtwebengine: disable SECURITY_STRINGFORMAT to fix the build
* meta/conf/distro/include/security_flags.inc adds -Wformat and -Wformat-security, but openh264 adds -Wno-format after that causing build to fail Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 84c46688..ab293a96 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -32,6 +32,14 @@ EXTRA_QMAKEVARS_PRE += "GYP_CONFIG+=use_system_yasm \
GYP_CONFIG+=use_experimental_allocator_shim=false \
"
+# chromium/third_party/openh264/openh264.gyp adds
+# -Wno-format to openh264_cflags_add
+# similarly chromium/third_party/openh264/BUILD.gn for newer qtwebengine
+# causing following error, because -Wformat-security cannot be used together with -Wno-format
+# cc1plus: error: -Wformat-security ignored without -Wformat [-Werror=format-security]
+# http://errors.yoctoproject.org/Errors/Details/150333/
+SECURITY_STRINGFORMAT = ""
+
# To use system ffmpeg you need to enable also libwebp, opus, vpx
# Only depenedencies available in oe-core are enabled by default
PACKAGECONFIG ??= "libwebp flac libevent libxslt speex"