aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Crowe <mac@mcrowe.com>2017-09-08 14:48:02 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-11 13:20:22 +0200
commit743b3b93e17f5382fd1f9f4e0d2932501c8a3c78 (patch)
tree798f62a04fcf79c3eccc3459ed27ebbdbb20ac82
parentbe3c2d3e8c06528c20fa4511a75d649488a8c802 (diff)
qtbase-native: Force use of built-in pcre
If we specify neither -system-pcre nor -qt-pcre then qtbase will first see if it can find the pcre library in the system and fall back to compiling its own if that's not possible. Unfortunately, this means that if qtbase-native happens to be built on a machine with system pcre available then the resulting binaries such as bin/qt5/uic in sstate files won't work correctly on machines that don't have pcre available. Even ignoring that, it doesn't help for packages to build differently depending on how the build system is configured. We could depend on pcre-native and pass -system-pcre, but this doesn't work by default because qtbase actually requires pcre16 which is an optional (via PACKAGECONFIG) feature of pcre so the default there would need to be changed too. So, let's make qtbase-native match the default of qtbase by passing -qt-pcre in order to ensure that qtbase-native is always built with its own pcre implementation. Signed-off-by: Mike Crowe <mac@mcrowe.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 7e916dfd..3a0699c4 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -52,6 +52,7 @@ PACKAGECONFIG_CONFARGS = " \
-sysroot ${STAGING_DIR_NATIVE} \
-no-gcc-sysroot \
-system-zlib \
+ -qt-pcre \
-no-libjpeg \
-no-libpng \
-no-gif \