aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2020-12-02 22:51:59 +0100
committerMartin Jansa <martin.jansa@lge.com>2021-10-03 15:43:25 -0700
commit2bd32a5ed33b88700e17a90192280695ae2ed32c (patch)
tree25ecb9c57a75975550041e15fa49b58752e69191
parentdda620dc562d38e950a603aef4e348b0f6ac3055 (diff)
qtwebkit: fix build with icu >= 68
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebkit/0008-Fix-build-with-icu-68.patch125
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb1
2 files changed, 126 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebkit/0008-Fix-build-with-icu-68.patch b/recipes-qt/qt5/qtwebkit/0008-Fix-build-with-icu-68.patch
new file mode 100644
index 00000000..1715c8f3
--- /dev/null
+++ b/recipes-qt/qt5/qtwebkit/0008-Fix-build-with-icu-68.patch
@@ -0,0 +1,125 @@
+From 0e94085f74b562bf8edf5418142323785a069454 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
+Date: Wed, 2 Dec 2020 22:34:54 +0100
+Subject: [PATCH] Fix build with icu >= 68
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Upstream-Status: Pending
+
+Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
+---
+ Source/WebCore/platform/text/TextCodecICU.cpp | 15 +++++++++++++++
+ Source/WebCore/platform/text/icu/UTextProvider.h | 15 +++++++++++++++
+ .../platform/text/icu/UTextProviderLatin1.cpp | 15 +++++++++++++++
+ .../platform/text/icu/UTextProviderUTF16.cpp | 15 +++++++++++++++
+ 4 files changed, 60 insertions(+)
+
+diff --git a/Source/WebCore/platform/text/TextCodecICU.cpp b/Source/WebCore/platform/text/TextCodecICU.cpp
+index dd6ff0675..7ce8a70ef 100644
+--- a/Source/WebCore/platform/text/TextCodecICU.cpp
++++ b/Source/WebCore/platform/text/TextCodecICU.cpp
+@@ -39,6 +39,21 @@
+ #include <wtf/text/StringBuilder.h>
+ #include <wtf/unicode/CharacterNames.h>
+
++// Since icu 68.1 icu we have to:
++#ifndef TRUE
++// Taken from umachibe.h:
++/**
++ * The TRUE value of a UBool.
++ *
++ * @deprecated ICU 68 Use standard "true" instead.
++ */
++# define TRUE true
++#endif
++
++#ifndef FALSE
++# define FALSE false
++#endif
++
+ namespace WebCore {
+
+ const size_t ConversionBufferSize = 16384;
+diff --git a/Source/WebCore/platform/text/icu/UTextProvider.h b/Source/WebCore/platform/text/icu/UTextProvider.h
+index c254fc4c7..9d2ad8b8c 100644
+--- a/Source/WebCore/platform/text/icu/UTextProvider.h
++++ b/Source/WebCore/platform/text/icu/UTextProvider.h
+@@ -28,6 +28,21 @@
+
+ #include <unicode/utext.h>
+
++// Since icu 68.1 icu we have to:
++#ifndef TRUE
++// Taken from umachibe.h:
++/**
++ * The TRUE value of a UBool.
++ *
++ * @deprecated ICU 68 Use standard "true" instead.
++ */
++# define TRUE true
++#endif
++
++#ifndef FALSE
++# define FALSE false
++#endif
++
+ namespace WebCore {
+
+ enum class UTextProviderContext {
+diff --git a/Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp b/Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp
+index cd6852c71..0c95ea529 100644
+--- a/Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp
++++ b/Source/WebCore/platform/text/icu/UTextProviderLatin1.cpp
+@@ -29,6 +29,21 @@
+ #include "UTextProvider.h"
+ #include <wtf/text/StringImpl.h>
+
++// Since icu 68.1 icu we have to:
++#ifndef TRUE
++// Taken from umachibe.h:
++/**
++ * The TRUE value of a UBool.
++ *
++ * @deprecated ICU 68 Use standard "true" instead.
++ */
++# define TRUE true
++#endif
++
++#ifndef FALSE
++# define FALSE false
++#endif
++
+ namespace WebCore {
+
+ // Latin1 provider
+diff --git a/Source/WebCore/platform/text/icu/UTextProviderUTF16.cpp b/Source/WebCore/platform/text/icu/UTextProviderUTF16.cpp
+index 7aaac48c8..6ac693602 100644
+--- a/Source/WebCore/platform/text/icu/UTextProviderUTF16.cpp
++++ b/Source/WebCore/platform/text/icu/UTextProviderUTF16.cpp
+@@ -28,6 +28,21 @@
+
+ #include "UTextProvider.h"
+
++// Since icu 68.1 icu we have to:
++#ifndef TRUE
++// Taken from umachibe.h:
++/**
++ * The TRUE value of a UBool.
++ *
++ * @deprecated ICU 68 Use standard "true" instead.
++ */
++# define TRUE true
++#endif
++
++#ifndef FALSE
++# define FALSE false
++#endif
++
+ namespace WebCore {
+
+ // UTF16ContextAware provider
+--
+2.26.2
+
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index 45810935..00ed73d4 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -18,6 +18,7 @@ SRC_URI += "\
file://0002-Fix-build-with-non-glibc-libc-on-musl.patch \
file://0004-Fix-build-bug-for-armv32-BE.patch \
file://0001-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch \
+ file://0008-Fix-build-with-icu-68.patch \
"
inherit cmake_qt5 perlnative pythonnative