aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2020-03-03 10:10:02 +0200
committerMartin Jansa <martin.jansa@lge.com>2020-04-17 04:27:46 -0700
commit7d0b17aa229edc9e138edfe0e8477fbbe9013ba6 (patch)
treefe0a91c3844c2af9c536026f9a2de06cb2241489
parent1f1afdb6a7d1b4d2c1d520a701c8ac06f9a79002 (diff)
qt5: upgrade to 5.12.8
Signed-off-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qt3d_git.bb2
-rw-r--r--recipes-qt/qt5/qt5-git.inc2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtcanvas3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtcharts_git.bb2
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
-rw-r--r--recipes-qt/qt5/qtdatavis3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtgamepad_git.bb2
-rw-r--r--recipes-qt/qt5/qtgraphicaleffects_git.bb2
-rw-r--r--recipes-qt/qt5/qtimageformats_git.bb2
-rw-r--r--recipes-qt/qt5/qtknx_git.bb2
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb2
-rw-r--r--recipes-qt/qt5/qtmqtt_git.bb2
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtnetworkauth_git.bb2
-rw-r--r--recipes-qt/qt5/qtopcua_git.bb2
-rw-r--r--recipes-qt/qt5/qtpurchasing_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols2_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols_git.bb2
-rw-r--r--recipes-qt/qt5/qtremoteobjects_git.bb2
-rw-r--r--recipes-qt/qt5/qtscript_git.bb2
-rw-r--r--recipes-qt/qt5/qtscxml_git.bb2
-rw-r--r--recipes-qt/qt5/qtsensors_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialbus_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialport_git.bb2
-rw-r--r--recipes-qt/qt5/qtsvg_git.bb2
-rw-r--r--recipes-qt/qt5/qttools_git.bb2
-rw-r--r--recipes-qt/qt5/qttranslations_git.bb2
-rw-r--r--recipes-qt/qt5/qtvirtualkeyboard_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebchannel_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb4
-rw-r--r--recipes-qt/qt5/qtwebglplugin_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebsockets_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebview_git.bb2
-rw-r--r--recipes-qt/qt5/qtx11extras_git.bb2
-rw-r--r--recipes-qt/qt5/qtxmlpatterns_git.bb2
40 files changed, 41 insertions, 41 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index c05b794f..9e5d061b 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -194,4 +194,4 @@ fakeroot do_generate_qt_environment_file() {
do_generate_qt_environment_file[umask] = "022"
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "1bf5d3af1a4ec307bb77e1b54bb1f723c3eef481"
+SRCREV = "08d6cb7673aa51bc0532d71db4134f4912e14769"
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index 5bb7f057..74ae3fe7 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -36,6 +36,6 @@ do_configure_prepend() {
${S}/src/quick3d/imports/input/importsinput.pro
}
-SRCREV = "4c25b436284669c44cc353dad7b9c89af3bae290"
+SRCREV = "f965d4712a97b69b2d4b43178f8e523668d97a82"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qt5-git.inc b/recipes-qt/qt5/qt5-git.inc
index 169c032a..fd8b1011 100644
--- a/recipes-qt/qt5/qt5-git.inc
+++ b/recipes-qt/qt5/qt5-git.inc
@@ -14,4 +14,4 @@ CVE_PRODUCT = "qt"
S = "${WORKDIR}/git"
-PV = "5.12.7+git${SRCPV}"
+PV = "5.12.8+git${SRCPV}"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index fa8709f0..c277e5ea 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -142,4 +142,4 @@ do_install() {
echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
}
-SRCREV = "1bf5d3af1a4ec307bb77e1b54bb1f723c3eef481"
+SRCREV = "08d6cb7673aa51bc0532d71db4134f4912e14769"
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index f051f5af..42e5cc35 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -294,4 +294,4 @@ sed -i \
$D${OE_QMAKE_PATH_ARCHDATA}/mkspecs/qmodule.pri
}
-SRCREV = "1bf5d3af1a4ec307bb77e1b54bb1f723c3eef481"
+SRCREV = "08d6cb7673aa51bc0532d71db4134f4912e14769"
diff --git a/recipes-qt/qt5/qtcanvas3d_git.bb b/recipes-qt/qt5/qtcanvas3d_git.bb
index 8318ba4f..048d01b3 100644
--- a/recipes-qt/qt5/qtcanvas3d_git.bb
+++ b/recipes-qt/qt5/qtcanvas3d_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS = "qtdeclarative"
-SRCREV = "41142426b6d2dd16cf622349238697a457767b06"
+SRCREV = "abab2cc31b49d78d40cd52d4ac3bf32510390522"
diff --git a/recipes-qt/qt5/qtcharts_git.bb b/recipes-qt/qt5/qtcharts_git.bb
index e35803d4..15e241d9 100644
--- a/recipes-qt/qt5/qtcharts_git.bb
+++ b/recipes-qt/qt5/qtcharts_git.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia"
-SRCREV = "3cfdc511efc4946fa585f2f1b67b6b651375cfbc"
+SRCREV = "76cf047c29a9ae80f712906257f93a0e447bca42"
# The same issue as in qtbase:
# http://errors.yoctoproject.org/Errors/Details/152641/
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index 055e62d9..58fc8b1e 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -19,4 +19,4 @@ PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,bluez5"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "bdedcf46183552cce796d9aa5149cac6826c49e6"
+SRCREV = "a526644f2f2c7359cbe7d50bea09ded3e6c65e4d"
diff --git a/recipes-qt/qt5/qtdatavis3d_git.bb b/recipes-qt/qt5/qtdatavis3d_git.bb
index ea68fdf0..76eb9937 100644
--- a/recipes-qt/qt5/qtdatavis3d_git.bb
+++ b/recipes-qt/qt5/qtdatavis3d_git.bb
@@ -8,4 +8,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia qtxmlpatterns"
-SRCREV = "633c128754dd586370d2b5e168b85eb7726c8203"
+SRCREV = "6c6a7eb15b490e59119b7262337dd2c6b8eb65e2"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 72994536..a4a3adec 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -24,6 +24,6 @@ do_install_append_class-nativesdk() {
rm -rf ${D}${OE_QMAKE_PATH_QML}
}
-SRCREV = "d762ea24b56d03d449c330626ff9b76f7663ad8d"
+SRCREV = "101799f8acdbfc4ebd05f37a7c09544d24b41af1"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtgamepad_git.bb b/recipes-qt/qt5/qtgamepad_git.bb
index f8ed6044..ddfaee53 100644
--- a/recipes-qt/qt5/qtgamepad_git.bb
+++ b/recipes-qt/qt5/qtgamepad_git.bb
@@ -14,4 +14,4 @@ PACKAGECONFIG[sdl2] = "-feature-sdl2,-no-feature-sdl2,libsdl2"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "cae992e59d40f5f73272dbc7c393bb6a8caf82a9"
+SRCREV = "a047498b16dc6c7abfdd1da5a0385e093b4520ce"
diff --git a/recipes-qt/qt5/qtgraphicaleffects_git.bb b/recipes-qt/qt5/qtgraphicaleffects_git.bb
index 36db225c..35c40188 100644
--- a/recipes-qt/qt5/qtgraphicaleffects_git.bb
+++ b/recipes-qt/qt5/qtgraphicaleffects_git.bb
@@ -18,4 +18,4 @@ RDEPENDS_${PN}-dev = ""
# http://errors.yoctoproject.org/Errors/Build/44912/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "f24a7b83c98661ecd7ba44c3fbc9aa06f6aac265"
+SRCREV = "4cab303c83f034cc926e32ec80dae03855a3ab27"
diff --git a/recipes-qt/qt5/qtimageformats_git.bb b/recipes-qt/qt5/qtimageformats_git.bb
index bc1f2b16..d1839aea 100644
--- a/recipes-qt/qt5/qtimageformats_git.bb
+++ b/recipes-qt/qt5/qtimageformats_git.bb
@@ -25,4 +25,4 @@ PACKAGECONFIG[libwebp] = ",CONFIG+=done_config_libwebp,libwebp"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "584bff1ba46c8049f12d56090c3203c0e26b8987"
+SRCREV = "6c75b54d3350161efb218bd357ff07bc61a421c2"
diff --git a/recipes-qt/qt5/qtknx_git.bb b/recipes-qt/qt5/qtknx_git.bb
index 569b60cc..59f80c5d 100644
--- a/recipes-qt/qt5/qtknx_git.bb
+++ b/recipes-qt/qt5/qtknx_git.bb
@@ -9,4 +9,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "9fc175a9771b1e54a5894795cdafee8e3ccda8d0"
+SRCREV = "ece5316e057bda975cf30100f42bf4305f905aa7"
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index 2d92ad91..6b982f41 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -36,7 +36,7 @@ SRC_URI += " \
${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=${QT_MODULE_BRANCH_MAPBOXGL};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \
"
-SRCREV_qtlocation = "f47d351a2b85159ba2986dc45d2474b840306946"
+SRCREV_qtlocation = "8a7d656a77138a276d4079f54b888d049097ffc5"
SRCREV_qtlocation-mapboxgl = "4b85252fbe811a786c6ee9eabedb7639b031dc53"
SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl"
diff --git a/recipes-qt/qt5/qtmqtt_git.bb b/recipes-qt/qt5/qtmqtt_git.bb
index b3f51bda..81d744b6 100644
--- a/recipes-qt/qt5/qtmqtt_git.bb
+++ b/recipes-qt/qt5/qtmqtt_git.bb
@@ -9,4 +9,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "f1892164ddeaf67062cc9a53f727fb7565a16cc5"
+SRCREV = "707802c57901e4855212ea893af6c01bf9674c1a"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index cd33e7b5..3fb3ac8d 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -37,4 +37,4 @@ SRC_URI += "\
# http://errors.yoctoproject.org/Errors/Build/44914/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "19f4e7ff9d8276e0aa30806de1072a63472e5827"
+SRCREV = "194b584ca1381ab5c5bdebfb455901cf2b0bad61"
diff --git a/recipes-qt/qt5/qtnetworkauth_git.bb b/recipes-qt/qt5/qtnetworkauth_git.bb
index 72fcd416..4bde256e 100644
--- a/recipes-qt/qt5/qtnetworkauth_git.bb
+++ b/recipes-qt/qt5/qtnetworkauth_git.bb
@@ -9,4 +9,4 @@ require qt5-git.inc
DEPENDS += "qtbase"
-SRCREV = "3681e2cd6c859e9028d9c6ae66cde77f56b2e972"
+SRCREV = "a282f5d49362a63d9637c69768b8283c5f85e0b3"
diff --git a/recipes-qt/qt5/qtopcua_git.bb b/recipes-qt/qt5/qtopcua_git.bb
index bf99577b..86aed3a5 100644
--- a/recipes-qt/qt5/qtopcua_git.bb
+++ b/recipes-qt/qt5/qtopcua_git.bb
@@ -18,4 +18,4 @@ SECURITY_STRINGFORMAT = ""
DEPENDS += "qtbase"
-SRCREV = "bae44d81b02c0c1ecc5ae560753ccc9c7a0972c8"
+SRCREV = "890f1428c62cea724e9f76dd019f26a27881474a"
diff --git a/recipes-qt/qt5/qtpurchasing_git.bb b/recipes-qt/qt5/qtpurchasing_git.bb
index a17cd57e..b75c655d 100644
--- a/recipes-qt/qt5/qtpurchasing_git.bb
+++ b/recipes-qt/qt5/qtpurchasing_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "dbe5a5ceb2232d6409e1e985c0f7816426655cba"
+SRCREV = "2191ec56a32cd1c1d6e49e54c5974562ebf3707b"
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb
index 0db3059b..5b00d62b 100644
--- a/recipes-qt/qt5/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols2_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative qtdeclarative-native"
-SRCREV = "54bc815660b5b9789ae88f64de060add4b99b5ca"
+SRCREV = "3c7be4a9911ede96613ffa30f83e1fa5c3d173dc"
diff --git a/recipes-qt/qt5/qtquickcontrols_git.bb b/recipes-qt/qt5/qtquickcontrols_git.bb
index 04058265..ed83327b 100644
--- a/recipes-qt/qt5/qtquickcontrols_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols_git.bb
@@ -17,4 +17,4 @@ FILES_${PN}-qmlplugins += " \
${OE_QMAKE_PATH_QML}/QtQuick/Dialogs/qml/icons.ttf \
"
-SRCREV = "f11d94e893ca2c696626d9a5785ad017d1d35792"
+SRCREV = "4687a1dbef006cbffe014b50c4bbd0edf912334d"
diff --git a/recipes-qt/qt5/qtremoteobjects_git.bb b/recipes-qt/qt5/qtremoteobjects_git.bb
index 426a5ec6..5827785a 100644
--- a/recipes-qt/qt5/qtremoteobjects_git.bb
+++ b/recipes-qt/qt5/qtremoteobjects_git.bb
@@ -24,6 +24,6 @@ PACKAGECONFIG[tools-only] = "CONFIG+=tools-only"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "11ea1541265e3c151b83e608d7d4966cce8118db"
+SRCREV = "e978116774163e6f6f36cbe62be2d9ad797ce9d4"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtscript_git.bb b/recipes-qt/qt5/qtscript_git.bb
index e4dbb5a0..0441b9de 100644
--- a/recipes-qt/qt5/qtscript_git.bb
+++ b/recipes-qt/qt5/qtscript_git.bb
@@ -36,4 +36,4 @@ DEPENDS += "qtbase"
# http://errors.yoctoproject.org/Errors/Build/44915/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "a7d80e756397b24b20eccc4f254219914d21f30c"
+SRCREV = "98e65d35112183bb608f14b3166637ada48c041c"
diff --git a/recipes-qt/qt5/qtscxml_git.bb b/recipes-qt/qt5/qtscxml_git.bb
index a70045bb..b286c8f5 100644
--- a/recipes-qt/qt5/qtscxml_git.bb
+++ b/recipes-qt/qt5/qtscxml_git.bb
@@ -10,7 +10,7 @@ require qt5-git.inc
DEPENDS += "qtbase qtdeclarative qtxmlpatterns qtscxml-native"
-SRCREV = "2aa8d6b2544a09980dbf4d00c16a8b0cae130f97"
+SRCREV = "5b97c163b3206aca5da15e8296529734d9c00210"
# Patches from https://github.com/meta-qt5/qtscxml/commits/b5.12
# 5.12.meta-qt5.2
diff --git a/recipes-qt/qt5/qtsensors_git.bb b/recipes-qt/qt5/qtsensors_git.bb
index d8420d0d..81594e79 100644
--- a/recipes-qt/qt5/qtsensors_git.bb
+++ b/recipes-qt/qt5/qtsensors_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "9f61100a5702b47e2ae421da243959d87f476f12"
+SRCREV = "37fa5756b09afad4ad6323293a51a52cbaa5a483"
diff --git a/recipes-qt/qt5/qtserialbus_git.bb b/recipes-qt/qt5/qtserialbus_git.bb
index 00c6f9e4..3198ac0d 100644
--- a/recipes-qt/qt5/qtserialbus_git.bb
+++ b/recipes-qt/qt5/qtserialbus_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtserialport"
-SRCREV = "723990439e80d77b6a19c496d8811e8059d6bbef"
+SRCREV = "4a47ea4e53e4e245d8fbced7b1b91bde04d564d9"
diff --git a/recipes-qt/qt5/qtserialport_git.bb b/recipes-qt/qt5/qtserialport_git.bb
index 15c3a514..1b8b0435 100644
--- a/recipes-qt/qt5/qtserialport_git.bb
+++ b/recipes-qt/qt5/qtserialport_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "eb1c0764effce86ee0a7c290600be395a369d960"
+SRCREV = "c9fd06130537d751edc36a377f7a9a8425851672"
diff --git a/recipes-qt/qt5/qtsvg_git.bb b/recipes-qt/qt5/qtsvg_git.bb
index 0ace968f..d9ce08c9 100644
--- a/recipes-qt/qt5/qtsvg_git.bb
+++ b/recipes-qt/qt5/qtsvg_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "a3e50a83ab5c4804ac1b1900420fdac70e7ffbd0"
+SRCREV = "91a4369b99a551779ced748cdb6eb67f6c6f7ac5"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 5001da8f..76749b89 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -32,7 +32,7 @@ EXTRA_QMAKEVARS_PRE += " \
${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)} \
"
-SRCREV = "d170069f8f727a91fc08461344f6d3cec50f8074"
+SRCREV = "64280d563ed9dd7f61786eb3d07a368b22828aad"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qttranslations_git.bb b/recipes-qt/qt5/qttranslations_git.bb
index 3bea9cc1..cedad469 100644
--- a/recipes-qt/qt5/qttranslations_git.bb
+++ b/recipes-qt/qt5/qttranslations_git.bb
@@ -98,4 +98,4 @@ FILES_${PN}-qthelp = " \
${OE_QMAKE_PATH_TRANSLATIONS}/qt_help_*.qm \
"
-SRCREV = "cb20da70ada2ffb92a08a232ddad5b1b51ade033"
+SRCREV = "74d8329bf6bbda2b925dd8bfc816b0577254526a"
diff --git a/recipes-qt/qt5/qtvirtualkeyboard_git.bb b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
index 7b0f5332..410f089d 100644
--- a/recipes-qt/qt5/qtvirtualkeyboard_git.bb
+++ b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
@@ -71,4 +71,4 @@ FILES_${PN} += "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/lipi_toolkit"
DEPENDS += "qtbase qtdeclarative qtmultimedia qtquickcontrols qtsvg qtxmlpatterns qtdeclarative-native"
-SRCREV = "d96dde15be0fccf92d8c145205b30b67c3ec3221"
+SRCREV = "0c71f71a28d61ba376ac2241c082f8ca2262fe4e"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 561f81eb..e01cd28f 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -37,7 +37,7 @@ PACKAGECONFIG[wayland-libhybris-egl-server-buffer] = "-feature-wayland-libhybris
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "32a5e01adf346ed317bfc6d5c7f7e994099f2448"
+SRCREV = "27c3046fd9caf7d654b81cc7c8fb1d9423377bbe"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtwebchannel_git.bb b/recipes-qt/qt5/qtwebchannel_git.bb
index a7ab448b..9e41d872 100644
--- a/recipes-qt/qt5/qtwebchannel_git.bb
+++ b/recipes-qt/qt5/qtwebchannel_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative qtwebsockets"
-SRCREV = "6e6c22c6b361ebb675e3594362b9a1edcbdb83ae"
+SRCREV = "bf986e4111ed03bd157e868d33dd8f1e6fab2d0d"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index c0631a0b..d7a697a5 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -176,8 +176,8 @@ SRC_URI_append_libc-musl = "\
file://chromium/0018-chromium-musl-pread-pwrite.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "41cef6e19364d785bd77c42e45ef7ca32e601410"
-SRCREV_chromium = "5ca6ac0f951adec1f816b42f1c862d699e56a645"
+SRCREV_qtwebengine = "175b8129d1b0e6d9372de8ce9e1b45ab49fef336"
+SRCREV_chromium = "7483e059d887136a989185d6056ccb79cf4ddd19"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"
diff --git a/recipes-qt/qt5/qtwebglplugin_git.bb b/recipes-qt/qt5/qtwebglplugin_git.bb
index 0d85a507..b76eb48d 100644
--- a/recipes-qt/qt5/qtwebglplugin_git.bb
+++ b/recipes-qt/qt5/qtwebglplugin_git.bb
@@ -18,4 +18,4 @@ do_configure_prepend() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtdeclarative', 'CONFIG+=OE_QTDECLARATIVE_ENABLED', '', d)}"
-SRCREV = "181201db91595a9a79b742a873360be3e3dd6f8b"
+SRCREV = "07074154be0733ca678d0ce684e8f0cfd4925462"
diff --git a/recipes-qt/qt5/qtwebsockets_git.bb b/recipes-qt/qt5/qtwebsockets_git.bb
index e53547d8..13aaa3cb 100644
--- a/recipes-qt/qt5/qtwebsockets_git.bb
+++ b/recipes-qt/qt5/qtwebsockets_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "c071c4528e48ceee72aeb00ab533e4db383502a0"
+SRCREV = "051a396183f7313d15ad444f9ece4b96fb8995d2"
diff --git a/recipes-qt/qt5/qtwebview_git.bb b/recipes-qt/qt5/qtwebview_git.bb
index 1744372e..1d28668d 100644
--- a/recipes-qt/qt5/qtwebview_git.bb
+++ b/recipes-qt/qt5/qtwebview_git.bb
@@ -19,4 +19,4 @@ COMPATIBLE_MACHINE_armv7a = "(.*)"
COMPATIBLE_MACHINE_armv7ve = "(.*)"
COMPATIBLE_MACHINE_aarch64 = "(.*)"
-SRCREV = "f2646867e21c95e4f648663f390828aeec898091"
+SRCREV = "30edb647a64542c0f4432bd3909e3b6ae5ddcd51"
diff --git a/recipes-qt/qt5/qtx11extras_git.bb b/recipes-qt/qt5/qtx11extras_git.bb
index 4881b2bd..e3092683 100644
--- a/recipes-qt/qt5/qtx11extras_git.bb
+++ b/recipes-qt/qt5/qtx11extras_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "5dada3edf48e5ea23541af75cc4d665787f7f188"
+SRCREV = "40b30b47188c20c6b64e6d0fe29f82a653836789"
diff --git a/recipes-qt/qt5/qtxmlpatterns_git.bb b/recipes-qt/qt5/qtxmlpatterns_git.bb
index d34744d8..57057e11 100644
--- a/recipes-qt/qt5/qtxmlpatterns_git.bb
+++ b/recipes-qt/qt5/qtxmlpatterns_git.bb
@@ -25,7 +25,7 @@ do_configure_prepend() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtdeclarative', 'CONFIG+=OE_QTDECLARATIVE_ENABLED', '', d)}"
-SRCREV = "50ef7981cada5be13ca836a0237fc060f8403a88"
+SRCREV = "9a88ab0974c7beaadacc1865f53ea526049c6227"
BBCLASSEXTEND =+ "native nativesdk"