aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-09-02 13:32:54 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2019-09-05 13:13:40 +0000
commitb4f9f22effea18f6ada4ea15299021c6f52caff2 (patch)
tree45e32a2c821974d3d1f8d07322d03aaca63e8032
parent2a5f9415e48a38f6f4eb0cf375737a2d8438e2fe (diff)
qtwebengine: Fix compile failure with 5.2+ kernel headers
Fixes error: 'SIOCGSTAMP' was not declared in this scope Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0007-chromium-fix-build-after-y2038-changes-in-glibc.patch31
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
2 files changed, 32 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0007-chromium-fix-build-after-y2038-changes-in-glibc.patch b/recipes-qt/qt5/qtwebengine/chromium/0007-chromium-fix-build-after-y2038-changes-in-glibc.patch
new file mode 100644
index 00000000..1e5d4e26
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/chromium/0007-chromium-fix-build-after-y2038-changes-in-glibc.patch
@@ -0,0 +1,31 @@
+From c5ae85ce82fec2333d6b8af3d1f17343fd0eb0ba Mon Sep 17 00:00:00 2001
+From: Jiri Slaby <jslaby@suse.cz>
+Date: Thu, 11 Jul 2019 09:35:13 +0200
+Subject: [PATCH] chromium: fix build after y2038 changes in glibc
+
+SIOCGSTAMP is defined in linux/sockios.h since kernel 5.2. Include that
+file wherever needed.
+
+Signed-off-by: Jiri Slaby <jslaby@suse.cz>
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+
+Upstream-Status: Submitted
+Patch-mainline: submitted on 2019/07/11
+References: QTBUG-76963
+
+---
+ chromium/third_party/webrtc/rtc_base/physicalsocketserver.cc | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/chromium/third_party/webrtc/rtc_base/physicalsocketserver.cc b/chromium/third_party/webrtc/rtc_base/physicalsocketserver.cc
+index ca78499179a..d91d17f8f00 100644
+--- a/chromium/third_party/webrtc/rtc_base/physicalsocketserver.cc
++++ b/chromium/third_party/webrtc/rtc_base/physicalsocketserver.cc
+@@ -68,6 +68,7 @@ typedef void* SockOptArg;
+ #endif // WEBRTC_POSIX
+
+ #if defined(WEBRTC_POSIX) && !defined(WEBRTC_MAC) && !defined(__native_client__)
++#include <linux/sockios.h>
+
+ int64_t GetSocketRecvTimestamp(int socket) {
+ struct timeval tv_ioctl;
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 84fcfbfb..e4e19a4b 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -156,6 +156,7 @@ SRC_URI += " \
file://chromium/0020-chromium-Check-for-__ARM_FP-2-before-using-__fp16.patch;patchdir=src/3rdparty \
file://chromium/0021-chromium-Exclude-CRC32-for-32bit-arm.patch;patchdir=src/3rdparty \
file://chromium/0022-chromium-Do-not-try-to-set-the-guessed-values-for-ma.patch;patchdir=src/3rdparty \
+ file://chromium/0007-chromium-fix-build-after-y2038-changes-in-glibc.patch;patchdir=src/3rdparty \
"
SRC_URI_append_libc-musl = "\