aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2017-12-01 12:12:43 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2017-12-01 13:17:52 +0000
commitafe5e7e6424037aee86f8a94971e968d9cbb9282 (patch)
treea8999681ef3b781107999799d2887b4dc6658c71
parentf2275de5433224cec21b0257437b612bfa889446 (diff)
qt5: update submodules to 5.10.0 RC3v5.10.0
Change-Id: I9b94b012ac53db65aae076ff2618d435e74471f2 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine/0002-chromium-Force-host-toolchain-configuration.patch25
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb2
6 files changed, 14 insertions, 21 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index f6056b91..9f3216a2 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -197,4 +197,4 @@ fakeroot do_generate_qt_environment_file() {
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "984ad6124992c9831f57c2776aa2ed0a760149e6"
+SRCREV = "50117d738af526cbfbd5afa50b9a501acb0fb9ce"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 944ba0b5..4c6b7015 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -131,4 +131,4 @@ do_install() {
echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
}
-SRCREV = "984ad6124992c9831f57c2776aa2ed0a760149e6"
+SRCREV = "50117d738af526cbfbd5afa50b9a501acb0fb9ce"
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index d9ba1a4c..161d5cef 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -228,4 +228,4 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps"
RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}"
-SRCREV = "984ad6124992c9831f57c2776aa2ed0a760149e6"
+SRCREV = "50117d738af526cbfbd5afa50b9a501acb0fb9ce"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 001d80ad..facb4485 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -30,6 +30,6 @@ do_install_append_class-nativesdk() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}"
-SRCREV = "cc46992fbb94f1775ac22aa23b42d76f810a5913"
+SRCREV = "dac71f3d6f6bc4f159f6107c792bc70cfe7c308e"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtwebengine/0002-chromium-Force-host-toolchain-configuration.patch b/recipes-qt/qt5/qtwebengine/0002-chromium-Force-host-toolchain-configuration.patch
index 4a1a975f..3b24e064 100644
--- a/recipes-qt/qt5/qtwebengine/0002-chromium-Force-host-toolchain-configuration.patch
+++ b/recipes-qt/qt5/qtwebengine/0002-chromium-Force-host-toolchain-configuration.patch
@@ -1,4 +1,4 @@
-From a0b1a742813d0846472fab4aada2388bf2d42d80 Mon Sep 17 00:00:00 2001
+From 5616656eb6d7423aaea107513209dac88c79d916 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Wed, 15 Mar 2017 13:53:28 +0200
Subject: [PATCH] chromium: Force host toolchain configuration
@@ -10,16 +10,16 @@ Upstream-Status: Inappropriate [OE specific]
Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
---
- chromium/tools/gn/bootstrap/bootstrap.py | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
+ chromium/tools/gn/bootstrap/bootstrap.py | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/chromium/tools/gn/bootstrap/bootstrap.py b/chromium/tools/gn/bootstrap/bootstrap.py
-index 43d252b43e..e58347848e 100755
+index b1ff7e7..bccabbb 100755
--- a/chromium/tools/gn/bootstrap/bootstrap.py
+++ b/chromium/tools/gn/bootstrap/bootstrap.py
-@@ -298,14 +298,14 @@ def write_gn_ninja(path, root_gen_dir, options):
- ld = os.environ.get('LD', 'link.exe')
- ar = os.environ.get('AR', 'lib.exe')
+@@ -318,10 +318,10 @@ def write_gn_ninja(path, root_gen_dir, options):
+ ld = os.environ.get('LD', cxx)
+ ar = os.environ.get('AR', 'ar -X64')
else:
- cc = os.environ.get('CC', 'cc')
- cxx = os.environ.get('CXX', 'c++')
@@ -29,12 +29,5 @@ index 43d252b43e..e58347848e 100755
- ar = os.environ.get('AR', 'ar')
+ ar = os.environ.get('AR_host', 'ar')
-- cflags = os.environ.get('CFLAGS', '').split()
-- cflags_cc = os.environ.get('CXXFLAGS', '').split()
-- ldflags = os.environ.get('LDFLAGS', '').split()
-+ cflags = os.environ.get('CFLAGS_host', '').split()
-+ cflags_cc = os.environ.get('CXXFLAGS_host', '').split()
-+ ldflags = os.environ.get('LDFLAGS_host', '').split()
- include_dirs = [root_gen_dir, SRC_ROOT]
- libs = []
-
+ # QTBUG-64759
+ # cflags = os.environ.get('CFLAGS', '').split()
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 2bb52535..38e97b15 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -155,7 +155,7 @@ SRC_URI_append_libc-musl = "\
"
SRCREV_qtwebengine = "efa6d3f0d3a01753dd40823ce119e7d4f9765c8e"
-SRCREV_chromium = "2366767e6c6f333ef090667aa6838d6781725a78"
+SRCREV_chromium = "e36dcec23b79a52fd7794ed2fad49bbf65a8146b"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"