aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2017-12-19 12:20:05 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2017-12-21 09:01:25 +0000
commit5d320ab6ecde34725ceef536f9d9229fb2125acf (patch)
treecaf6b496d7b30a7d0cdc3797eedca822d310bd6c
parent479384fc4beeb291a971b3f16731ba5c18a00319 (diff)
qt5: update submodules
Update Qt submodules to latest in 5.10 branch Task-number: QTBUG-65164 Change-Id: I76d7edef0bd12d9ccabdc9d60a3e0f8323d28b26 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qt3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb4
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols2_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols_git.bb2
-rw-r--r--recipes-qt/qt5/qtscript_git.bb2
-rw-r--r--recipes-qt/qt5/qtsensors_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialbus_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialport_git.bb2
-rw-r--r--recipes-qt/qt5/qtsvg_git.bb2
-rw-r--r--recipes-qt/qt5/qttools_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb4
-rw-r--r--recipes-qt/qt5/qtx11extras_git.bb2
-rw-r--r--recipes-qt/qt5/qtxmlpatterns_git.bb2
20 files changed, 22 insertions, 22 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index e36de716..972696dc 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -197,4 +197,4 @@ fakeroot do_generate_qt_environment_file() {
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "812bb236dd1622896b6a0ca9bbe1334a69855aa2"
+SRCREV = "ca181d3740c4251ef945625cbb6e235479b56bcd"
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index f505ad7e..3264219a 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -37,6 +37,6 @@ do_configure_prepend() {
${S}/src/quick3d/imports/input/importsinput.pro
}
-SRCREV = "8470becd886d299c1be892d8113dfff216035611"
+SRCREV = "24e8db22e50449b30fac6619d074b98f08ff0315"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 97c57cf6..26613364 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -131,4 +131,4 @@ do_install() {
echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
}
-SRCREV = "812bb236dd1622896b6a0ca9bbe1334a69855aa2"
+SRCREV = "ca181d3740c4251ef945625cbb6e235479b56bcd"
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index bc029c8c..5671e96c 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -228,4 +228,4 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps"
RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}"
-SRCREV = "812bb236dd1622896b6a0ca9bbe1334a69855aa2"
+SRCREV = "ca181d3740c4251ef945625cbb6e235479b56bcd"
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index 4b7fe3d5..8c7d28f2 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -19,4 +19,4 @@ PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,${BLUEZ}"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "cf0df8be7f4cc809672f98507c1723015a0741bc"
+SRCREV = "1d8ba3610ae36dd62fda88dcf7c81baa5fe1fc51"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 75186f12..471c2e39 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -30,6 +30,6 @@ do_install_append_class-nativesdk() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}"
-SRCREV = "8283bc83857ed8c7d85b61d2dc3b35fa4e96a037"
+SRCREV = "4fff2bb14e55484eacec0a1b49a2b02958f75eca"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index 1e5ffc20..e2e42d8b 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -29,7 +29,7 @@ SRC_URI += " \
${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=upstream/qt-staging;protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \
"
-SRCREV_qtlocation = "b2e0a242a8c77d8cff186ef25b8360927c955941"
-SRCREV_qtlocation-mapboxgl = "572822c8ca15be190b43afbf7f91d132e988bf21"
+SRCREV_qtlocation = "337aea7bc386d5e97825d27335d860fc88b2bee3"
+SRCREV_qtlocation-mapboxgl = "8c1be4ec01ef46bf453856531ebf53b48ce3dbe7"
SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index a8a7421e..3b77d886 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -35,4 +35,4 @@ SRC_URI += "\
# http://errors.yoctoproject.org/Errors/Build/44914/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "10304528c20fb9a385c617a38b6be35d1b18598a"
+SRCREV = "1083ed94683c3356f9ee19210cfe9b0dd53e4815"
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb
index 648fd607..2619cadd 100644
--- a/recipes-qt/qt5/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols2_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative"
-SRCREV = "eb7551d5d5e5155606e21158ead1541546bc2149"
+SRCREV = "6767d789b3544c6ff7717250e1c0dee02ad91fd4"
diff --git a/recipes-qt/qt5/qtquickcontrols_git.bb b/recipes-qt/qt5/qtquickcontrols_git.bb
index ecbf7dbf..32091e17 100644
--- a/recipes-qt/qt5/qtquickcontrols_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols_git.bb
@@ -26,4 +26,4 @@ SRC_URI += " \
file://0001-texteditor-fix-invalid-use-of-incomplete-type-class-.patch \
"
-SRCREV = "5bc4310529a8ae5cfc18afda1a1b788691448d6e"
+SRCREV = "65976402344a2642d6d6dc5bfbf71b3b511f6d12"
diff --git a/recipes-qt/qt5/qtscript_git.bb b/recipes-qt/qt5/qtscript_git.bb
index 5d323155..1081d0c9 100644
--- a/recipes-qt/qt5/qtscript_git.bb
+++ b/recipes-qt/qt5/qtscript_git.bb
@@ -30,4 +30,4 @@ DEPENDS += "qtbase"
# http://errors.yoctoproject.org/Errors/Build/44915/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "0bb3f3017f72cbf8d6866b8baa1820ab3dd89316"
+SRCREV = "34784015a96c204633bad5ed86056eee2d32c22f"
diff --git a/recipes-qt/qt5/qtsensors_git.bb b/recipes-qt/qt5/qtsensors_git.bb
index dcaf381c..d3df2999 100644
--- a/recipes-qt/qt5/qtsensors_git.bb
+++ b/recipes-qt/qt5/qtsensors_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "af1372a4e69d5a7664142df06b0b96d7cd197340"
+SRCREV = "bfe35b4ebc4ac46fd181b36d35e6535064f4e056"
diff --git a/recipes-qt/qt5/qtserialbus_git.bb b/recipes-qt/qt5/qtserialbus_git.bb
index cd0f2d73..e6d2e112 100644
--- a/recipes-qt/qt5/qtserialbus_git.bb
+++ b/recipes-qt/qt5/qtserialbus_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtserialport"
-SRCREV = "e13737e5de8d3a2653e97de365412c28bd6c6124"
+SRCREV = "557a7cb8c2b053a67d8dc55f7433f2db2286852b"
diff --git a/recipes-qt/qt5/qtserialport_git.bb b/recipes-qt/qt5/qtserialport_git.bb
index ee0dd263..d02e82c0 100644
--- a/recipes-qt/qt5/qtserialport_git.bb
+++ b/recipes-qt/qt5/qtserialport_git.bb
@@ -15,4 +15,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "98454fbc2a687a6440ae5e61070ebd6073e8016d"
+SRCREV = "c38dcc1118746a0a16405764a707ffc19dda362a"
diff --git a/recipes-qt/qt5/qtsvg_git.bb b/recipes-qt/qt5/qtsvg_git.bb
index 3d0a372c..b92cf597 100644
--- a/recipes-qt/qt5/qtsvg_git.bb
+++ b/recipes-qt/qt5/qtsvg_git.bb
@@ -13,4 +13,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "984ba6977201f8fbd94d44a2b67519e1faf458cc"
+SRCREV = "b3ce191284221a384d04fd8a3d6eb152f84fd192"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index ac408da2..24637337 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -31,7 +31,7 @@ PACKAGECONFIG[qtwebkit] = ",,qtwebkit"
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)}"
-SRCREV = "84e40c5f4d78a6d4a0ae1d87323a20ed96f319d6"
+SRCREV = "e6a65cdb85edc4710017c33d4966425d852f0e47"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 624a2a2a..4a7a9e47 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -37,7 +37,7 @@ PACKAGECONFIG[libhybris-egl-server] = "-feature-libhybris-egl-server,-no-feature
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "61f92b6742c96f4974e23893ba6926e4d012cd09"
+SRCREV = "98f38b01997ec59aa5040f839deb6f062f01be17"
# Patches from https://github.com/meta-qt5/qtwayland/commits/b5.9
# 5.9.meta-qt5.2
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index a81ec1e3..5b4a02c8 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -154,8 +154,8 @@ SRC_URI_append_libc-musl = "\
file://0016-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "6921ebd6d8bc8bb62d9118c7a1a750f2fd787897"
-SRCREV_chromium = "4368c7380883fd6b32d913d27a5b8f51f615068d"
+SRCREV_qtwebengine = "78cc35d0705ef9f7b3e7785f031f77595ed71217"
+SRCREV_chromium = "224acc295777ea2cf642842cebbd6df86ad2c888"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"
diff --git a/recipes-qt/qt5/qtx11extras_git.bb b/recipes-qt/qt5/qtx11extras_git.bb
index 99283358..f1c0afc6 100644
--- a/recipes-qt/qt5/qtx11extras_git.bb
+++ b/recipes-qt/qt5/qtx11extras_git.bb
@@ -13,4 +13,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "8e4810cf73a4294eacafede22f93f4bda8dab1bf"
+SRCREV = "5a42fb1b13a9ac91a6a078dc6d63dbbd5d87836e"
diff --git a/recipes-qt/qt5/qtxmlpatterns_git.bb b/recipes-qt/qt5/qtxmlpatterns_git.bb
index b479b320..e83ecb6c 100644
--- a/recipes-qt/qt5/qtxmlpatterns_git.bb
+++ b/recipes-qt/qt5/qtxmlpatterns_git.bb
@@ -18,7 +18,7 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "3cd6679d8702fef3f0d3614724375577945fcf05"
+SRCREV = "bc5129b8868891742356114ab05c6ac254fc07cd"
BBCLASSEXTEND =+ "native nativesdk"