aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-11-21 13:37:43 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2017-11-23 08:51:04 +0000
commite015edf046a88ca13dd603265f71a6e05662db72 (patch)
treef583c5c28c49a5a20c8be2d55e8a7c126ed8f1d4
parentaf9c256fc4e99ec4692b4b95bffa85018bd8c767 (diff)
qtwebengine: update to 61-based chromium
Change-Id: I6f7f023a6517a5813c5243417207f9c872f07ecf Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io> Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--recipes-qt/qt5/qtwebengine/0001-Build-accessibility-tests-only-when-Qt-is-configured.patch41
-rw-r--r--recipes-qt/qt5/qtwebengine/0001-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch63
-rw-r--r--recipes-qt/qt5/qtwebengine/0001-functions.prf-allow-build-for-linux-oe-g-platform.patch30
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb9
4 files changed, 3 insertions, 140 deletions
diff --git a/recipes-qt/qt5/qtwebengine/0001-Build-accessibility-tests-only-when-Qt-is-configured.patch b/recipes-qt/qt5/qtwebengine/0001-Build-accessibility-tests-only-when-Qt-is-configured.patch
deleted file mode 100644
index a5fb1d84..00000000
--- a/recipes-qt/qt5/qtwebengine/0001-Build-accessibility-tests-only-when-Qt-is-configured.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 4649f2a11fe4b87e9b79f50ff8ac99ba9a2344f4 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Michael=20Br=C3=BCning?= <michael.bruning@qt.io>
-Date: Wed, 25 Oct 2017 09:47:47 +0200
-Subject: [PATCH] Build accessibility tests only when Qt is configured with
- accessibility
-
-Original patch by Daniel Mack <daniel@zonque.org>
-
-Task-number: QTBUG-64015
-Change-Id: I7dd0a1aa9bff08c6d19e818acf0e1b8b4b701f5b
-Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
----
- tests/auto/widgets/widgets.pro | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/tests/auto/widgets/widgets.pro b/tests/auto/widgets/widgets.pro
-index 441eea0..7bab18f 100644
---- a/tests/auto/widgets/widgets.pro
-+++ b/tests/auto/widgets/widgets.pro
-@@ -1,7 +1,6 @@
- TEMPLATE = subdirs
-
- SUBDIRS += \
-- qwebengineaccessibility \
- qwebenginedefaultsurfaceformat \
- qwebenginedownloads \
- qwebenginefaviconmanager \
-@@ -14,6 +13,10 @@ SUBDIRS += \
- qwebenginesettings \
- qwebengineview
-
-+qtConfig(accessibility) {
-+ SUBDIRS += qwebengineaccessibility
-+}
-+
- contains(WEBENGINE_CONFIG, use_spellchecker):!cross_compile {
- !contains(WEBENGINE_CONFIG, use_native_spellchecker) {
- SUBDIRS += qwebenginespellcheck
---
-2.7.4
-
diff --git a/recipes-qt/qt5/qtwebengine/0001-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch b/recipes-qt/qt5/qtwebengine/0001-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch
deleted file mode 100644
index 0e9ea724..00000000
--- a/recipes-qt/qt5/qtwebengine/0001-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch
+++ /dev/null
@@ -1,63 +0,0 @@
-From d559da6ab0834aeb7307008015b6232e586fea00 Mon Sep 17 00:00:00 2001
-From: Cleiton Bueno <cleitonrbueno@gmail.com>
-Date: Thu, 24 Dec 2015 12:46:58 -0200
-Subject: [PATCH] chromium: Change false to FALSE and 1 to TRUE, FIX
- qtwebengine compile
-
-Signed-off-by: Cleiton Bueno <cleitonrbueno@gmail.com>
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
----
- chromium/ui/gfx/codec/jpeg_codec.cc | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/chromium/ui/gfx/codec/jpeg_codec.cc b/chromium/ui/gfx/codec/jpeg_codec.cc
-index 6d926378be..738d3fdedf 100644
---- a/chromium/ui/gfx/codec/jpeg_codec.cc
-+++ b/chromium/ui/gfx/codec/jpeg_codec.cc
-@@ -121,7 +121,7 @@ boolean EmptyOutputBuffer(jpeg_compress_struct* cinfo) {
- // tell libjpeg where to write the next data
- cinfo->dest->next_output_byte = &(*state->out)[state->image_buffer_used];
- cinfo->dest->free_in_buffer = state->out->size() - state->image_buffer_used;
-- return 1;
-+ return TRUE;
- }
-
- // Cleans up the JpegEncoderState to prepare for returning in the final form.
-@@ -262,7 +262,7 @@ bool JPEGCodec::Encode(const unsigned char* input, ColorFormat format,
- cinfo.data_precision = 8;
-
- jpeg_set_defaults(&cinfo);
-- jpeg_set_quality(&cinfo, quality, 1); // quality here is 0-100
-+ jpeg_set_quality(&cinfo, quality, TRUE); // quality here is 0-100
-
- // set up the destination manager
- jpeg_destination_mgr destmgr;
-@@ -274,7 +274,7 @@ bool JPEGCodec::Encode(const unsigned char* input, ColorFormat format,
- JpegEncoderState state(output);
- cinfo.client_data = &state;
-
-- jpeg_start_compress(&cinfo, 1);
-+ jpeg_start_compress(&cinfo, TRUE);
-
- // feed it the rows, doing necessary conversions for the color format
- #ifdef JCS_EXTENSIONS
-@@ -360,7 +360,7 @@ void InitSource(j_decompress_ptr cinfo) {
- // set to a positive value if TRUE is returned. A FALSE return should only
- // be used when I/O suspension is desired."
- boolean FillInputBuffer(j_decompress_ptr cinfo) {
-- return false;
-+ return FALSE;
- }
-
- // Skip data in the buffer. Since we have all the data at once, this operation
-@@ -488,8 +488,8 @@ bool JPEGCodec::Decode(const unsigned char* input, size_t input_size,
- cinfo.client_data = &state;
-
- // fill the file metadata into our buffer
-- if (jpeg_read_header(&cinfo, true) != JPEG_HEADER_OK)
-- return false;
-+ if (jpeg_read_header(&cinfo, TRUE) != JPEG_HEADER_OK)
-+ return FALSE;
-
- // we want to always get RGB data out
- switch (cinfo.jpeg_color_space) {
diff --git a/recipes-qt/qt5/qtwebengine/0001-functions.prf-allow-build-for-linux-oe-g-platform.patch b/recipes-qt/qt5/qtwebengine/0001-functions.prf-allow-build-for-linux-oe-g-platform.patch
deleted file mode 100644
index 275ef9e8..00000000
--- a/recipes-qt/qt5/qtwebengine/0001-functions.prf-allow-build-for-linux-oe-g-platform.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 96746f09947cc36f6c9fc8631bc6a6e7f59efe24 Mon Sep 17 00:00:00 2001
-From: Frieder Schrempf <frieder.schrempf@online.de>
-Date: Mon, 1 Dec 2014 14:34:40 +0000
-Subject: [PATCH] functions.prf: allow build for linux-oe-g++ platform
-
-Upstream-Status: Inappropriate [OE specific]
-
-Signed-off-by: Frieder Schrempf <frieder.schrempf@online.de>
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
----
- mkspecs/features/functions.prf | 6 ++++++
- 1 file changed, 6 insertions(+)
-
-diff --git a/mkspecs/features/functions.prf b/mkspecs/features/functions.prf
-index 56894e58..ef418a4c 100644
---- a/mkspecs/features/functions.prf
-+++ b/mkspecs/features/functions.prf
-@@ -21,6 +21,12 @@ defineTest(isPlatformSupported) {
- return(false)
- }
- gcc:!clang:!isGCCVersionSupported(): return(false)
-+ } else:linux-oe-g++* {
-+ !gcc:!clang {
-+ skipBuild("Qt WebEngine on Linux requires clang or GCC.")
-+ return(false)
-+ }
-+ gcc:!clang:!isGCCVersionSupported(): return(false)
- } else:win32 {
- winrt {
- skipBuild("WinRT is not supported.")
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index f6318e15..f3c7c142 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -120,14 +120,12 @@ RDEPENDS_${PN}-examples += " \
qtdeclarative-qmlplugins \
"
-QT_MODULE_BRANCH_CHROMIUM = "58-based"
+QT_MODULE_BRANCH_CHROMIUM = "61-based"
# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.9
# 5.9.meta-qt5.3
SRC_URI += " \
${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \
- file://0001-functions.prf-allow-build-for-linux-oe-g-platform.patch \
- file://0001-Build-accessibility-tests-only-when-Qt-is-configured.patch \
file://0002-WebEngine-qquickwebengineview_p_p.h-add-include-QCol.patch \
file://0003-Include-dependency-to-QCoreApplication-translate.patch \
file://0004-Force-host-toolchain-configuration.patch \
@@ -136,7 +134,6 @@ SRC_URI += " \
# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/56-based
# 56-based.meta-qt5.2
SRC_URI += " \
- file://0001-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch;patchdir=src/3rdparty \
file://0002-chromium-Force-host-toolchain-configuration.patch;patchdir=src/3rdparty \
file://0003-chromium-workaround-for-too-long-.rps-file-name.patch;patchdir=src/3rdparty \
"
@@ -157,8 +154,8 @@ SRC_URI_append_libc-musl = "\
file://0016-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "f32b3514a5186bc4f5452f004324bdb7782d30a3"
-SRCREV_chromium = "582c5493439ba9ac57c6c14c706f530741f5bfc8"
+SRCREV_qtwebengine = "5617373d9b5ded9d4c724b15132d6989ed9e05f9"
+SRCREV_chromium = "2366767e6c6f333ef090667aa6838d6781725a78"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"