aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-01-25 15:36:46 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2018-02-12 06:58:59 +0000
commit50c4963980164ae0e9992d652fd934d85fd2400e (patch)
tree2e1a1beb461e4ea3b793e87ee0d1583273eb20fa
parentc907a6caee05b559ee231300a228f88708f9b7c2 (diff)
qt5: Upgrade to Qt 5.11.0
QtQuickCompiler functionality is now integrated to qtdeclarative and can be enabled with CONFIG+=qtquickcompiler. Add PACKAGECONFIG to qt5.inc, so that any qtmodule can take advantage of this. Enable by default for qtcharts and qtvirtualkeyboard. Change-Id: I484b4b6c7869b3ca5630ef9685453aecc626137a Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--recipes-connectivity/libqofono/libqofono_git.bb2
-rw-r--r--recipes-qt/examples/qt5everywheredemo_1.0.bb2
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb11
-rw-r--r--recipes-qt/qt5/qt3d_git.bb2
-rw-r--r--recipes-qt/qt5/qt5-git.inc4
-rw-r--r--recipes-qt/qt5/qt5.inc2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb3
-rw-r--r--recipes-qt/qt5/qtbase_git.bb7
-rw-r--r--recipes-qt/qt5/qtcanvas3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtcharts_git.bb4
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
-rw-r--r--recipes-qt/qt5/qtdatavis3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb6
-rw-r--r--recipes-qt/qt5/qtgamepad_git.bb2
-rw-r--r--recipes-qt/qt5/qtgraphicaleffects_git.bb4
-rw-r--r--recipes-qt/qt5/qtimageformats_git.bb2
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb8
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtnetworkauth_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols2_git.bb4
-rw-r--r--recipes-qt/qt5/qtquickcontrols_git.bb4
-rw-r--r--recipes-qt/qt5/qtremoteobjects_git.bb2
-rw-r--r--recipes-qt/qt5/qtscript_git.bb10
-rw-r--r--recipes-qt/qt5/qtscxml_git.bb2
-rw-r--r--recipes-qt/qt5/qtsensors_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialbus_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialport_git.bb7
-rw-r--r--recipes-qt/qt5/qtsvg_git.bb2
-rw-r--r--recipes-qt/qt5/qttools_git.bb2
-rw-r--r--recipes-qt/qt5/qttranslations_git.bb2
-rw-r--r--recipes-qt/qt5/qtvirtualkeyboard_git.bb6
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebchannel_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine/0001-Ignore-PKG_CONFIG-shell-exports-for-Yocto.patch36
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb7
-rw-r--r--recipes-qt/qt5/qtwebsockets_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebview_git.bb2
-rw-r--r--recipes-qt/qt5/qtx11extras_git.bb2
-rw-r--r--recipes-qt/qt5/qtxmlpatterns_git.bb2
39 files changed, 104 insertions, 65 deletions
diff --git a/recipes-connectivity/libqofono/libqofono_git.bb b/recipes-connectivity/libqofono/libqofono_git.bb
index 18e9b8fd..c0859852 100644
--- a/recipes-connectivity/libqofono/libqofono_git.bb
+++ b/recipes-connectivity/libqofono/libqofono_git.bb
@@ -3,7 +3,7 @@ SECTION = "libs"
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
-DEPENDS += "qtbase qtdeclarative"
+DEPENDS += "qtbase qtxmlpatterns qtdeclarative"
SRCREV = "6916cd030b05f0bd137ea9b669fee48f20c19084"
SRC_URI = "git://git.merproject.org/mer-core/libqofono.git"
diff --git a/recipes-qt/examples/qt5everywheredemo_1.0.bb b/recipes-qt/examples/qt5everywheredemo_1.0.bb
index ee947991..dfbe4aed 100644
--- a/recipes-qt/examples/qt5everywheredemo_1.0.bb
+++ b/recipes-qt/examples/qt5everywheredemo_1.0.bb
@@ -4,7 +4,7 @@ LICENSE = "BSD"
HOMEPAGE = "https://qt.gitorious.org/qt-labs"
LIC_FILES_CHKSUM = "file://qml/QtDemo/main.qml;endline=39;md5=7d80863906a4bc8ffca77fd869e335a9"
-DEPENDS = "qtdeclarative qtgraphicaleffects qtsvg qtmultimedia"
+DEPENDS = "qtdeclarative qtxmlpatterns qtgraphicaleffects qtsvg qtmultimedia"
SRCREV = "35d72a2eba7456a2efc5eb8b77afbc00f69ba0ac"
SRC_URI = "${QT_LABS_GIT}/qt-labs-qt5-everywhere-demo"
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 1214c435..99fa96dc 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -122,7 +122,6 @@ do_configure() {
-no-accessibility \
-no-cups \
-no-gui \
- -no-qml-debug \
-no-sql-mysql \
-no-sql-sqlite \
-no-opengl \
@@ -175,11 +174,9 @@ do_install() {
install -m 644 ${WORKDIR}/OEQt5Toolchain.cmake ${D}${datadir}/cmake/OEToolchainConfig.cmake.d/
# Fix up absolute paths in scripts
- grep -lr /usr/bin/python ${D}${OE_QMAKE_PATH_QT_ARCHDATA}/ | \
- xargs -r sed -i -e '1s,#!.*python,#! ${USRBINPATH}/env python,'
-}
+ sed -i -e '1s,#!/usr/bin/python,#! ${USRBINPATH}/env python,' \
+ ${D}${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs/features/uikit/devices.py
-fakeroot do_generate_qt_environment_file() {
mkdir -p ${D}${SDKPATHNATIVE}/environment-setup.d/
script=${D}${SDKPATHNATIVE}/environment-setup.d/qt5.sh
@@ -208,6 +205,4 @@ fakeroot do_generate_qt_environment_file() {
sed -i -e 's:${SDKPATHNATIVE}:$OECORE_NATIVE_SYSROOT:g' $script
}
-addtask generate_qt_environment_file after do_install before do_package
-
-SRCREV = "41cdfbe3a473a4f691c193a58206d860cb9c676d"
+SRCREV = "2cb1db64370989fffeec313c196fe573c479e6aa"
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index 82421683..e7c4c9af 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -37,6 +37,6 @@ do_configure_prepend() {
${S}/src/quick3d/imports/input/importsinput.pro
}
-SRCREV = "6b662b93048ee29d6684010cee7e59e9c4248bd1"
+SRCREV = "c8a48a9a28889598cb2a06fc8d5deb9b803509ca"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qt5-git.inc b/recipes-qt/qt5/qt5-git.inc
index 7ee06438..94f2bfbc 100644
--- a/recipes-qt/qt5/qt5-git.inc
+++ b/recipes-qt/qt5/qt5-git.inc
@@ -2,7 +2,7 @@
# Copyright (C) 2013-2017 Martin Jansa <martin.jansa@gmail.com>
QT_MODULE ?= "${BPN}"
-QT_MODULE_BRANCH ?= "5.10"
+QT_MODULE_BRANCH ?= "5.11"
QT_MODULE_BRANCH_PARAM ?= "branch=${QT_MODULE_BRANCH};nobranch=1"
# each module needs to define valid SRCREV
@@ -14,4 +14,4 @@ CVE_PRODUCT = "qt"
S = "${WORKDIR}/git"
-PV = "5.10.1+git${SRCPV}"
+PV = "5.11.0+git${SRCPV}"
diff --git a/recipes-qt/qt5/qt5.inc b/recipes-qt/qt5/qt5.inc
index 95e3854c..b17feaa4 100644
--- a/recipes-qt/qt5/qt5.inc
+++ b/recipes-qt/qt5/qt5.inc
@@ -7,8 +7,10 @@ PACKAGECONFIG_OPENSSL ?= "openssl"
PACKAGECONFIG[examples] = ""
PACKAGECONFIG[tests] = ""
+PACKAGECONFIG[qtquickcompiler] = ""
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'examples', 'QT_BUILD_PARTS+=examples', '', d)}"
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'tests', 'QT_BUILD_PARTS+=tests', '', d)}"
+EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtquickcompiler', 'CONFIG+=qtquickcompiler', '', d)}"
# we don't want conflicts with qt4
OE_QMAKE_PATH_HEADERS = "${OE_QMAKE_PATH_QT_HEADERS}"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 7cf4c8f6..96ed7255 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -64,7 +64,6 @@ PACKAGECONFIG_CONFARGS = " \
-no-accessibility \
-no-cups \
-no-gui \
- -no-qml-debug \
-no-sql-mysql \
-no-sql-sqlite \
-no-opengl \
@@ -136,4 +135,4 @@ do_install() {
echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
}
-SRCREV = "41cdfbe3a473a4f691c193a58206d860cb9c676d"
+SRCREV = "2cb1db64370989fffeec313c196fe573c479e6aa"
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 441af9c2..bbfcc9d7 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -87,7 +87,6 @@ PACKAGECONFIG ?= " \
PACKAGECONFIG[release] = "-release,-debug"
PACKAGECONFIG[debug] = ""
PACKAGECONFIG[developer] = "-developer-build"
-PACKAGECONFIG[qml-debug] = "-qml-debug,-no-qml-debug"
PACKAGECONFIG[sm] = "-sm,-no-sm"
PACKAGECONFIG[tests] = "-make tests,-nomake tests"
PACKAGECONFIG[examples] = "-make examples -compile-examples,-nomake examples"
@@ -233,6 +232,10 @@ do_install_append() {
echo "isEmpty(QMAKE_STRIP): QMAKE_STRIP = ${TARGET_PREFIX}strip" >> $conf
generate_target_qt_config_file ${D}${OE_QMAKE_PATH_BINS}/qt.conf
+
+ # Fix up absolute paths in scripts
+ sed -i -e '1s,#!/usr/bin/python,#! ${USRBINPATH}/env python,' \
+ ${D}${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs/features/uikit/devices.py
}
# mkspecs have mac specific scripts that depend on perl and bash
@@ -240,4 +243,4 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps"
RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}"
-SRCREV = "41cdfbe3a473a4f691c193a58206d860cb9c676d"
+SRCREV = "2cb1db64370989fffeec313c196fe573c479e6aa"
diff --git a/recipes-qt/qt5/qtcanvas3d_git.bb b/recipes-qt/qt5/qtcanvas3d_git.bb
index 13d75669..7174bf53 100644
--- a/recipes-qt/qt5/qtcanvas3d_git.bb
+++ b/recipes-qt/qt5/qtcanvas3d_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS = "qtdeclarative"
-SRCREV = "b742b8f1b654bd185244973f7bae60da951d41a4"
+SRCREV = "b3d1613d1c2eb2f942336c27b4e760e45f18c7c5"
diff --git a/recipes-qt/qt5/qtcharts_git.bb b/recipes-qt/qt5/qtcharts_git.bb
index 3afd33ea..6ea51fba 100644
--- a/recipes-qt/qt5/qtcharts_git.bb
+++ b/recipes-qt/qt5/qtcharts_git.bb
@@ -8,8 +8,10 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia"
-SRCREV = "175d864fbb96ed64cc609fe08df4b28668368040"
+SRCREV = "c844c1e5bde966c50a41d43c942b806d5c2f251e"
# The same issue as in qtbase:
# http://errors.yoctoproject.org/Errors/Details/152641/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
+
+PACKAGECONFIG ?= "qtquickcompiler"
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index 681fd05c..ae675d68 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -19,4 +19,4 @@ PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,${BLUEZ}"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "b274a83bf4f44d0e2642a8e3bd6bada4ccdbf83c"
+SRCREV = "1d9d30a75a1c13851a9f050d7ce4f8057c4fa9fb"
diff --git a/recipes-qt/qt5/qtdatavis3d_git.bb b/recipes-qt/qt5/qtdatavis3d_git.bb
index 249f8f06..ce4a815e 100644
--- a/recipes-qt/qt5/qtdatavis3d_git.bb
+++ b/recipes-qt/qt5/qtdatavis3d_git.bb
@@ -8,4 +8,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia qtxmlpatterns"
-SRCREV = "63b90a1d334743b63f396331434e9b12e366f9d3"
+SRCREV = "8b0018cb1a4dea8e74de01427d79494a68d843c6"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 222cccc4..31f2d709 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -14,8 +14,10 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-PACKAGECONFIG ??= "qtxmlpatterns"
+PACKAGECONFIG ??= "qtxmlpatterns qml-debug qml-network"
PACKAGECONFIG[qtxmlpatterns] = ",,qtxmlpatterns"
+PACKAGECONFIG[qml-debug] = "-qml-debug,-no-qml-debug"
+PACKAGECONFIG[qml-network] = "-qml-network, -no-qml-network"
do_configure_prepend() {
# disable qtxmlpatterns test if it isn't enabled by PACKAGECONFIG
@@ -30,6 +32,6 @@ do_install_append_class-nativesdk() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}"
-SRCREV = "1b96186d1418adcba85fdbfd794da2d2f6ea122d"
+SRCREV = "5cef1f6b505939976684c00e8deee614f2c20928"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtgamepad_git.bb b/recipes-qt/qt5/qtgamepad_git.bb
index dcb4d115..e2807801 100644
--- a/recipes-qt/qt5/qtgamepad_git.bb
+++ b/recipes-qt/qt5/qtgamepad_git.bb
@@ -14,4 +14,4 @@ PACKAGECONFIG[sdl2] = "-feature-sdl2,-no-feature-sdl2,libsdl2"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "544d3e4f6f42771b38cafd8a200b16299f2d102c"
+SRCREV = "0ed771f5045729052cef906475395dc8ced3fc8a"
diff --git a/recipes-qt/qt5/qtgraphicaleffects_git.bb b/recipes-qt/qt5/qtgraphicaleffects_git.bb
index c58cc7af..697e2bd5 100644
--- a/recipes-qt/qt5/qtgraphicaleffects_git.bb
+++ b/recipes-qt/qt5/qtgraphicaleffects_git.bb
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
"
-DEPENDS += "qtdeclarative"
+DEPENDS += "qtdeclarative qtdeclarative-native"
RDEPENDS_${PN}-dev = ""
@@ -18,4 +18,4 @@ RDEPENDS_${PN}-dev = ""
# http://errors.yoctoproject.org/Errors/Build/44912/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "66031e932c321ccb936e254b5d1810fa633c6cb0"
+SRCREV = "586476ff2ce59ba4ea2cee2ab59818e0bda4b90c"
diff --git a/recipes-qt/qt5/qtimageformats_git.bb b/recipes-qt/qt5/qtimageformats_git.bb
index 41eb8c73..9058bf69 100644
--- a/recipes-qt/qt5/qtimageformats_git.bb
+++ b/recipes-qt/qt5/qtimageformats_git.bb
@@ -26,4 +26,4 @@ PACKAGECONFIG[libwebp] = ",CONFIG+=done_config_libwebp,libwebp"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "54cdb5b07b2ae2130ce73c6bb22c65b4ad1cba03"
+SRCREV = "a10fec1d386efd99f95973c7d446f94622a5da56"
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index 08655994..f97d026b 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -4,15 +4,15 @@ require qt5-git.inc
LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )"
LIC_FILES_CHKSUM = " \
file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
- file://LICENSE.LGPLv3;md5=e0459b45c5c4840b353141a8bbed91f0 \
file://LICENSE.GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://LICENSE.GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
- file://LICENSE.GPLv3;md5=88e2b9117e6be406b5ed6ee4ca99a705 \
file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \
file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
"
-DEPENDS += "qtbase qtxmlpatterns qtdeclarative qtquickcontrols"
+DEPENDS += "qtbase qtxmlpatterns qtdeclarative qtdeclarative-native qtquickcontrols"
PACKAGECONFIG ??= ""
# older geoclue 0.12.99 is needed
@@ -30,7 +30,7 @@ SRC_URI += " \
${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=upstream/qt-staging;protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \
"
-SRCREV_qtlocation = "9283a290040fd55f7eb34580b99f771d4facdeb4"
+SRCREV_qtlocation = "8d1b370cf371e73540424191241a7432b41d0785"
SRCREV_qtlocation-mapboxgl = "8c1be4ec01ef46bf453856531ebf53b48ce3dbe7"
SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index 7e914dc6..8d1143fd 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -35,4 +35,4 @@ SRC_URI += "\
# http://errors.yoctoproject.org/Errors/Build/44914/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "a3fb242676055355deb68788199ae59abe58ca41"
+SRCREV = "923c2ab674d903d5c71254bf127d2784d3cc6980"
diff --git a/recipes-qt/qt5/qtnetworkauth_git.bb b/recipes-qt/qt5/qtnetworkauth_git.bb
index 0180376e..b51b36f5 100644
--- a/recipes-qt/qt5/qtnetworkauth_git.bb
+++ b/recipes-qt/qt5/qtnetworkauth_git.bb
@@ -9,4 +9,4 @@ require qt5-git.inc
DEPENDS += "qtbase"
-SRCREV = "8f4f2e0cae642ff5eb0b87ae1d4e9c5e6ccf2bd8"
+SRCREV = "1a251f8fcf2749604dc15a4d7d2ceb636daac61c"
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb
index af998732..7c0a8e87 100644
--- a/recipes-qt/qt5/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols2_git.bb
@@ -8,6 +8,6 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.GPLv3;md5=dce746aa5261707df6d6999ab9958d8b \
"
-DEPENDS += "qtdeclarative"
+DEPENDS += "qtdeclarative qtdeclarative-native"
-SRCREV = "b500fbfb5b24f24f6cb3cb02981726fb858287ce"
+SRCREV = "72abc4e94764b4a5592a9d153ff9991fe66d7395"
diff --git a/recipes-qt/qt5/qtquickcontrols_git.bb b/recipes-qt/qt5/qtquickcontrols_git.bb
index 534869b3..b2781973 100644
--- a/recipes-qt/qt5/qtquickcontrols_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols_git.bb
@@ -13,11 +13,11 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
"
-DEPENDS += "qtdeclarative"
+DEPENDS += "qtdeclarative qtdeclarative-native"
FILES_${PN}-qmlplugins += " \
${OE_QMAKE_PATH_QML}/QtQuick/Controls/Shaders \
${OE_QMAKE_PATH_QML}/QtQuick/Dialogs/qml/icons.ttf \
"
-SRCREV = "698a8268f786d74726eb07255df2d26ac2269079"
+SRCREV = "4459886e3f949821425dd5fd9fc9da0416d0ffc9"
diff --git a/recipes-qt/qt5/qtremoteobjects_git.bb b/recipes-qt/qt5/qtremoteobjects_git.bb
index e78b36f2..5c236962 100644
--- a/recipes-qt/qt5/qtremoteobjects_git.bb
+++ b/recipes-qt/qt5/qtremoteobjects_git.bb
@@ -24,6 +24,6 @@ PACKAGECONFIG[tools-only] = "CONFIG+=tools-only"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "c26dd694e8374b478bf428bc9e8753cfc0c3a523"
+SRCREV = "a0b0c1f6a3927e2f31b40619c17bffaf7571dd24"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtscript_git.bb b/recipes-qt/qt5/qtscript_git.bb
index a0ab305d..0819912e 100644
--- a/recipes-qt/qt5/qtscript_git.bb
+++ b/recipes-qt/qt5/qtscript_git.bb
@@ -4,10 +4,10 @@ require qt5-git.inc
HOMEPAGE = "http://www.qt.io"
LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )"
LIC_FILES_CHKSUM = " \
- file://LICENSE.LGPLv21;md5=4bfd28363f541b10d9f024181b8df516 \
- file://LICENSE.LGPLv3;md5=e0459b45c5c4840b353141a8bbed91f0 \
- file://LICENSE.GPLv3;md5=88e2b9117e6be406b5ed6ee4ca99a705 \
- file://LGPL_EXCEPTION.txt;md5=9625233da42f9e0ce9d63651a9d97654 \
+ file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
+ file://LICENSE.GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
+ file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
+ file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \
file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
"
@@ -30,4 +30,4 @@ DEPENDS += "qtbase"
# http://errors.yoctoproject.org/Errors/Build/44915/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "84b13fd9fcd85d39411150f8ae46916a048c413c"
+SRCREV = "a002116ece257e2a2a1e6047c43652073806917e"
diff --git a/recipes-qt/qt5/qtscxml_git.bb b/recipes-qt/qt5/qtscxml_git.bb
index d094f29e..08d19917 100644
--- a/recipes-qt/qt5/qtscxml_git.bb
+++ b/recipes-qt/qt5/qtscxml_git.bb
@@ -10,7 +10,7 @@ require qt5-git.inc
DEPENDS += "qtbase qtdeclarative qtxmlpatterns qtscxml-native"
-SRCREV = "be2cb77f0c882444d4d1080953b4d1b961973c0a"
+SRCREV = "c043ebebaba80b32ddb69ed29aa3408549567a6d"
# Patches from https://github.com/meta-qt5/qtscxml/commits/b5.10
# 5.10.meta-qt5.1
diff --git a/recipes-qt/qt5/qtsensors_git.bb b/recipes-qt/qt5/qtsensors_git.bb
index a3725483..91a6f1c6 100644
--- a/recipes-qt/qt5/qtsensors_git.bb
+++ b/recipes-qt/qt5/qtsensors_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "a5881f10e0ba6ba283b1215a5342056196661414"
+SRCREV = "0a6b30351a0e80447c2dd683765fc1fe66c1eda2"
diff --git a/recipes-qt/qt5/qtserialbus_git.bb b/recipes-qt/qt5/qtserialbus_git.bb
index 427d5964..35a5d8ec 100644
--- a/recipes-qt/qt5/qtserialbus_git.bb
+++ b/recipes-qt/qt5/qtserialbus_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtserialport"
-SRCREV = "b65de45fbfa08d0d2d5b89df77181d3726598097"
+SRCREV = "1399a77954ec4b40fa14b75218e046e76d1324bc"
diff --git a/recipes-qt/qt5/qtserialport_git.bb b/recipes-qt/qt5/qtserialport_git.bb
index d988feec..9cd63aef 100644
--- a/recipes-qt/qt5/qtserialport_git.bb
+++ b/recipes-qt/qt5/qtserialport_git.bb
@@ -5,14 +5,13 @@ require qt5-git.inc
# other qt* components use :/
LICENSE = "GFDL-1.3 & BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( GPL-2.0+ | LGPL-3.0 | The-Qt-Company-Commercial )"
LIC_FILES_CHKSUM = " \
- file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
+ file://LICENSE.FDL;md5=3801d7932fdc07fd9efe89f9854a6caa \
file://LICENSE.GPL2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
file://LICENSE.GPL3-EXCEPT;md5=763d8c535a234d9a3fb682c7ecb6c073 \
- file://LGPL_EXCEPTION.txt;md5=bb426f3367c4805d1e12fad05bd0b750 \
- file://LICENSE.FDL;md5=3801d7932fdc07fd9efe89f9854a6caa \
+ file://LICENSE.LGPL3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
"
DEPENDS += "qtbase"
-SRCREV = "7c827dcbf82d5e5bfbba4053a32c54413a95182a"
+SRCREV = "3f8222efa943617994d982bf31fcda5e568952c4"
diff --git a/recipes-qt/qt5/qtsvg_git.bb b/recipes-qt/qt5/qtsvg_git.bb
index e06940ac..99d9666e 100644
--- a/recipes-qt/qt5/qtsvg_git.bb
+++ b/recipes-qt/qt5/qtsvg_git.bb
@@ -13,4 +13,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "275bd8a4a76256e889cad1ea88c4b5d3acb9ad8f"
+SRCREV = "4366fe95477f96489f9a7a99df96230f0ac72112"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 8534b207..23ae3443 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -29,7 +29,7 @@ PACKAGECONFIG[qtwebkit] = ",,qtwebkit"
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)}"
-SRCREV = "3c7675d9609a15bea81884560920bded736f79a6"
+SRCREV = "5b35868d810751698070f50d894ec1f0cc969a38"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qttranslations_git.bb b/recipes-qt/qt5/qttranslations_git.bb
index 95357374..01eca1cb 100644
--- a/recipes-qt/qt5/qttranslations_git.bb
+++ b/recipes-qt/qt5/qttranslations_git.bb
@@ -111,4 +111,4 @@ FILES_${PN}-qt = " \
${OE_QMAKE_PATH_TRANSLATIONS}/qt_*.qm \
"
-SRCREV = "c3486e072ebc704f9c82c005044143b07bb88f12"
+SRCREV = "25eb2bbb4bf5e7b556d60b2328a19fcedbc3f4fe"
diff --git a/recipes-qt/qt5/qtvirtualkeyboard_git.bb b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
index 0fca94d6..69970f3b 100644
--- a/recipes-qt/qt5/qtvirtualkeyboard_git.bb
+++ b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
@@ -17,7 +17,7 @@ SRC_URI += "file://0001-include-sys-time.h-for-timeval.patch"
#SRC_URI += "file://${T9WRITEPACKAGE};subdir=git/src/virtualkeyboard/3rdparty/t9write"
#PACKAGECONFIG = "t9write lang-all"
-PACKAGECONFIG ?= "lang-all lipi-toolkit"
+PACKAGECONFIG ?= "lang-all lipi-toolkit qtquickcompiler"
PACKAGECONFIG[hunspell] = ",CONFIG+=disable-hunspell,hunspell"
PACKAGECONFIG[t9write] = "CONFIG+=t9write"
PACKAGECONFIG[lipi-toolkit] = "CONFIG+=lipi-toolkit"
@@ -51,6 +51,6 @@ RRECOMMENDS_${PN} += "${PN}-dictionaries"
FILES_${PN}-dictionaries = "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/*/*.dat"
FILES_${PN} += "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/lipi_toolkit"
-DEPENDS += "qtbase qtdeclarative qtmultimedia qtquickcontrols qtsvg qtxmlpatterns"
+DEPENDS += "qtbase qtdeclarative qtdeclarative-native qtmultimedia qtquickcontrols qtsvg qtxmlpatterns"
-SRCREV = "1a9158bfbdd8dd01bac591c11bb0d0bf46514ddb"
+SRCREV = "93af389b0cb786864af8e54d53c7da308cb557a8"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index b5ffa1cc..e0cc422b 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -37,7 +37,7 @@ PACKAGECONFIG[libhybris-egl-server] = "-feature-libhybris-egl-server,-no-feature
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "06230d22488796d92ea130e985d1e0ee2ed05199"
+SRCREV = "ebe5f6097af0fd01b3733ebd4d920f710e4b186a"
# Patches from https://github.com/meta-qt5/qtwayland/commits/b5.10
# 5.10.meta-qt5.1
diff --git a/recipes-qt/qt5/qtwebchannel_git.bb b/recipes-qt/qt5/qtwebchannel_git.bb
index ce51cbc0..8686a292 100644
--- a/recipes-qt/qt5/qtwebchannel_git.bb
+++ b/recipes-qt/qt5/qtwebchannel_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative qtwebsockets"
-SRCREV = "a2b88f9ba0ce2e03ffa73ba26e910e988db5d6c1"
+SRCREV = "f1a65fe2e8294f9a42f360cf13539735211e5878"
diff --git a/recipes-qt/qt5/qtwebengine/0001-Ignore-PKG_CONFIG-shell-exports-for-Yocto.patch b/recipes-qt/qt5/qtwebengine/0001-Ignore-PKG_CONFIG-shell-exports-for-Yocto.patch
new file mode 100644
index 00000000..60e2c564
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/0001-Ignore-PKG_CONFIG-shell-exports-for-Yocto.patch
@@ -0,0 +1,36 @@
+From 7604806e71e6b7931b3ea06ed3aa9aae33ac5883 Mon Sep 17 00:00:00 2001
+From: Michal Klocek <michal.klocek@qt.io>
+Date: Thu, 8 Feb 2018 10:55:01 +0100
+Subject: [PATCH] Ignore PKG_CONFIG* shell exports for Yocto
+
+Yocto sets GN_HOST_PKG_CONFIG script for native
+tools builds, therefore skip host pkg-config script
+generation even if PKG_CONFIG* shell variables for target
+are exported.
+
+Task-number: QTBUG-66275
+Change-Id: I4a9939cd67ca5f32faeb827b5df0d3274ae7c30e
+Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
+---
+ src/core/config/linux.pri | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/core/config/linux.pri b/src/core/config/linux.pri
+index d337f686..1ce3ea89 100644
+--- a/src/core/config/linux.pri
++++ b/src/core/config/linux.pri
+@@ -115,12 +115,12 @@ host_build {
+ PKG_CONFIG_HOST = $$(GN_PKG_CONFIG_HOST)
+ pkgConfigLibDir = $$(PKG_CONFIG_LIBDIR)
+ pkgConfigSysrootDir = $$(PKG_CONFIG_SYSROOT_DIR)
+- isEmpty(PKG_CONFIG_HOST): PKG_CONFIG_HOST = $$QMAKE_PKG_CONFIG_HOST
+- cross_compile {
++ isEmpty(PKG_CONFIG_HOST): cross_compile {
+ !isEmpty(pkgConfigLibDir)|!isEmpty(pkgConfigSysrootDir) {
+ PKG_CONFIG_HOST = $$pkgConfigHostExecutable()
+ }
+ }
++ isEmpty(PKG_CONFIG_HOST): PKG_CONFIG_HOST = $$QMAKE_PKG_CONFIG_HOST
+ gn_args += host_pkg_config=\"$$PKG_CONFIG_HOST\"
+ }
+
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 54a22f19..6e4de7bc 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -121,7 +121,7 @@ RDEPENDS_${PN}-examples += " \
qtdeclarative-qmlplugins \
"
-QT_MODULE_BRANCH_CHROMIUM = "61-based"
+QT_MODULE_BRANCH_CHROMIUM = "63-based"
# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.10
# 5.10.meta-qt5.1
@@ -130,6 +130,7 @@ SRC_URI += " \
file://0001-WebEngine-qquickwebengineview_p_p.h-add-include-QCol.patch \
file://0002-Include-dependency-to-QCoreApplication-translate.patch \
file://0003-Force-host-toolchain-configuration.patch \
+ file://0001-Ignore-PKG_CONFIG-shell-exports-for-Yocto.patch \
"
SRC_URI_append_libc-musl = "\
file://0004-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \
@@ -159,8 +160,8 @@ SRC_URI_append_libc-musl = "\
file://0015-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "14b58276822c12e8d21580f61869b5a9bbf43f22"
-SRCREV_chromium = "f0775ea93ab66f0676993db1633c9098dfb3a3ad"
+SRCREV_qtwebengine = "7a3e38d779352ca09e9118d735c9a2b0ea55b763"
+SRCREV_chromium = "3fa04d22883e42bd987e4f83d394a1040b410024"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"
diff --git a/recipes-qt/qt5/qtwebsockets_git.bb b/recipes-qt/qt5/qtwebsockets_git.bb
index 91660c62..145f1bf5 100644
--- a/recipes-qt/qt5/qtwebsockets_git.bb
+++ b/recipes-qt/qt5/qtwebsockets_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "f8665a7cf5e18e5e40ad3e50039ba0362c5d2ec7"
+SRCREV = "b0fe74a5b924646568291b5ce65e7d13bccbc731"
diff --git a/recipes-qt/qt5/qtwebview_git.bb b/recipes-qt/qt5/qtwebview_git.bb
index b666548d..e304049e 100644
--- a/recipes-qt/qt5/qtwebview_git.bb
+++ b/recipes-qt/qt5/qtwebview_git.bb
@@ -19,4 +19,4 @@ COMPATIBLE_MACHINE_armv7a = "(.*)"
COMPATIBLE_MACHINE_armv7ve = "(.*)"
COMPATIBLE_MACHINE_aarch64 = "(.*)"
-SRCREV = "eef3467cfad9f6ad892344bfcadbd59b5bcb4f53"
+SRCREV = "0f0d87a757fe30976c183207968e1c07f87460d5"
diff --git a/recipes-qt/qt5/qtx11extras_git.bb b/recipes-qt/qt5/qtx11extras_git.bb
index a1e0c1a1..d6742839 100644
--- a/recipes-qt/qt5/qtx11extras_git.bb
+++ b/recipes-qt/qt5/qtx11extras_git.bb
@@ -13,4 +13,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "fcd1d9a09d22619dfae4c1d4f9911e9acce2e893"
+SRCREV = "7eae66f6693e560b01c03907bfeccb1deac7aed5"
diff --git a/recipes-qt/qt5/qtxmlpatterns_git.bb b/recipes-qt/qt5/qtxmlpatterns_git.bb
index 226b00a7..02562e51 100644
--- a/recipes-qt/qt5/qtxmlpatterns_git.bb
+++ b/recipes-qt/qt5/qtxmlpatterns_git.bb
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "0a84ad44ff5b793316485fd992326627a70fda84"
+SRCREV = "5fac6d6fda04924b03f6a5651933f0c055d0df23"
BBCLASSEXTEND =+ "native nativesdk"