aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2018-02-27 10:48:56 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2018-03-05 06:26:04 +0000
commitce85883673e134947addf3d6859b2b79815e49cd (patch)
tree5edda7a5d937bd5e335c0e56411442e3d25d2106
parentf6f12ed5bcf5fc1e36bc5c6dee386947df3c3dc2 (diff)
qt5: update submodules
Update to 5.11.0 Beta1 Change-Id: I86dc55386536cace94bb0657ded4efe5decdb49f Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qt3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtknx_git.bb2
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb2
-rw-r--r--recipes-qt/qt5/qtmqtt_git.bb2
-rw-r--r--recipes-qt/qt5/qtopcua_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols2_git.bb2
-rw-r--r--recipes-qt/qt5/qtscxml_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialbus_git.bb2
-rw-r--r--recipes-qt/qt5/qttools_git.bb2
-rw-r--r--recipes-qt/qt5/qttranslations_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebview_git.bb2
18 files changed, 18 insertions, 18 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index d227a946..505c8cde 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -205,4 +205,4 @@ do_install() {
sed -i -e 's:${SDKPATHNATIVE}:$OECORE_NATIVE_SYSROOT:g' $script
}
-SRCREV = "8a66924ca000fe4e05b680ca82c6587da8d28e0b"
+SRCREV = "9df6f3367e971d4fad63e59bb42615e2b7a580ce"
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index c2cec36e..04483be5 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -37,6 +37,6 @@ do_configure_prepend() {
${S}/src/quick3d/imports/input/importsinput.pro
}
-SRCREV = "51dca6514593978beb28afa1c9f99ccd9a5c212c"
+SRCREV = "4ce90380ad5272de3bec178c480a132b5d4771ba"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 3d3ceeda..fb08fd40 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -135,4 +135,4 @@ do_install() {
echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
}
-SRCREV = "8a66924ca000fe4e05b680ca82c6587da8d28e0b"
+SRCREV = "9df6f3367e971d4fad63e59bb42615e2b7a580ce"
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 7d104275..21a08386 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -243,4 +243,4 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps"
RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}"
-SRCREV = "8a66924ca000fe4e05b680ca82c6587da8d28e0b"
+SRCREV = "9df6f3367e971d4fad63e59bb42615e2b7a580ce"
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index f8421e87..89f92546 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -19,4 +19,4 @@ PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,${BLUEZ}"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "7bcc5dc2c323b2ed120fb7bf695286f6a01c44d0"
+SRCREV = "d70fe2ac47dbf034991f0b2a4b0a3e1f16d171b9"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 3e840830..cca3f611 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -32,6 +32,6 @@ do_install_append_class-nativesdk() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}"
-SRCREV = "ba05397ad723fa19125eb5ca2f91c7f437b21484"
+SRCREV = "53d1e9ed21d25e65a2f13606af479838f5f21fe7"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtknx_git.bb b/recipes-qt/qt5/qtknx_git.bb
index 5e01e3c9..24d3527b 100644
--- a/recipes-qt/qt5/qtknx_git.bb
+++ b/recipes-qt/qt5/qtknx_git.bb
@@ -9,4 +9,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "29c34e8f072afd01002ed3847d752b4e065f977e"
+SRCREV = "4d5a04a0793ef05ade54a09cd469c9934f102753"
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index 71f953ef..1b07d532 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -28,7 +28,7 @@ SRC_URI += " \
${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=upstream/qt-staging;protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \
"
-SRCREV_qtlocation = "3d2993d0c31540f48244918541741c5d521a4dc4"
+SRCREV_qtlocation = "d458bd47106dd849e6cf72b97a27f871735e4eed"
SRCREV_qtlocation-mapboxgl = "8c1be4ec01ef46bf453856531ebf53b48ce3dbe7"
SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl"
diff --git a/recipes-qt/qt5/qtmqtt_git.bb b/recipes-qt/qt5/qtmqtt_git.bb
index b705f7c4..a3e6da49 100644
--- a/recipes-qt/qt5/qtmqtt_git.bb
+++ b/recipes-qt/qt5/qtmqtt_git.bb
@@ -9,4 +9,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "2c3c2a41c55a179332ec2a076856990f36dd5ef9"
+SRCREV = "b61e7bd3182addd8675ae907fc681db402fb138f"
diff --git a/recipes-qt/qt5/qtopcua_git.bb b/recipes-qt/qt5/qtopcua_git.bb
index c2abb4a7..897429be 100644
--- a/recipes-qt/qt5/qtopcua_git.bb
+++ b/recipes-qt/qt5/qtopcua_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "e1d769a270ba376374410c351dcb7f53bea0d9a5"
+SRCREV = "e6410a0fed4c7f43df28dfbf6e02e6db0e145971"
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb
index 33e1c8d4..122549c6 100644
--- a/recipes-qt/qt5/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols2_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative qtdeclarative-native"
-SRCREV = "c924a94fb5077028965e2c6343e1bafabc0e69f8"
+SRCREV = "f1f884d353c5a9190e200cc04e94d4658c69a23b"
diff --git a/recipes-qt/qt5/qtscxml_git.bb b/recipes-qt/qt5/qtscxml_git.bb
index 8714c36a..3ca3337f 100644
--- a/recipes-qt/qt5/qtscxml_git.bb
+++ b/recipes-qt/qt5/qtscxml_git.bb
@@ -10,7 +10,7 @@ require qt5-git.inc
DEPENDS += "qtbase qtdeclarative qtxmlpatterns qtscxml-native"
-SRCREV = "f71a6d1a746d5ceb19ce017902c83e1819b5c0ea"
+SRCREV = "544f8c4ef7b77c5194605cba612fdde6fa02b06b"
# Patches from https://github.com/meta-qt5/qtscxml/commits/b5.10
# 5.10.meta-qt5.1
diff --git a/recipes-qt/qt5/qtserialbus_git.bb b/recipes-qt/qt5/qtserialbus_git.bb
index c869523f..fca80af8 100644
--- a/recipes-qt/qt5/qtserialbus_git.bb
+++ b/recipes-qt/qt5/qtserialbus_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtserialport"
-SRCREV = "bfb218c46324f89dd435ddfa0dbfe3643fcc2d27"
+SRCREV = "7c6e9d8f29148793dc619a743a0b5d3a601ec34b"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 4ecd98ad..e564366f 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -29,7 +29,7 @@ PACKAGECONFIG[qtwebkit] = ",,qtwebkit"
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)}"
-SRCREV = "c0bfa2a930f6414d41684e578b59872defdffdf9"
+SRCREV = "9dfdfdf5744d3bf0ffea3c380ed37f0ab9273fe5"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qttranslations_git.bb b/recipes-qt/qt5/qttranslations_git.bb
index 01eca1cb..4c4ae00f 100644
--- a/recipes-qt/qt5/qttranslations_git.bb
+++ b/recipes-qt/qt5/qttranslations_git.bb
@@ -111,4 +111,4 @@ FILES_${PN}-qt = " \
${OE_QMAKE_PATH_TRANSLATIONS}/qt_*.qm \
"
-SRCREV = "25eb2bbb4bf5e7b556d60b2328a19fcedbc3f4fe"
+SRCREV = "f1c17f060d09ea3d225803afa9f82fa22117cd3b"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 3659aa77..8f1ec946 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -37,7 +37,7 @@ PACKAGECONFIG[libhybris-egl-server] = "-feature-libhybris-egl-server,-no-feature
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "abfdf34f510b64439c85cc54f47b41c4ce3f9c61"
+SRCREV = "ec495c98189f1d849e793108b09b5af0ce2c8984"
# Patches from https://github.com/meta-qt5/qtwayland/commits/b5.10
# 5.10.meta-qt5.1
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 8eb0ee06..6788bbaa 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -159,7 +159,7 @@ SRC_URI_append_libc-musl = "\
file://0015-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "51658fac63299f818afd8ddde6dccee66a36efda"
+SRCREV_qtwebengine = "73e72f7b5f3dc9b08a18a2afc286576951b424b9"
SRCREV_chromium = "3fa04d22883e42bd987e4f83d394a1040b410024"
SRCREV = "${SRCREV_qtwebengine}"
diff --git a/recipes-qt/qt5/qtwebview_git.bb b/recipes-qt/qt5/qtwebview_git.bb
index ceecfb0b..f995c05f 100644
--- a/recipes-qt/qt5/qtwebview_git.bb
+++ b/recipes-qt/qt5/qtwebview_git.bb
@@ -19,4 +19,4 @@ COMPATIBLE_MACHINE_armv7a = "(.*)"
COMPATIBLE_MACHINE_armv7ve = "(.*)"
COMPATIBLE_MACHINE_aarch64 = "(.*)"
-SRCREV = "cf23a402b97b459309ec32fe49c82a845a3636af"
+SRCREV = "fa66026beafaf00aa549f71d6879320610d0e7e5"