aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-09-10 17:27:23 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2018-09-11 10:59:34 +0300
commit7070dd34e136a53dadb59ffbb6b127bcf23b301c (patch)
tree9f3d0ac915bcb1bdea23c53f6782020ac5fc9a24
parent1fe27390ef279ad973eba60c83e9f69d75ccc613 (diff)
parent78b8872328a2162c1030831a36d0814da6c200a5 (diff)
Merge remote-tracking branch 'qtyocto/5.11' into 5.12
* qtyocto/5.11: qt5: update submodules qtwebengine: enable debug info for webengine Change-Id: I8cbc5a4fc17513ae9fbabebc8640ec0ec514c390
-rw-r--r--recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch24
-rw-r--r--recipes-qt/qt5/qtknx_git.bb2
-rw-r--r--recipes-qt/qt5/qtmqtt_git.bb2
-rw-r--r--recipes-qt/qt5/qtopcua_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
5 files changed, 15 insertions, 16 deletions
diff --git a/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch b/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
index f4dfe0b7..e49cd000 100644
--- a/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
+++ b/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
@@ -1,4 +1,4 @@
-From bb416ea80d421c53012e13280d68bdcefc815b8f Mon Sep 17 00:00:00 2001
+From 7aefc3b3351dd8a2b47dc8baa790ffde6fd1f158 Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Mon, 15 Apr 2013 04:29:32 +0200
Subject: [PATCH] Add linux-oe-g++ platform
@@ -22,16 +22,16 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
---
configure | 2 +-
mkspecs/features/configure.prf | 4 +--
- mkspecs/features/qt.prf | 6 ++--
+ mkspecs/features/qt.prf | 6 ++---
mkspecs/features/qt_functions.prf | 2 +-
- mkspecs/linux-oe-g++/qmake.conf | 42 ++++++++++++++++++++++++++++
+ mkspecs/linux-oe-g++/qmake.conf | 40 ++++++++++++++++++++++++++++
mkspecs/linux-oe-g++/qplatformdefs.h | 1 +
- 6 files changed, 50 insertions(+), 7 deletions(-)
+ 6 files changed, 48 insertions(+), 7 deletions(-)
create mode 100644 mkspecs/linux-oe-g++/qmake.conf
create mode 100644 mkspecs/linux-oe-g++/qplatformdefs.h
diff --git a/configure b/configure
-index 2830a1b189..6445dc2d5a 100755
+index 2830a1b1897..6445dc2d5a0 100755
--- a/configure
+++ b/configure
@@ -712,7 +712,7 @@ fi
@@ -44,7 +44,7 @@ index 2830a1b189..6445dc2d5a 100755
# build qmake
diff --git a/mkspecs/features/configure.prf b/mkspecs/features/configure.prf
-index 934a18a924..0f5b1b6333 100644
+index 934a18a9249..0f5b1b63334 100644
--- a/mkspecs/features/configure.prf
+++ b/mkspecs/features/configure.prf
@@ -46,14 +46,14 @@ defineTest(qtCompileTest) {
@@ -65,7 +65,7 @@ index 934a18a924..0f5b1b6333 100644
msg = "test $$1 succeeded"
write_file($$QMAKE_CONFIG_LOG, msg, append)
diff --git a/mkspecs/features/qt.prf b/mkspecs/features/qt.prf
-index b57afcf72d..afa1c39b3e 100644
+index b57afcf72d7..afa1c39b3e9 100644
--- a/mkspecs/features/qt.prf
+++ b/mkspecs/features/qt.prf
@@ -147,7 +147,7 @@ import_plugins:qtConfig(static) {
@@ -89,7 +89,7 @@ index b57afcf72d..afa1c39b3e 100644
# run qmlimportscanner
qtPrepareTool(QMLIMPORTSCANNER, qmlimportscanner, , system)
diff --git a/mkspecs/features/qt_functions.prf b/mkspecs/features/qt_functions.prf
-index 1903e509c8..c093dd4592 100644
+index 1903e509c8e..c093dd4592d 100644
--- a/mkspecs/features/qt_functions.prf
+++ b/mkspecs/features/qt_functions.prf
@@ -69,7 +69,7 @@ defineTest(qtHaveModule) {
@@ -103,10 +103,10 @@ index 1903e509c8..c093dd4592 100644
cmd = perl -w $$system_path($${cmd}.pl)
diff --git a/mkspecs/linux-oe-g++/qmake.conf b/mkspecs/linux-oe-g++/qmake.conf
new file mode 100644
-index 0000000000..30d31ed16d
+index 00000000000..d90dfeb4482
--- /dev/null
+++ b/mkspecs/linux-oe-g++/qmake.conf
-@@ -0,0 +1,42 @@
+@@ -0,0 +1,40 @@
+#
+# qmake configuration for linux-g++ with modifications for building with OpenEmbedded
+#
@@ -135,8 +135,6 @@ index 0000000000..30d31ed16d
+QMAKE_CC = $$(OE_QMAKE_CC)
+QMAKE_CXX = $$(OE_QMAKE_CXX)
+
-+QMAKE_CFLAGS_RELEASE_WITH_DEBUGINFO += $$(OE_QMAKE_CFLAGS)
-+
+QMAKE_LINK = $$(OE_QMAKE_LINK)
+QMAKE_LINK_SHLIB = $$(OE_QMAKE_LINK)
+QMAKE_LINK_C = $$(OE_QMAKE_LINK)
@@ -151,7 +149,7 @@ index 0000000000..30d31ed16d
+load(qt_config)
diff --git a/mkspecs/linux-oe-g++/qplatformdefs.h b/mkspecs/linux-oe-g++/qplatformdefs.h
new file mode 100644
-index 0000000000..5d22fb4101
+index 00000000000..5d22fb41013
--- /dev/null
+++ b/mkspecs/linux-oe-g++/qplatformdefs.h
@@ -0,0 +1 @@
diff --git a/recipes-qt/qt5/qtknx_git.bb b/recipes-qt/qt5/qtknx_git.bb
index 70218296..ed821c01 100644
--- a/recipes-qt/qt5/qtknx_git.bb
+++ b/recipes-qt/qt5/qtknx_git.bb
@@ -9,4 +9,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "e2faddd5d6b6ef468fed7ce129d849130c957da4"
+SRCREV = "c378516c007f15f439dfb167bbe78a6b275667dc"
diff --git a/recipes-qt/qt5/qtmqtt_git.bb b/recipes-qt/qt5/qtmqtt_git.bb
index 8aa26be8..e691e48d 100644
--- a/recipes-qt/qt5/qtmqtt_git.bb
+++ b/recipes-qt/qt5/qtmqtt_git.bb
@@ -9,4 +9,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "b8a9a5aff7e924826c85029a9f919b5247752d5c"
+SRCREV = "fd396f82b34f11afafc63f33a15e87b89fd1bd88"
diff --git a/recipes-qt/qt5/qtopcua_git.bb b/recipes-qt/qt5/qtopcua_git.bb
index 2a788bec..20bf4e96 100644
--- a/recipes-qt/qt5/qtopcua_git.bb
+++ b/recipes-qt/qt5/qtopcua_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "f08a50d9d7b8ddec27fdd9f070fb7e54108570e4"
+SRCREV = "e8561dd48762cbaf92bdb1b191ca8647415e19b1"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index a99f6550..9c03f995 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -31,6 +31,7 @@ DEPENDS += " \
DEPENDS_append_libc-musl = " libexecinfo"
EXTRA_QMAKEVARS_CONFIGURE += "-feature-webengine-system-ninja -no-feature-webengine-system-gn"
+EXTRA_QMAKEVARS_PRE += "CONFIG+=force_debug_info"
# chromium/third_party/openh264/openh264.gyp adds
# -Wno-format to openh264_cflags_add