aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-09-11 10:43:26 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2018-09-11 09:14:11 +0000
commit7a4b795671a587ab812b72b7a3fed07d47b701cf (patch)
tree462a104cdf0d914afba3748659bd6a4d9a43ac38
parent7070dd34e136a53dadb59ffbb6b127bcf23b301c (diff)
qt5: update submodules
Change-Id: I2cc8469aa33e239352e06d6ab9fce805b95ff81e Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch11
-rw-r--r--recipes-qt/qt5/qt3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtcanvas3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtcharts_git.bb2
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtimageformats_git.bb2
-rw-r--r--recipes-qt/qt5/qtknx_git.bb2
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb4
-rw-r--r--recipes-qt/qt5/qtmqtt_git.bb2
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtopcua_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols2_git.bb2
-rw-r--r--recipes-qt/qt5/qtremoteobjects_git.bb2
-rw-r--r--recipes-qt/qt5/qtsensors_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialbus_git.bb2
-rw-r--r--recipes-qt/qt5/qtsvg_git.bb2
-rw-r--r--recipes-qt/qt5/qtsystems_git.bb2
-rw-r--r--recipes-qt/qt5/qttools_git.bb2
-rw-r--r--recipes-qt/qt5/qttranslations_git.bb2
-rw-r--r--recipes-qt/qt5/qtvirtualkeyboard_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebchannel_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb4
-rw-r--r--recipes-qt/qt5/qtwebsockets_git.bb2
-rw-r--r--recipes-qt/qt5/qtxmlpatterns_git.bb2
29 files changed, 36 insertions, 35 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 87cc1954..184d3730 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -207,4 +207,4 @@ fakeroot do_generate_qt_environment_file() {
do_generate_qt_environment_file[umask] = "022"
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "ee2e38490d51667e878ed1732df387a6d9f2a5fe"
+SRCREV = "42a68ee9dd53eac2d8aaabf02dcf4ffa4525facf"
diff --git a/recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch b/recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch
index 1f871bb0..de6826bd 100644
--- a/recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch
+++ b/recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch
@@ -1,4 +1,4 @@
-From da05164543625a93f3a646967d4692bcf13f441f Mon Sep 17 00:00:00 2001
+From 46137e8cf94fd24fe5270739da72e03b7bb92673 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@theqtcompany.com>
Date: Wed, 10 Feb 2016 09:02:09 +0200
Subject: [PATCH] Allow a tools-only build
@@ -40,12 +40,13 @@ index 8ba2d9a41..e973d93dd 100644
} else {
include(assimp.pri)
diff --git a/tools/tools.pro b/tools/tools.pro
-index 64f2b9fc7..d108e7fa7 100644
+index c2f692034..24c49ad5a 100644
--- a/tools/tools.pro
+++ b/tools/tools.pro
-@@ -1,4 +1,4 @@
+@@ -1,5 +1,5 @@
TEMPLATE = subdirs
QT_FOR_CONFIG += 3dcore-private
--qtConfig(assimp):qtConfig(commandlineparser): \
-+tools-only|qtConfig(assimp):qtConfig(commandlineparser): \
+-qtConfig(assimp):qtConfig(commandlineparser):!cross_compile: {
++tools-only|qtConfig(assimp):qtConfig(commandlineparser): {
SUBDIRS += qgltf
+ }
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index 49aa667a..2bcb06b8 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -36,6 +36,6 @@ do_configure_prepend() {
${S}/src/quick3d/imports/input/importsinput.pro
}
-SRCREV = "db836a410555108adff3bd594cf75f4174069f0c"
+SRCREV = "27457f50b35b3941db4e7e5def742fcdefe218ff"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 8086c733..be86a93b 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -133,4 +133,4 @@ do_install() {
echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
}
-SRCREV = "ee2e38490d51667e878ed1732df387a6d9f2a5fe"
+SRCREV = "42a68ee9dd53eac2d8aaabf02dcf4ffa4525facf"
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index bc502362..6ef23107 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -248,4 +248,4 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps"
RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}"
-SRCREV = "ee2e38490d51667e878ed1732df387a6d9f2a5fe"
+SRCREV = "42a68ee9dd53eac2d8aaabf02dcf4ffa4525facf"
diff --git a/recipes-qt/qt5/qtcanvas3d_git.bb b/recipes-qt/qt5/qtcanvas3d_git.bb
index 9f41a020..08614f82 100644
--- a/recipes-qt/qt5/qtcanvas3d_git.bb
+++ b/recipes-qt/qt5/qtcanvas3d_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS = "qtdeclarative"
-SRCREV = "d5565b5cee35570e185b34ca143158f79a27a3a5"
+SRCREV = "fb5394ce6d38d06c13b01574cf00d4fe98025c52"
diff --git a/recipes-qt/qt5/qtcharts_git.bb b/recipes-qt/qt5/qtcharts_git.bb
index 7c5dc9ac..9308e861 100644
--- a/recipes-qt/qt5/qtcharts_git.bb
+++ b/recipes-qt/qt5/qtcharts_git.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia"
-SRCREV = "cfde71c26792d595c2d948627b6c19ce0d7e9054"
+SRCREV = "79888d87ad08ec120fc170c7d450c5ac1067ce89"
# The same issue as in qtbase:
# http://errors.yoctoproject.org/Errors/Details/152641/
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index 3ad49495..e794e7d4 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -19,4 +19,4 @@ PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,${BLUEZ}"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "b6edd379204221bf9848b3648106e56c7c2cd7e6"
+SRCREV = "68475e563d8a19f521278703a3e98c7664d6bbbc"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index b0204d39..a5451b8d 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -33,6 +33,6 @@ do_install_append_class-nativesdk() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}"
-SRCREV = "32f93f087dac5ed73ca1c19dbee4059e026bc3da"
+SRCREV = "2dac7983b0cceb23682ae2f14cc0a612888461e2"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtimageformats_git.bb b/recipes-qt/qt5/qtimageformats_git.bb
index 541768f3..488b644a 100644
--- a/recipes-qt/qt5/qtimageformats_git.bb
+++ b/recipes-qt/qt5/qtimageformats_git.bb
@@ -25,4 +25,4 @@ PACKAGECONFIG[libwebp] = ",CONFIG+=done_config_libwebp,libwebp"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "6a039e4e77cef7d590c973c27c03a4576d6f5362"
+SRCREV = "dd38f75d8614e5d4e1906594e1d83f284af42457"
diff --git a/recipes-qt/qt5/qtknx_git.bb b/recipes-qt/qt5/qtknx_git.bb
index ed821c01..cfaab3c6 100644
--- a/recipes-qt/qt5/qtknx_git.bb
+++ b/recipes-qt/qt5/qtknx_git.bb
@@ -9,4 +9,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "c378516c007f15f439dfb167bbe78a6b275667dc"
+SRCREV = "2efeb7739d15c49ea382638a4b40de477dee12f8"
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index 9796ceb7..6f1d2c21 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -31,7 +31,7 @@ SRC_URI += " \
${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=${QT_MODULE_BRANCH_MAPBOXGL};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \
"
-SRCREV_qtlocation = "07be65e9d9a883aab4e1fda367cf591b7cb97631"
-SRCREV_qtlocation-mapboxgl = "b59b0450c60b3df9e0852f62f6c8a6024889cd9e"
+SRCREV_qtlocation = "ffd680a132db99f1fa1e9ebb75c844c491afa83b"
+SRCREV_qtlocation-mapboxgl = "4b85252fbe811a786c6ee9eabedb7639b031dc53"
SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl"
diff --git a/recipes-qt/qt5/qtmqtt_git.bb b/recipes-qt/qt5/qtmqtt_git.bb
index e691e48d..deb7d6e4 100644
--- a/recipes-qt/qt5/qtmqtt_git.bb
+++ b/recipes-qt/qt5/qtmqtt_git.bb
@@ -9,4 +9,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "fd396f82b34f11afafc63f33a15e87b89fd1bd88"
+SRCREV = "b3ee3a0fe18e8d101a4c58fa17764ae8c9aa9268"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index 3c846957..e50e1461 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -37,4 +37,4 @@ SRC_URI += "\
# http://errors.yoctoproject.org/Errors/Build/44914/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "6dda96f4d4681f7107931bea4c5a0f3fc35bec8d"
+SRCREV = "35ace9e289dcaada5e0828a59ca7dfee78a6342c"
diff --git a/recipes-qt/qt5/qtopcua_git.bb b/recipes-qt/qt5/qtopcua_git.bb
index 20bf4e96..521287a5 100644
--- a/recipes-qt/qt5/qtopcua_git.bb
+++ b/recipes-qt/qt5/qtopcua_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "e8561dd48762cbaf92bdb1b191ca8647415e19b1"
+SRCREV = "674b5557bf943e6be3e027a7dde0632c1db210bf"
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb
index 2c33bbd3..2d4ae159 100644
--- a/recipes-qt/qt5/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols2_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative qtdeclarative-native"
-SRCREV = "628df3881fbb3d3bd1ee4316b47df5871c6dad73"
+SRCREV = "d19f782a887e4a8c87ceee42ad8405a0b12388d0"
diff --git a/recipes-qt/qt5/qtremoteobjects_git.bb b/recipes-qt/qt5/qtremoteobjects_git.bb
index 2f181306..7b4f1050 100644
--- a/recipes-qt/qt5/qtremoteobjects_git.bb
+++ b/recipes-qt/qt5/qtremoteobjects_git.bb
@@ -24,6 +24,6 @@ PACKAGECONFIG[tools-only] = "CONFIG+=tools-only"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "6f781fd266caa1e268e167f7273fec3e30d5af7a"
+SRCREV = "854217d60da9ab54795fb39896a053f301222848"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtsensors_git.bb b/recipes-qt/qt5/qtsensors_git.bb
index ca2f62e6..c4d8d2fd 100644
--- a/recipes-qt/qt5/qtsensors_git.bb
+++ b/recipes-qt/qt5/qtsensors_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "44c357ce531b06d7050ac9987c1ee8c1c470bd75"
+SRCREV = "12bb2552599111aa2f7b6dc69bd0dd565edba710"
diff --git a/recipes-qt/qt5/qtserialbus_git.bb b/recipes-qt/qt5/qtserialbus_git.bb
index b3c13f49..b87b134d 100644
--- a/recipes-qt/qt5/qtserialbus_git.bb
+++ b/recipes-qt/qt5/qtserialbus_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtserialport"
-SRCREV = "34d346c161bf89a6a98d4782627a5c4f12271bde"
+SRCREV = "9f5b14b06775e91ac65dc3c0b0ea3a54235a93a2"
diff --git a/recipes-qt/qt5/qtsvg_git.bb b/recipes-qt/qt5/qtsvg_git.bb
index ab9a0c68..d971cd16 100644
--- a/recipes-qt/qt5/qtsvg_git.bb
+++ b/recipes-qt/qt5/qtsvg_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "524478f60e6eac991b9ef033a2030a9ea5aa5c36"
+SRCREV = "907c2db46915eedac02f2a5a26291d2ce19282f9"
diff --git a/recipes-qt/qt5/qtsystems_git.bb b/recipes-qt/qt5/qtsystems_git.bb
index 7e930047..0bda2e99 100644
--- a/recipes-qt/qt5/qtsystems_git.bb
+++ b/recipes-qt/qt5/qtsystems_git.bb
@@ -31,4 +31,4 @@ do_install_append() {
QT_MODULE_BRANCH = "dev"
-SRCREV = "434af789f0d56ca7a521ca2d9ec8cf3b1057fd37"
+SRCREV = "66e45676f5f5c6251ccab36906c6324fd0065e08"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index fe38fe32..039e98cb 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -32,7 +32,7 @@ EXTRA_QMAKEVARS_PRE += " \
${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)} \
"
-SRCREV = "6e60c31d3513da3a9ec5e9a38326961bc6a32928"
+SRCREV = "53094d904447abf2c720dbec1bf8d6e63d53af14"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qttranslations_git.bb b/recipes-qt/qt5/qttranslations_git.bb
index 93da0fb4..e91a9c7a 100644
--- a/recipes-qt/qt5/qttranslations_git.bb
+++ b/recipes-qt/qt5/qttranslations_git.bb
@@ -103,4 +103,4 @@ FILES_${PN}-qthelp = " \
${OE_QMAKE_PATH_TRANSLATIONS}/qt_help_*.qm \
"
-SRCREV = "e2ab66653d0c8ae59868ff5bc2a3a44d1b61cfd9"
+SRCREV = "bb5f0ac724b7179df25c7d7442991eceea1fd58d"
diff --git a/recipes-qt/qt5/qtvirtualkeyboard_git.bb b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
index 7b640d6e..41c5783d 100644
--- a/recipes-qt/qt5/qtvirtualkeyboard_git.bb
+++ b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
@@ -49,4 +49,4 @@ FILES_${PN} += "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/lipi_toolkit"
DEPENDS += "qtbase qtdeclarative qtmultimedia qtquickcontrols qtsvg qtxmlpatterns qtdeclarative-native"
-SRCREV = "246c406fc2bad945284704bb6613ae9adf3230ed"
+SRCREV = "1372dd25d5fd5623046eb9e5ceebb2f4bd34f969"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 163edf55..fb53bf22 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -37,7 +37,7 @@ PACKAGECONFIG[libhybris-egl-server] = "-feature-libhybris-egl-server,-no-feature
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "617341751630be295f9e3dc0a9ea630de61ee345"
+SRCREV = "54285dd5f6a660ce0ddd45b222d6c4dcd8ea6f74"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtwebchannel_git.bb b/recipes-qt/qt5/qtwebchannel_git.bb
index a00aff4a..56d0ce98 100644
--- a/recipes-qt/qt5/qtwebchannel_git.bb
+++ b/recipes-qt/qt5/qtwebchannel_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative qtwebsockets"
-SRCREV = "0880c04eec2653b94ac58f0e20a2215243fd1c66"
+SRCREV = "e6c5b44453635be0f05f3ee9545e3cb348e1b1a9"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 9c03f995..b01c2ca9 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -165,8 +165,8 @@ SRC_URI_append_libc-musl = "\
file://chromium/0015-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "80f42a0955365d641d7ca6cb5e99d0a8252a543e"
-SRCREV_chromium = "d4ae420c54b0e8b4660b5c41ec0c38049115f9a9"
+SRCREV_qtwebengine = "874ca9668bae643445b282a1681f15dc67008d29"
+SRCREV_chromium = "922a17dfc0045e5ca565faf446c8ce09557e92cf"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"
diff --git a/recipes-qt/qt5/qtwebsockets_git.bb b/recipes-qt/qt5/qtwebsockets_git.bb
index b42f446b..cb7b40c1 100644
--- a/recipes-qt/qt5/qtwebsockets_git.bb
+++ b/recipes-qt/qt5/qtwebsockets_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "85e345a38709026d4d82c67b9016338675851249"
+SRCREV = "4321fd13ac58e5bebe4d564431e9c18b627598bc"
diff --git a/recipes-qt/qt5/qtxmlpatterns_git.bb b/recipes-qt/qt5/qtxmlpatterns_git.bb
index 87eb4d8b..f307a4f6 100644
--- a/recipes-qt/qt5/qtxmlpatterns_git.bb
+++ b/recipes-qt/qt5/qtxmlpatterns_git.bb
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "e95c186fe8da96fba394490f9bca817534124b63"
+SRCREV = "8c6e24329ecd65f364654b1ca2b6a273f0826a8b"
BBCLASSEXTEND =+ "native nativesdk"