aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2018-10-19 08:13:33 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2018-10-19 11:02:52 +0000
commitaecbcd8423e44b89bd187bf0ecf9caa14283e581 (patch)
treecf56765d839b7a5c4fce88971c93c76a246d836f
parent21f10e47108ed83d92da2c80574b884bdbc83cf1 (diff)
qt5: update submodules
Update to latest 5.12.0 snapshot. Obsolete qtscript patch removed. Task-number: QTBUG-70847 Change-Id: I88ca3639bb015d108019d40a6910fc51cac1f887 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qt3d-runtime/0001-runtime-Include-missing-QCoreApplication-header.patch7
-rw-r--r--recipes-qt/qt5/qt3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtimageformats_git.bb2
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols2_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols_git.bb2
-rw-r--r--recipes-qt/qt5/qtscript/0001-3rdparty-javascriptcore-Add-RISC-V-support.patch47
-rw-r--r--recipes-qt/qt5/qtscript_git.bb3
-rw-r--r--recipes-qt/qt5/qtserialbus_git.bb2
-rw-r--r--recipes-qt/qt5/qttools_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb4
17 files changed, 20 insertions, 67 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 1368758e..dac1e9b2 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -192,4 +192,4 @@ fakeroot do_generate_qt_environment_file() {
do_generate_qt_environment_file[umask] = "022"
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "473d9a5fc763d114fbfa1c0d2b5f8d03cab6e972"
+SRCREV = "b88eaa255a4646446e0842f3d8f732b39d09a65f"
diff --git a/recipes-qt/qt5/qt3d-runtime/0001-runtime-Include-missing-QCoreApplication-header.patch b/recipes-qt/qt5/qt3d-runtime/0001-runtime-Include-missing-QCoreApplication-header.patch
index bc61e538..4a4505a1 100644
--- a/recipes-qt/qt5/qt3d-runtime/0001-runtime-Include-missing-QCoreApplication-header.patch
+++ b/recipes-qt/qt5/qt3d-runtime/0001-runtime-Include-missing-QCoreApplication-header.patch
@@ -1,4 +1,4 @@
-From e6247a6823d372cc779934cf6c74d65bae9652b5 Mon Sep 17 00:00:00 2001
+From b592df2afbbeb0670a9d2939d5cca1544095c7ae Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Thu, 23 Aug 2018 03:23:20 +0000
Subject: [PATCH] runtime: Include missing <QCoreApplication> header
@@ -11,17 +11,18 @@ q3dsengine.cpp:1327:9: error: 'QCoreApplication' has not been declared
Upstream-Status: Pending
Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
---
src/runtime/q3dsengine.cpp | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/runtime/q3dsengine.cpp b/src/runtime/q3dsengine.cpp
-index 1a438f0..d6d4eb5 100644
+index 053fda4..65c34aa 100644
--- a/src/runtime/q3dsengine.cpp
+++ b/src/runtime/q3dsengine.cpp
@@ -36,6 +36,7 @@
#include "q3dsinlineqmlsubpresentation_p.h"
- #include "q3dsviewersettings.h"
+ #include "q3dsviewportsettings_p.h"
+#include <QCoreApplication>
#include <QLoggingCategory>
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index 9836ddc9..a3a47c6f 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -36,6 +36,6 @@ do_configure_prepend() {
${S}/src/quick3d/imports/input/importsinput.pro
}
-SRCREV = "e549220a5daaedb13f167d6cde4a181666faec63"
+SRCREV = "3d75a66c2908faa39d25b55f3d4b8ff3d0c5c4b7"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index bf6f6b32..f2e56327 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -134,4 +134,4 @@ do_install() {
echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
}
-SRCREV = "473d9a5fc763d114fbfa1c0d2b5f8d03cab6e972"
+SRCREV = "b88eaa255a4646446e0842f3d8f732b39d09a65f"
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 23c58c22..7c17c474 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -250,4 +250,4 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps"
RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}"
-SRCREV = "473d9a5fc763d114fbfa1c0d2b5f8d03cab6e972"
+SRCREV = "b88eaa255a4646446e0842f3d8f732b39d09a65f"
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index 3e93fbe4..66494d29 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -19,4 +19,4 @@ PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,${BLUEZ}"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "c9ed3c49e3884ffad899d7ae28b2480691824228"
+SRCREV = "a3aa995332c3afdba6e56527263363ac593f6f58"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 579be84f..db416497 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -33,6 +33,6 @@ do_install_append_class-nativesdk() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}"
-SRCREV = "41e15cb21c2f8924eee56aacc4ba8aace950cae5"
+SRCREV = "878a17729b4cdaf0a7989d3e5fe22b058c1715d4"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtimageformats_git.bb b/recipes-qt/qt5/qtimageformats_git.bb
index 75391148..9cc64027 100644
--- a/recipes-qt/qt5/qtimageformats_git.bb
+++ b/recipes-qt/qt5/qtimageformats_git.bb
@@ -25,4 +25,4 @@ PACKAGECONFIG[libwebp] = ",CONFIG+=done_config_libwebp,libwebp"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "3e081dbc87eb3872197f56ddea8f55edf9c8aa3b"
+SRCREV = "4783c6dc4441ab833050a08996d40d959960ecff"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index 47ef7f25..f885ca1b 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -37,4 +37,4 @@ SRC_URI += "\
# http://errors.yoctoproject.org/Errors/Build/44914/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "7750d9014ee38cffe349af5c50f715774e7b1982"
+SRCREV = "30cbbd98e7159de08bb71ab4332dbd0bab19eba5"
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb
index 80f4f2f6..9b104684 100644
--- a/recipes-qt/qt5/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols2_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative qtdeclarative-native"
-SRCREV = "700b5d89a1040faba1145999e64ce31e37d5b782"
+SRCREV = "2876332ad911b3c0402006ca9116af66cecdb8eb"
diff --git a/recipes-qt/qt5/qtquickcontrols_git.bb b/recipes-qt/qt5/qtquickcontrols_git.bb
index 73fa87ae..c6e92811 100644
--- a/recipes-qt/qt5/qtquickcontrols_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols_git.bb
@@ -17,4 +17,4 @@ FILES_${PN}-qmlplugins += " \
${OE_QMAKE_PATH_QML}/QtQuick/Dialogs/qml/icons.ttf \
"
-SRCREV = "352be75dec15cb333f58d0075d89b2ebc7a2e46b"
+SRCREV = "c345d1ddf66fa73660a299826b9e3a3328519bed"
diff --git a/recipes-qt/qt5/qtscript/0001-3rdparty-javascriptcore-Add-RISC-V-support.patch b/recipes-qt/qt5/qtscript/0001-3rdparty-javascriptcore-Add-RISC-V-support.patch
deleted file mode 100644
index 94f03a31..00000000
--- a/recipes-qt/qt5/qtscript/0001-3rdparty-javascriptcore-Add-RISC-V-support.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From a67b00eb05abcb5242ee21049400a1e4a033389f Mon Sep 17 00:00:00 2001
-From: Alistair Francis <alistair.francis@wdc.com>
-Date: Wed, 18 Jul 2018 14:26:21 -0700
-Subject: [PATCH] 3rdparty/javascriptcore: Add RISC-V support
-
-Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
-Change-Id: I81f15084ef6b5b8d855c1f568cacca176af51b57
-Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
-
-Upstream-Status: Backport
----
- .../javascriptcore/JavaScriptCore/wtf/Platform.h | 14 ++++++++++++--
- 1 file changed, 12 insertions(+), 2 deletions(-)
-
-diff --git a/src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h b/src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h
-index 00caa6d..96942c7 100644
---- a/src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h
-+++ b/src/3rdparty/javascriptcore/JavaScriptCore/wtf/Platform.h
-@@ -397,6 +397,16 @@
- #endif
- #endif /* __mips__ */
-
-+/* CPU(RISCV64) - RISC-V 64-bit */
-+#if defined(__riscv) && __riscv_xlen == 64
-+#define WTF_CPU_RISCV64 1
-+#endif
-+
-+/* CPU(RISCV32) - RISC-V 32-bit */
-+#if defined(__riscv) && __riscv_xlen == 32
-+#define WTF_CPU_RISCV32 1
-+#endif
-+
- /* ==== OS() - underlying operating system; only to be used for mandated low-level services like
- virtual memory, not to choose a GUI toolkit ==== */
-
-@@ -948,9 +958,9 @@
- #endif
-
- #if !defined(WTF_USE_JSVALUE64) && !defined(WTF_USE_JSVALUE32) && !defined(WTF_USE_JSVALUE32_64)
--#if (CPU(X86_64) && !CPU(X32) && (OS(UNIX) || OS(WINDOWS) || OS(SOLARIS) || OS(HPUX))) || (CPU(IA64) && !CPU(IA64_32)) || CPU(ALPHA) || CPU(AIX64) || CPU(SPARC64) || CPU(MIPS64) || CPU(AARCH64)
-+#if (CPU(X86_64) && !CPU(X32) && (OS(UNIX) || OS(WINDOWS) || OS(SOLARIS) || OS(HPUX))) || (CPU(IA64) && !CPU(IA64_32)) || CPU(ALPHA) || CPU(AIX64) || CPU(SPARC64) || CPU(MIPS64) || CPU(AARCH64) || CPU(RISCV64)
- #define WTF_USE_JSVALUE64 1
--#elif CPU(ARM) || CPU(PPC64)
-+#elif CPU(ARM) || CPU(PPC64) || CPU(RISCV32)
- #define WTF_USE_JSVALUE32 1
- #elif OS(WINDOWS) && COMPILER(MINGW)
- /* Using JSVALUE32_64 causes padding/alignement issues for JITStubArg
diff --git a/recipes-qt/qt5/qtscript_git.bb b/recipes-qt/qt5/qtscript_git.bb
index d9aadc40..851d5b15 100644
--- a/recipes-qt/qt5/qtscript_git.bb
+++ b/recipes-qt/qt5/qtscript_git.bb
@@ -14,7 +14,6 @@ LIC_FILES_CHKSUM = " \
# Patches from https://github.com/meta-qt5/qtscript/commits/b5.11
# 5.11.meta-qt5.1
SRC_URI += " \
- file://0001-3rdparty-javascriptcore-Add-RISC-V-support.patch \
file://0002-Include-asm-sgidefs.h-on-non-glibc-systems.patch \
"
@@ -37,4 +36,4 @@ DEPENDS += "qtbase"
# http://errors.yoctoproject.org/Errors/Build/44915/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "42742b847213f7041fc686d7e15182c4669f897d"
+SRCREV = "9b0fcf7943e63f35cf7d13c7771cb0185178e9fa"
diff --git a/recipes-qt/qt5/qtserialbus_git.bb b/recipes-qt/qt5/qtserialbus_git.bb
index 315f9dd0..d8ed104b 100644
--- a/recipes-qt/qt5/qtserialbus_git.bb
+++ b/recipes-qt/qt5/qtserialbus_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtserialport"
-SRCREV = "7577cd3fa7ebfa35b199d485233f3b41cec79e46"
+SRCREV = "43a65b661f54755eb725e25112d62cb5eb726ac3"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index cf429279..06689b98 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -32,7 +32,7 @@ EXTRA_QMAKEVARS_PRE += " \
${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)} \
"
-SRCREV = "b29d3f5b5b189297e0412f832111a91ae40fad42"
+SRCREV = "54e8925e0997bb4606e4b5491d2d8e446db401ce"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 352e0185..c4d77ea5 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -37,7 +37,7 @@ PACKAGECONFIG[wayland-libhybris-egl-server-buffer] = "-feature-wayland-libhybris
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "43d12496c684b5f2b08c6a8c0b994f06efc25712"
+SRCREV = "4a328e3533f93ed65f9dc77f764b3cbe3c694266"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index d01cbfac..8ff546a9 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -174,8 +174,8 @@ SRC_URI_append_libc-musl = "\
file://chromium/0017-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get-__WORDSIZE-on.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "75f6f4d3178d9356aff9a5a14f8601ebc8b70c95"
-SRCREV_chromium = "3f8994c671d1cfc674ab64e118304b897a84762c"
+SRCREV_qtwebengine = "404201b9a41564512937a7d96e55d6b095bdcab0"
+SRCREV_chromium = "156c2b70ceef9a4464a5a241c9f816dea4fd3168"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"