aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-10-23 15:55:46 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2018-10-30 08:11:51 +0000
commitbfddeb7f34db5b1d1b73a787246ca28f8ad3575b (patch)
treead8d7e0e85bbf25772fe0a3d35e8c0045e23f336
parent11b63656bad9db24950d05901a8b1917bc5cb7f8 (diff)
qtwebengine: update chromium musl patchset
Change-Id: I792a600e354531f234a3ff641c030c119921f200 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0001-chromium-Force-host-toolchain-configuration.patch4
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0002-chromium-workaround-for-too-long-.rps-file-name.patch4
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0003-chromium-Fix-build-with-gcc8.patch8
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0004-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0005-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch35
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0006-chromium-musl-include-fcntl.h-for-loff_t.patch6
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0007-chromium-musl-use-off64_t-instead-of-the-internal-__.patch20
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0008-chromium-musl-linux-glibc-make-the-distinction.patch4
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0009-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch4
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0010-chromium-musl-Use-correct-member-name-__si_fields-fr.patch2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0011-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch6
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0012-chromium-musl-Do-not-define-__sbrk-on-musl.patch26
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0013-chromium-musl-Adjust-default-pthread-stack-size.patch14
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0014-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch2
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0015-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch23
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0016-chromium-musl-Use-_fpstate-instead-of-_libc_fpstate-on-linux.patch5
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0017-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get-__WORDSIZE-on.patch33
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb3
18 files changed, 66 insertions, 135 deletions
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0001-chromium-Force-host-toolchain-configuration.patch b/recipes-qt/qt5/qtwebengine/chromium/0001-chromium-Force-host-toolchain-configuration.patch
index 03ae406f..e2094a68 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0001-chromium-Force-host-toolchain-configuration.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0001-chromium-Force-host-toolchain-configuration.patch
@@ -1,4 +1,4 @@
-From b660e83be35d64ebf7961ec9b4d4ea42c4b9f679 Mon Sep 17 00:00:00 2001
+From 9a97eb31696f24ed9edd9193bf65a439cbcc1bc1 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Wed, 15 Mar 2017 13:53:28 +0200
Subject: [PATCH] chromium: Force host toolchain configuration
@@ -14,7 +14,7 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/gn/build/gen.py b/gn/build/gen.py
-index b677954..698b4e5 100755
+index 87db4c26bc..34c853b7f4 100755
--- a/gn/build/gen.py
+++ b/gn/build/gen.py
@@ -310,10 +310,10 @@ def WriteGNNinja(path, platform, host, options, linux_sysroot):
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0002-chromium-workaround-for-too-long-.rps-file-name.patch b/recipes-qt/qt5/qtwebengine/chromium/0002-chromium-workaround-for-too-long-.rps-file-name.patch
index 99c7112d..75958512 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0002-chromium-workaround-for-too-long-.rps-file-name.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0002-chromium-workaround-for-too-long-.rps-file-name.patch
@@ -1,4 +1,4 @@
-From 20b7ef92a1580409aa9ff10cfc16dd6865e451b7 Mon Sep 17 00:00:00 2001
+From b83ddad1ae371c3de893673cec86190b4c894c72 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Thu, 30 Mar 2017 11:37:24 +0300
Subject: [PATCH] chromium: workaround for too long .rps file name
@@ -18,7 +18,7 @@ Change-Id: I73c5e64ae5174412be2a675e35b0b6047f2bf4c1
1 file changed, 9 insertions(+)
diff --git a/gn/tools/gn/ninja_action_target_writer.cc b/gn/tools/gn/ninja_action_target_writer.cc
-index 7e945c0..3deb587 100644
+index 7e945c0de0..3deb587668 100644
--- a/gn/tools/gn/ninja_action_target_writer.cc
+++ b/gn/tools/gn/ninja_action_target_writer.cc
@@ -118,9 +118,18 @@ std::string NinjaActionTargetWriter::WriteRuleDefinition() {
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0003-chromium-Fix-build-with-gcc8.patch b/recipes-qt/qt5/qtwebengine/chromium/0003-chromium-Fix-build-with-gcc8.patch
index a6c859ec..cbde56a4 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0003-chromium-Fix-build-with-gcc8.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0003-chromium-Fix-build-with-gcc8.patch
@@ -1,4 +1,4 @@
-From 4a8e2acea8759c6eafa22d325f6c2e27862404de Mon Sep 17 00:00:00 2001
+From 301d74843b0e897dccfe1c32f27c5b3c608446ae Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Tue, 5 Jun 2018 13:58:16 +0000
Subject: [PATCH] chromium: Fix build with gcc8
@@ -10,7 +10,7 @@ Subject: [PATCH] chromium: Fix build with gcc8
3 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/chromium/mojo/public/c/system/buffer.h b/chromium/mojo/public/c/system/buffer.h
-index 2cc5427..917415f 100644
+index 2cc54270ad..917415f8db 100644
--- a/chromium/mojo/public/c/system/buffer.h
+++ b/chromium/mojo/public/c/system/buffer.h
@@ -30,7 +30,7 @@ struct MOJO_ALIGNAS(8) MojoCreateSharedBufferOptions {
@@ -23,7 +23,7 @@ index 2cc5427..917415f 100644
"MojoCreateSharedBufferOptions has wrong size");
diff --git a/chromium/mojo/public/c/system/data_pipe.h b/chromium/mojo/public/c/system/data_pipe.h
-index 3702cdb..a86c8e8 100644
+index 3702cdb624..a86c8e8b32 100644
--- a/chromium/mojo/public/c/system/data_pipe.h
+++ b/chromium/mojo/public/c/system/data_pipe.h
@@ -40,7 +40,7 @@ struct MOJO_ALIGNAS(8) MojoCreateDataPipeOptions {
@@ -36,7 +36,7 @@ index 3702cdb..a86c8e8 100644
"MojoCreateDataPipeOptions has wrong size");
diff --git a/chromium/mojo/public/c/system/message_pipe.h b/chromium/mojo/public/c/system/message_pipe.h
-index 9f222f9..4878774 100644
+index 9f222f9aa8..4878774707 100644
--- a/chromium/mojo/public/c/system/message_pipe.h
+++ b/chromium/mojo/public/c/system/message_pipe.h
@@ -35,7 +35,7 @@ struct MOJO_ALIGNAS(8) MojoCreateMessagePipeOptions {
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0004-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch b/recipes-qt/qt5/qtwebengine/chromium/0004-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch
index 77f3f999..c8b18f5f 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0004-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0004-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch
@@ -1,4 +1,4 @@
-From 7dbbfa0804a902c18534cf8bdcebc07d26496585 Mon Sep 17 00:00:00 2001
+From 71bb7a3ab845c554e3b59d538666641d350e9a85 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 7 Jul 2017 14:01:12 -0700
Subject: [PATCH] chromium: musl: sandbox: Define TEMP_FAILURE_RETRY if not
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0005-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch b/recipes-qt/qt5/qtwebengine/chromium/0005-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch
index 3396b7f7..0c1b2017 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0005-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0005-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch
@@ -1,4 +1,4 @@
-From d886de89a3afad81d0b3ac012098d064eb00d8ed Mon Sep 17 00:00:00 2001
+From 22a60b7403ba8404e2936caf9126c6c666fa577b Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 7 Jul 2017 14:09:06 -0700
Subject: [PATCH] chromium: musl: Avoid mallinfo() APIs on non-glibc/linux
@@ -6,15 +6,14 @@ Subject: [PATCH] chromium: musl: Avoid mallinfo() APIs on non-glibc/linux
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
chromium/base/process/process_metrics_posix.cc | 4 ++--
- chromium/base/trace_event/malloc_dump_provider.cc | 3 ++-
- chromium/content/child/content_child_helpers.cc | 2 +-
- 3 files changed, 5 insertions(+), 4 deletions(-)
+ chromium/base/trace_event/malloc_dump_provider.cc | 2 ++
+ 2 files changed, 4 insertions(+), 2 deletions(-)
diff --git a/chromium/base/process/process_metrics_posix.cc b/chromium/base/process/process_metrics_posix.cc
-index 73a52d6210..4867198a50 100644
+index a09bbf2c56..b309f6b694 100644
--- a/chromium/base/process/process_metrics_posix.cc
+++ b/chromium/base/process/process_metrics_posix.cc
-@@ -94,14 +94,14 @@ size_t ProcessMetrics::GetMallocUsage() {
+@@ -100,14 +100,14 @@ size_t ProcessMetrics::GetMallocUsage() {
malloc_statistics_t stats = {0};
malloc_zone_statistics(nullptr, &stats);
return stats.size_in_use;
@@ -32,10 +31,10 @@ index 73a52d6210..4867198a50 100644
return 0;
#endif
diff --git a/chromium/base/trace_event/malloc_dump_provider.cc b/chromium/base/trace_event/malloc_dump_provider.cc
-index ffd519133c..0c9131e98e 100644
+index 46fdb3e214..27936e6b20 100644
--- a/chromium/base/trace_event/malloc_dump_provider.cc
+++ b/chromium/base/trace_event/malloc_dump_provider.cc
-@@ -197,6 +197,7 @@ MallocDumpProvider::~MallocDumpProvider() = default;
+@@ -77,6 +77,7 @@ MallocDumpProvider::~MallocDumpProvider() = default;
// the current process.
bool MallocDumpProvider::OnMemoryDump(const MemoryDumpArgs& args,
ProcessMemoryDump* pmd) {
@@ -43,25 +42,11 @@ index ffd519133c..0c9131e98e 100644
{
base::AutoLock auto_lock(emit_metrics_on_memory_dump_lock_);
if (!emit_metrics_on_memory_dump_)
-@@ -322,7 +323,7 @@ bool MallocDumpProvider::OnMemoryDump(const MemoryDumpArgs& args,
- pmd->DumpHeapUsage(metrics_by_context, overhead, "malloc");
+@@ -172,6 +173,7 @@ bool MallocDumpProvider::OnMemoryDump(const MemoryDumpArgs& args,
+ MemoryAllocatorDump::kUnitsBytes,
+ resident_size - allocated_objects_size);
}
- tid_dumping_heap_ = kInvalidThreadId;
--
+#endif // __GLIBC__
return true;
}
-diff --git a/chromium/content/child/content_child_helpers.cc b/chromium/content/child/content_child_helpers.cc
-index 7ddeb4d16a..b8c73b09c5 100644
---- a/chromium/content/child/content_child_helpers.cc
-+++ b/chromium/content/child/content_child_helpers.cc
-@@ -25,7 +25,7 @@ namespace content {
- // though, this provides only a partial and misleading value.
- // Unfortunately some telemetry benchmark rely on it and these need to
- // be refactored before getting rid of this. See crbug.com/581365 .
--#if defined(OS_LINUX) || defined(OS_ANDROID)
-+#if defined(__GLIBC__) || defined(OS_ANDROID)
- size_t GetMemoryUsageKB() {
- struct mallinfo minfo = mallinfo();
- uint64_t mem_usage =
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0006-chromium-musl-include-fcntl.h-for-loff_t.patch b/recipes-qt/qt5/qtwebengine/chromium/0006-chromium-musl-include-fcntl.h-for-loff_t.patch
index 79a18323..80f7d5f7 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0006-chromium-musl-include-fcntl.h-for-loff_t.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0006-chromium-musl-include-fcntl.h-for-loff_t.patch
@@ -1,4 +1,4 @@
-From 58362949631d043f72711b1c990cb71d9206caa0 Mon Sep 17 00:00:00 2001
+From 34d37948df08f250aaf31125c40f088b1d0d2aa0 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 7 Jul 2017 14:37:49 -0700
Subject: [PATCH] chromium: musl: include fcntl.h for loff_t
@@ -9,10 +9,10 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
1 file changed, 1 insertion(+)
diff --git a/chromium/third_party/tcmalloc/chromium/src/base/linux_syscall_support.h b/chromium/third_party/tcmalloc/chromium/src/base/linux_syscall_support.h
-index b29ec2d29a..91f77dd88d 100644
+index 13aa415e25..9d1309b836 100644
--- a/chromium/third_party/tcmalloc/chromium/src/base/linux_syscall_support.h
+++ b/chromium/third_party/tcmalloc/chromium/src/base/linux_syscall_support.h
-@@ -150,6 +150,7 @@ extern "C" {
+@@ -154,6 +154,7 @@ extern "C" {
#include <stddef.h>
#include <stdint.h>
#include <string.h>
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0007-chromium-musl-use-off64_t-instead-of-the-internal-__.patch b/recipes-qt/qt5/qtwebengine/chromium/0007-chromium-musl-use-off64_t-instead-of-the-internal-__.patch
index ec1a5676..e98074d9 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0007-chromium-musl-use-off64_t-instead-of-the-internal-__.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0007-chromium-musl-use-off64_t-instead-of-the-internal-__.patch
@@ -1,4 +1,4 @@
-From ac37250356e2923572e33491198f27117d4afa6a Mon Sep 17 00:00:00 2001
+From 52ba569d06e28de9fec463481411792661d66d9e Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 7 Jul 2017 14:38:37 -0700
Subject: [PATCH] chromium: musl: use off64_t instead of the internal __off64_t
@@ -12,19 +12,19 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/chromium/third_party/tcmalloc/chromium/src/malloc_hook_mmap_linux.h b/chromium/third_party/tcmalloc/chromium/src/malloc_hook_mmap_linux.h
-index 715c045f66..edc8cf2db7 100644
+index 2f6116fa45..7486a05a27 100755
--- a/chromium/third_party/tcmalloc/chromium/src/malloc_hook_mmap_linux.h
+++ b/chromium/third_party/tcmalloc/chromium/src/malloc_hook_mmap_linux.h
-@@ -77,7 +77,7 @@ typedef off64_t __off64_t;
+@@ -60,7 +60,7 @@
static inline void* do_mmap64(void *start, size_t length,
int prot, int flags,
- int fd, __off64_t offset) __THROW {
+ int fd, off64_t offset) __THROW {
- // The original gperftools uses sys_mmap() here. But, it is not allowed by
- // Chromium's sandbox.
- return (void *)syscall(SYS_mmap, start, length, prot, flags, fd, offset);
-@@ -90,7 +90,7 @@ static inline void* do_mmap64(void *start, size_t length,
+ return sys_mmap(start, length, prot, flags, fd, offset);
+ }
+
+@@ -71,7 +71,7 @@ static inline void* do_mmap64(void *start, size_t length,
static inline void* do_mmap64(void *start, size_t length,
int prot, int flags,
@@ -33,7 +33,7 @@ index 715c045f66..edc8cf2db7 100644
void *result;
// Try mmap2() unless it's not supported
-@@ -161,7 +161,7 @@ static inline void* do_mmap64(void *start, size_t length,
+@@ -142,7 +142,7 @@ static inline void* do_mmap64(void *start, size_t length,
extern "C" {
void* mmap64(void *start, size_t length, int prot, int flags,
@@ -42,7 +42,7 @@ index 715c045f66..edc8cf2db7 100644
ATTRIBUTE_SECTION(malloc_hook);
void* mmap(void *start, size_t length,int prot, int flags,
int fd, off_t offset) __THROW
-@@ -178,7 +178,7 @@ extern "C" {
+@@ -157,7 +157,7 @@ extern "C" {
}
extern "C" void* mmap64(void *start, size_t length, int prot, int flags,
@@ -51,7 +51,7 @@ index 715c045f66..edc8cf2db7 100644
MallocHook::InvokePreMmapHook(start, length, prot, flags, fd, offset);
void *result;
if (!MallocHook::InvokeMmapReplacement(
-@@ -189,7 +189,7 @@ extern "C" void* mmap64(void *start, size_t length, int prot, int flags,
+@@ -168,7 +168,7 @@ extern "C" void* mmap64(void *start, size_t length, int prot, int flags,
return result;
}
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0008-chromium-musl-linux-glibc-make-the-distinction.patch b/recipes-qt/qt5/qtwebengine/chromium/0008-chromium-musl-linux-glibc-make-the-distinction.patch
index ec49539d..5e60ce45 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0008-chromium-musl-linux-glibc-make-the-distinction.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0008-chromium-musl-linux-glibc-make-the-distinction.patch
@@ -1,4 +1,4 @@
-From d9875480e5ab9b72b6e30ba5154bc90c63fea9fa Mon Sep 17 00:00:00 2001
+From 7f8e9ac3c1018b198574a60b3be444b0ae6433d5 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 7 Jul 2017 14:54:38 -0700
Subject: [PATCH] chromium: musl: linux != glibc, make the distinction
@@ -9,7 +9,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/chromium/base/allocator/allocator_check.cc b/chromium/base/allocator/allocator_check.cc
-index 9cd5d2207d..1e70095648 100644
+index a17ff21733..9f6175ad1d 100644
--- a/chromium/base/allocator/allocator_check.cc
+++ b/chromium/base/allocator/allocator_check.cc
@@ -27,7 +27,7 @@ bool IsAllocatorInitialized() {
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0009-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch b/recipes-qt/qt5/qtwebengine/chromium/0009-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch
index f0627f56..b1b9f076 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0009-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0009-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch
@@ -1,4 +1,4 @@
-From e78ef57ef202bcf101a2dadb694ab38f02927151 Mon Sep 17 00:00:00 2001
+From c071a51e75e370c432bf4348fdda2b794927c896 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 7 Jul 2017 15:09:02 -0700
Subject: [PATCH] chromium: musl: allocator: Do not include glibc_weak_symbols
@@ -10,7 +10,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/chromium/base/allocator/allocator_shim.cc b/chromium/base/allocator/allocator_shim.cc
-index 4b7de5e1a3..fe565223f2 100644
+index e919f094c3..414a21d32a 100644
--- a/chromium/base/allocator/allocator_shim.cc
+++ b/chromium/base/allocator/allocator_shim.cc
@@ -302,7 +302,7 @@ ALWAYS_INLINE void ShimFreeDefiniteSize(void* ptr, size_t size, void* context) {
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0010-chromium-musl-Use-correct-member-name-__si_fields-fr.patch b/recipes-qt/qt5/qtwebengine/chromium/0010-chromium-musl-Use-correct-member-name-__si_fields-fr.patch
index 2dde67b3..4e426e07 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0010-chromium-musl-Use-correct-member-name-__si_fields-fr.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0010-chromium-musl-Use-correct-member-name-__si_fields-fr.patch
@@ -1,4 +1,4 @@
-From 4c6d3018b3a96e322c74f3998d10c4d28c813e50 Mon Sep 17 00:00:00 2001
+From b082f048a5789f7ab6466c84d7e955a4f2c03d03 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 7 Jul 2017 15:12:39 -0700
Subject: [PATCH] chromium: musl: Use correct member name __si_fields from
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0011-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch b/recipes-qt/qt5/qtwebengine/chromium/0011-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch
index 63fd9bf3..d4fc2bbc 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0011-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0011-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch
@@ -1,4 +1,4 @@
-From ff6be9a301b7d831c95fe7b10c34783433abd6df Mon Sep 17 00:00:00 2001
+From bec65d7ea2899131007b46336d4a1df1e59709df Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 7 Jul 2017 15:27:50 -0700
Subject: [PATCH] chromium: musl: Define res_ninit and res_nclose for non-glibc
@@ -13,7 +13,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
create mode 100644 chromium/net/dns/resolv_compat.h
diff --git a/chromium/net/dns/dns_config_service_posix.cc b/chromium/net/dns/dns_config_service_posix.cc
-index f2e66331e3..6fe84dd66a 100644
+index 06e9d7969c..8e18a297a9 100644
--- a/chromium/net/dns/dns_config_service_posix.cc
+++ b/chromium/net/dns/dns_config_service_posix.cc
@@ -27,6 +27,10 @@
@@ -28,7 +28,7 @@ index f2e66331e3..6fe84dd66a 100644
#include "net/dns/dns_config_watcher_mac.h"
#endif
diff --git a/chromium/net/dns/dns_reloader.cc b/chromium/net/dns/dns_reloader.cc
-index 322c8a5f0f..72ff40dbe1 100644
+index ad96f681cc..334ff59ad7 100644
--- a/chromium/net/dns/dns_reloader.cc
+++ b/chromium/net/dns/dns_reloader.cc
@@ -9,6 +9,10 @@
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0012-chromium-musl-Do-not-define-__sbrk-on-musl.patch b/recipes-qt/qt5/qtwebengine/chromium/0012-chromium-musl-Do-not-define-__sbrk-on-musl.patch
deleted file mode 100644
index aa0a9dcd..00000000
--- a/recipes-qt/qt5/qtwebengine/chromium/0012-chromium-musl-Do-not-define-__sbrk-on-musl.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From b836ce7350f40f9f031835f71793788d922452bd Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Fri, 7 Jul 2017 15:39:57 -0700
-Subject: [PATCH] chromium: musl: Do not define __sbrk on musl
-
-musl libc does not have sbrk. on musl libc will only work when called with 0 as
-argument, so we just let it out for now
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- .../third_party/tcmalloc/chromium/src/malloc_hook_mmap_linux.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/chromium/third_party/tcmalloc/chromium/src/malloc_hook_mmap_linux.h b/chromium/third_party/tcmalloc/chromium/src/malloc_hook_mmap_linux.h
-index edc8cf2db7..a868b50d30 100644
---- a/chromium/third_party/tcmalloc/chromium/src/malloc_hook_mmap_linux.h
-+++ b/chromium/third_party/tcmalloc/chromium/src/malloc_hook_mmap_linux.h
-@@ -233,7 +233,7 @@ extern "C" void* mremap(void* old_addr, size_t old_size, size_t new_size,
- }
-
- // Don't hook sbrk() in Android, since it doesn't expose __sbrk.
--#if !defined(__ANDROID__)
-+#if !defined(__ANDROID__) && defined(__GLIBC__)
- // libc's version:
- extern "C" void* __sbrk(ptrdiff_t increment);
-
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0013-chromium-musl-Adjust-default-pthread-stack-size.patch b/recipes-qt/qt5/qtwebengine/chromium/0013-chromium-musl-Adjust-default-pthread-stack-size.patch
index 2c91413e..844b2da1 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0013-chromium-musl-Adjust-default-pthread-stack-size.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0013-chromium-musl-Adjust-default-pthread-stack-size.patch
@@ -1,4 +1,4 @@
-From 90d3755c55e3fbda3a4eba7aec481da4f22e044e Mon Sep 17 00:00:00 2001
+From dcfd333f7c6c19fc2e206637683a3b0e90ed6c83 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 7 Jul 2017 16:41:23 -0700
Subject: [PATCH] chromium: musl: Adjust default pthread stack size
@@ -6,11 +6,11 @@ Subject: [PATCH] chromium: musl: Adjust default pthread stack size
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
chromium/base/threading/platform_thread_linux.cc | 3 ++-
- chromium/third_party/WebKit/Source/platform/wtf/StackUtil.cpp | 4 ++--
+ .../third_party/blink/renderer/platform/wtf/stack_util.cc | 4 ++--
2 files changed, 4 insertions(+), 3 deletions(-)
diff --git a/chromium/base/threading/platform_thread_linux.cc b/chromium/base/threading/platform_thread_linux.cc
-index 9917a7b1fd..cb406659b9 100644
+index 190acedf7c..343e1a8c61 100644
--- a/chromium/base/threading/platform_thread_linux.cc
+++ b/chromium/base/threading/platform_thread_linux.cc
@@ -173,7 +173,8 @@ void TerminateOnThread() {}
@@ -23,10 +23,10 @@ index 9917a7b1fd..cb406659b9 100644
#else
// ThreadSanitizer bloats the stack heavily. Evidence has been that the
// default stack size isn't enough for some browser tests.
-diff --git a/chromium/third_party/WebKit/Source/platform/wtf/StackUtil.cpp b/chromium/third_party/WebKit/Source/platform/wtf/StackUtil.cpp
-index 13c3f907f8..07308e0835 100644
---- a/chromium/third_party/WebKit/Source/platform/wtf/StackUtil.cpp
-+++ b/chromium/third_party/WebKit/Source/platform/wtf/StackUtil.cpp
+diff --git a/chromium/third_party/blink/renderer/platform/wtf/stack_util.cc b/chromium/third_party/blink/renderer/platform/wtf/stack_util.cc
+index 10f1c0df11..8e86a2eb1e 100644
+--- a/chromium/third_party/blink/renderer/platform/wtf/stack_util.cc
++++ b/chromium/third_party/blink/renderer/platform/wtf/stack_util.cc
@@ -28,7 +28,7 @@ size_t GetUnderestimatedStackSize() {
// FIXME: On Mac OSX and Linux, this method cannot estimate stack size
// correctly for the main thread.
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0014-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch b/recipes-qt/qt5/qtwebengine/chromium/0014-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch
index 9bb01e17..1036d943 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0014-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0014-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch
@@ -1,4 +1,4 @@
-From 389967c783f65b39663dae273abe703e6d195c4d Mon Sep 17 00:00:00 2001
+From e9a71c8bc66cd4ae996a81130ec9995cd1121b2a Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Fri, 7 Jul 2017 17:15:34 -0700
Subject: [PATCH] chromium: musl: include asm-generic/ioctl.h for TCGETS2
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0015-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch b/recipes-qt/qt5/qtwebengine/chromium/0015-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch
deleted file mode 100644
index 1ab91150..00000000
--- a/recipes-qt/qt5/qtwebengine/chromium/0015-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 851216b2a9a10a9fe924a84693fd2b44fc16f464 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Sat, 8 Jul 2017 09:08:23 -0700
-Subject: [PATCH] chromium: musl: tcmalloc: Use off64_t insread of __off64_t
-
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- .../tcmalloc/chromium/src/base/linux_syscall_support.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/chromium/third_party/tcmalloc/chromium/src/base/linux_syscall_support.h b/chromium/third_party/tcmalloc/chromium/src/base/linux_syscall_support.h
-index 91f77dd88d..bb84a0b305 100644
---- a/chromium/third_party/tcmalloc/chromium/src/base/linux_syscall_support.h
-+++ b/chromium/third_party/tcmalloc/chromium/src/base/linux_syscall_support.h
-@@ -1929,7 +1929,7 @@ typedef unsigned long int ulong;
- #if defined(__x86_64__)
- /* Need to make sure __off64_t isn't truncated to 32-bits under x32. */
- LSS_INLINE void* LSS_NAME(mmap)(void *s, size_t l, int p, int f, int d,
-- __off64_t o) {
-+ off64_t o) {
- LSS_BODY(6, void*, mmap, LSS_SYSCALL_ARG(s), LSS_SYSCALL_ARG(l),
- LSS_SYSCALL_ARG(p), LSS_SYSCALL_ARG(f),
- LSS_SYSCALL_ARG(d), (uint64_t)(o));
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0016-chromium-musl-Use-_fpstate-instead-of-_libc_fpstate-on-linux.patch b/recipes-qt/qt5/qtwebengine/chromium/0016-chromium-musl-Use-_fpstate-instead-of-_libc_fpstate-on-linux.patch
index 2be0cb07..db52d77b 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0016-chromium-musl-Use-_fpstate-instead-of-_libc_fpstate-on-linux.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0016-chromium-musl-Use-_fpstate-instead-of-_libc_fpstate-on-linux.patch
@@ -1,4 +1,4 @@
-From cd92f771ac37ae41d7a1abfd6fcc9d50aa7529d8 Mon Sep 17 00:00:00 2001
+From 5d74f21ea59cc3a2ed214b83432a634d93140c3f Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Tue, 25 Sep 2018 12:35:07 -0700
Subject: [PATCH] Use _fpstate instead of _libc_fpstate on linux
@@ -60,6 +60,3 @@ index d1dc331215..d1cc5624cd 100644
#endif
// These entries store a list of memory regions that the client wants included
---
-2.19.0
-
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0017-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get-__WORDSIZE-on.patch b/recipes-qt/qt5/qtwebengine/chromium/0017-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get-__WORDSIZE-on.patch
index 6f34473d..da890915 100644
--- a/recipes-qt/qt5/qtwebengine/chromium/0017-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get-__WORDSIZE-on.patch
+++ b/recipes-qt/qt5/qtwebengine/chromium/0017-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get-__WORDSIZE-on.patch
@@ -1,4 +1,4 @@
-From 986bf2ecd7b450dceff5cb0f3f76fe886b58d884 Mon Sep 17 00:00:00 2001
+From e6b0d8e952706f450ba6204ffe894330f2087f86 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Tue, 25 Sep 2018 12:59:05 -0700
Subject: [PATCH] elf_reader.cc: include <sys/reg.h> to get __WORDSIZE on musl
@@ -6,14 +6,15 @@ Subject: [PATCH] elf_reader.cc: include <sys/reg.h> to get __WORDSIZE on musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
- chromium/third_party/breakpad/breakpad/configure.ac | 2 +-
- .../breakpad/breakpad/src/common/dwarf/elf_reader.cc | 5 ++++-
- 2 files changed, 5 insertions(+), 2 deletions(-)
+ chromium/third_party/breakpad/breakpad/configure.ac | 2 +-
+ .../breakpad/breakpad/src/common/dwarf/elf_reader.cc | 3 ++-
+ .../breakpad/breakpad/src/common/linux/elf_core_dump.h | 1 +
+ 3 files changed, 4 insertions(+), 2 deletions(-)
-Index: 3rdparty/chromium/third_party/breakpad/breakpad/configure.ac
-===================================================================
---- 3rdparty.orig/chromium/third_party/breakpad/breakpad/configure.ac
-+++ 3rdparty/chromium/third_party/breakpad/breakpad/configure.ac
+diff --git a/chromium/third_party/breakpad/breakpad/configure.ac b/chromium/third_party/breakpad/breakpad/configure.ac
+index 9cca5aa069..04139a728c 100644
+--- a/chromium/third_party/breakpad/breakpad/configure.ac
++++ b/chromium/third_party/breakpad/breakpad/configure.ac
@@ -72,7 +72,7 @@ AC_ARG_ENABLE(m32,
AC_HEADER_STDC
AC_SYS_LARGEFILE
@@ -23,10 +24,10 @@ Index: 3rdparty/chromium/third_party/breakpad/breakpad/configure.ac
AC_CHECK_FUNCS([arc4random getrandom])
AX_CXX_COMPILE_STDCXX(11, noext, mandatory)
-Index: 3rdparty/chromium/third_party/breakpad/breakpad/src/common/dwarf/elf_reader.cc
-===================================================================
---- 3rdparty.orig/chromium/third_party/breakpad/breakpad/src/common/dwarf/elf_reader.cc
-+++ 3rdparty/chromium/third_party/breakpad/breakpad/src/common/dwarf/elf_reader.cc
+diff --git a/chromium/third_party/breakpad/breakpad/src/common/dwarf/elf_reader.cc b/chromium/third_party/breakpad/breakpad/src/common/dwarf/elf_reader.cc
+index 4135a51a98..be92b792d3 100644
+--- a/chromium/third_party/breakpad/breakpad/src/common/dwarf/elf_reader.cc
++++ b/chromium/third_party/breakpad/breakpad/src/common/dwarf/elf_reader.cc
@@ -29,10 +29,11 @@
#ifndef _GNU_SOURCE
#define _GNU_SOURCE // needed for pread()
@@ -40,10 +41,10 @@ Index: 3rdparty/chromium/third_party/breakpad/breakpad/src/common/dwarf/elf_read
#include <unistd.h>
#include <fcntl.h>
#include <string.h>
-Index: 3rdparty/chromium/third_party/breakpad/breakpad/src/common/linux/elf_core_dump.h
-===================================================================
---- 3rdparty.orig/chromium/third_party/breakpad/breakpad/src/common/linux/elf_core_dump.h
-+++ 3rdparty/chromium/third_party/breakpad/breakpad/src/common/linux/elf_core_dump.h
+diff --git a/chromium/third_party/breakpad/breakpad/src/common/linux/elf_core_dump.h b/chromium/third_party/breakpad/breakpad/src/common/linux/elf_core_dump.h
+index d03c7a88d3..28b55ab630 100644
+--- a/chromium/third_party/breakpad/breakpad/src/common/linux/elf_core_dump.h
++++ b/chromium/third_party/breakpad/breakpad/src/common/linux/elf_core_dump.h
@@ -33,6 +33,7 @@
#ifndef COMMON_LINUX_ELF_CORE_DUMP_H_
#define COMMON_LINUX_ELF_CORE_DUMP_H_
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index de606923..b4e0bd4d 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -111,7 +111,6 @@ do_configure_prepend_libc-musl() {
for f in `find ${S}/src/3rdparty/chromium/third_party/ffmpeg/chromium/config/Chromium/linux/ -name config.h -o -name config.asm`; do
sed -i -e "s:define HAVE_SYSCTL 1:define HAVE_SYSCTL 0:g" $f
done
- sed -i -e "s:define HAVE_STRUCT_MALLINFO 1:/*undef HAVE_STRUCT_MALLINFO */:g" ${S}/src/3rdparty/chromium/third_party/tcmalloc/chromium/src/config_linux.h
}
do_compile[progress] = "outof:^\[(\d+)/(\d+)\]\s+"
@@ -165,10 +164,8 @@ SRC_URI_append_libc-musl = "\
file://chromium/0009-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch;patchdir=src/3rdparty \
file://chromium/0010-chromium-musl-Use-correct-member-name-__si_fields-fr.patch;patchdir=src/3rdparty \
file://chromium/0011-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch;patchdir=src/3rdparty \
- file://chromium/0012-chromium-musl-Do-not-define-__sbrk-on-musl.patch;patchdir=src/3rdparty \
file://chromium/0013-chromium-musl-Adjust-default-pthread-stack-size.patch;patchdir=src/3rdparty \
file://chromium/0014-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch;patchdir=src/3rdparty \
- file://chromium/0015-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch;patchdir=src/3rdparty \
file://chromium/0016-chromium-musl-Use-_fpstate-instead-of-_libc_fpstate-on-linux.patch;patchdir=src/3rdparty \
file://chromium/0017-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get-__WORDSIZE-on.patch;patchdir=src/3rdparty \
"