aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2019-02-13 09:30:34 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2019-02-14 10:00:36 +0000
commit356ff007aa53439fbeb44798e550386f6f9194af (patch)
treea7ac044a5cab7239b0505d0edeb75c0acee575ea
parent7935b6bd03aafb7e238e623bdca832d1437b923a (diff)
qt5: update submodules
Update to latest content in Qt 5.12.2 branch Task-number: QTBUG-73533 Change-Id: I9bbbf6ce3992ac834c8f060e0f059e8ae35c4966 Reviewed-by: Sami Nurmenniemi <sami.nurmenniemi@qt.io>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch16
-rw-r--r--recipes-qt/qt5/qt3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb2
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtnetworkauth_git.bb2
-rw-r--r--recipes-qt/qt5/qtpurchasing_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols2_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols_git.bb2
-rw-r--r--recipes-qt/qt5/qtremoteobjects_git.bb2
-rw-r--r--recipes-qt/qt5/qtsvg_git.bb2
-rw-r--r--recipes-qt/qt5/qttools_git.bb2
-rw-r--r--recipes-qt/qt5/qttranslations_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb4
-rw-r--r--recipes-qt/qt5/qtwebglplugin_git.bb2
20 files changed, 29 insertions, 27 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index cef46a9a..376fbbbe 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -193,4 +193,4 @@ fakeroot do_generate_qt_environment_file() {
do_generate_qt_environment_file[umask] = "022"
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "850c922036b7eebc24cdb74a43a4b31319d924c7"
+SRCREV = "81fd7f4c8af260d753a834480f790c82fb161889"
diff --git a/recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch b/recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch
index e4d9c2a0..901a47fd 100644
--- a/recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch
+++ b/recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch
@@ -1,25 +1,27 @@
-From d3053e33c76cdb41eeeec3c853fa88c7c7bfb8a5 Mon Sep 17 00:00:00 2001
+From ee6c6dc4183234a6f092d9e5b8d05eaab8ee5382 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Fri, 17 Aug 2018 13:23:58 +0300
Subject: [PATCH] Allow a tools-only build
---
- qt3d.pro | 7 ++++++-
+ qt3d.pro | 9 +++++++--
src/3rdparty/assimp/assimp_dependency.pri | 2 +-
tools/tools.pro | 2 +-
- 3 files changed, 8 insertions(+), 3 deletions(-)
+ 3 files changed, 9 insertions(+), 4 deletions(-)
diff --git a/qt3d.pro b/qt3d.pro
-index 3fc7d1452..7311eff5b 100644
+index 847507f17..286286dd0 100644
--- a/qt3d.pro
+++ b/qt3d.pro
-@@ -1,4 +1,4 @@
+@@ -1,5 +1,5 @@
+-requires(qtHaveModule(gui))
-requires(qtConfig(opengl):!wasm)
++!tools-only:requires(qtHaveModule(gui))
+!tools-only:requires(qtConfig(opengl):!wasm)
CONFIG += examples_need_tools
load(qt_parts)
-@@ -14,3 +14,8 @@ load(qt_parts)
+@@ -15,3 +15,8 @@ load(qt_parts)
OTHER_FILES += \
sync.profile
@@ -29,7 +31,7 @@ index 3fc7d1452..7311eff5b 100644
+ SUBDIRS = sub_tools
+}
diff --git a/src/3rdparty/assimp/assimp_dependency.pri b/src/3rdparty/assimp/assimp_dependency.pri
-index 8ba2d9a..e973d93 100644
+index 8ba2d9a41..e973d93dd 100644
--- a/src/3rdparty/assimp/assimp_dependency.pri
+++ b/src/3rdparty/assimp/assimp_dependency.pri
@@ -1,5 +1,5 @@
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index 548d72ac..9e76e055 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -36,6 +36,6 @@ do_configure_prepend() {
${S}/src/quick3d/imports/input/importsinput.pro
}
-SRCREV = "3c68eeac236b2e33cf34d2f23e04a8d156118eb0"
+SRCREV = "efa4665b316dbd5361b0936a1135f45c141f14aa"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 998e8c46..521dc49d 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -139,4 +139,4 @@ do_install() {
echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
}
-SRCREV = "850c922036b7eebc24cdb74a43a4b31319d924c7"
+SRCREV = "81fd7f4c8af260d753a834480f790c82fb161889"
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 3b9e1b2c..0fe1d874 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -253,4 +253,4 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps"
RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}"
-SRCREV = "850c922036b7eebc24cdb74a43a4b31319d924c7"
+SRCREV = "81fd7f4c8af260d753a834480f790c82fb161889"
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index fcc8ae50..887782ec 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -19,4 +19,4 @@ PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,${BLUEZ}"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "370e84c6d5f7c4f2d3f274ccb250f4baccd4614d"
+SRCREV = "1606ccb76ba72990df652fbd7f01d709ae20b63c"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 6f89f199..4feae2c5 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -24,6 +24,6 @@ do_install_append_class-nativesdk() {
rm -rf ${D}${OE_QMAKE_PATH_QML}
}
-SRCREV = "d27d896d8cb9d240138fe8ea69f1051f74ce1945"
+SRCREV = "91a71bce9c633934540e9f06fb081e3b89259ff3"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index 2436154a..74767c6d 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -31,7 +31,7 @@ SRC_URI += " \
${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=${QT_MODULE_BRANCH_MAPBOXGL};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \
"
-SRCREV_qtlocation = "dc384a2376a13ae2a8776ea0eda7d6e2fd088a64"
+SRCREV_qtlocation = "633b0f40ca82709863bad48e0ed6a1c92ad3b8b4"
SRCREV_qtlocation-mapboxgl = "4b85252fbe811a786c6ee9eabedb7639b031dc53"
SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index 492c3bdd..c7fd0607 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -37,4 +37,4 @@ SRC_URI += "\
# http://errors.yoctoproject.org/Errors/Build/44914/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "dee506f70536dd10f3e00c42f685ead9283433b9"
+SRCREV = "a7f01cea43a16a9b2b06ab3a8ff3b62b8edce5cd"
diff --git a/recipes-qt/qt5/qtnetworkauth_git.bb b/recipes-qt/qt5/qtnetworkauth_git.bb
index 627473fd..9440cc06 100644
--- a/recipes-qt/qt5/qtnetworkauth_git.bb
+++ b/recipes-qt/qt5/qtnetworkauth_git.bb
@@ -9,4 +9,4 @@ require qt5-git.inc
DEPENDS += "qtbase"
-SRCREV = "2d58e369ed692c8a7e639919d15ff6299a76f810"
+SRCREV = "8363321174f64a1497952d2d7fec895a2a7e18f3"
diff --git a/recipes-qt/qt5/qtpurchasing_git.bb b/recipes-qt/qt5/qtpurchasing_git.bb
index 8924a63e..6fcf6025 100644
--- a/recipes-qt/qt5/qtpurchasing_git.bb
+++ b/recipes-qt/qt5/qtpurchasing_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "7f9e30e242a7ba02501f24eb9ff7fdb3028783ec"
+SRCREV = "dff997ecf2984acd7eae650e8ffe3269e6b2a5e2"
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb
index 19c124de..c7427cc9 100644
--- a/recipes-qt/qt5/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols2_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative qtdeclarative-native"
-SRCREV = "1d29b1e36732a7d17ed34c5fa207e7b935f2f41d"
+SRCREV = "579422faaad76b12341a725320da65fcabb3cf7b"
diff --git a/recipes-qt/qt5/qtquickcontrols_git.bb b/recipes-qt/qt5/qtquickcontrols_git.bb
index b2e54864..4a0e1164 100644
--- a/recipes-qt/qt5/qtquickcontrols_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols_git.bb
@@ -17,4 +17,4 @@ FILES_${PN}-qmlplugins += " \
${OE_QMAKE_PATH_QML}/QtQuick/Dialogs/qml/icons.ttf \
"
-SRCREV = "d049f759c6f897db528ca549435c56b4420b016e"
+SRCREV = "65d61277be164a0781f9b57873afc000f36073fa"
diff --git a/recipes-qt/qt5/qtremoteobjects_git.bb b/recipes-qt/qt5/qtremoteobjects_git.bb
index b89522c4..eb280159 100644
--- a/recipes-qt/qt5/qtremoteobjects_git.bb
+++ b/recipes-qt/qt5/qtremoteobjects_git.bb
@@ -24,6 +24,6 @@ PACKAGECONFIG[tools-only] = "CONFIG+=tools-only"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "d3cde521533787f5f91364ffdba3e0a386d131f6"
+SRCREV = "5f94145128035bce167ca23780296564aa5f25d1"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtsvg_git.bb b/recipes-qt/qt5/qtsvg_git.bb
index 6d94c79d..1f897c7d 100644
--- a/recipes-qt/qt5/qtsvg_git.bb
+++ b/recipes-qt/qt5/qtsvg_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "74f7566527c6ed3c47fac873e90942f2834d248f"
+SRCREV = "a91a65632c4d830070e1ca9bbda7e355f1459414"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 471d40d2..f521d03f 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -32,7 +32,7 @@ EXTRA_QMAKEVARS_PRE += " \
${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)} \
"
-SRCREV = "d264cde2c754a683a723a2b5aad9b634a07eea21"
+SRCREV = "6c8d836335a0eb57c76aee78b700893ca014fc90"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qttranslations_git.bb b/recipes-qt/qt5/qttranslations_git.bb
index 6cfc8f90..4158fb00 100644
--- a/recipes-qt/qt5/qttranslations_git.bb
+++ b/recipes-qt/qt5/qttranslations_git.bb
@@ -98,4 +98,4 @@ FILES_${PN}-qthelp = " \
${OE_QMAKE_PATH_TRANSLATIONS}/qt_help_*.qm \
"
-SRCREV = "6431236ba6506c0eb9263e2b14d8b84d7716b12c"
+SRCREV = "c8a0da51adcc015447fc26e5a2b3d1de12479f75"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 8d9486bf..8e35401f 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -37,7 +37,7 @@ PACKAGECONFIG[wayland-libhybris-egl-server-buffer] = "-feature-wayland-libhybris
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "5f645af22bb63f0d215294535cf683029ed7aab5"
+SRCREV = "4b58ff21f4a3c629867064289b6c778bbb57f95a"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 9cd01938..2f73bf8c 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -172,8 +172,8 @@ SRC_URI_append_libc-musl = "\
file://chromium/0018-chromium-musl-pread-pwrite.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "31730085ee9247864a5da5682939eb399853f984"
-SRCREV_chromium = "fec48c17fa1853a1e42a5b6ce97680767464185d"
+SRCREV_qtwebengine = "3e88b4d35441301e44981874c06c16e3c6351b6e"
+SRCREV_chromium = "7b5e48775b3ac89f49d4b0f74b7db03540cc212b"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"
diff --git a/recipes-qt/qt5/qtwebglplugin_git.bb b/recipes-qt/qt5/qtwebglplugin_git.bb
index 0d4f2d07..7faa3795 100644
--- a/recipes-qt/qt5/qtwebglplugin_git.bb
+++ b/recipes-qt/qt5/qtwebglplugin_git.bb
@@ -18,4 +18,4 @@ do_configure_prepend() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtdeclarative', 'CONFIG+=OE_QTDECLARATIVE_ENABLED', '', d)}"
-SRCREV = "3154a358e2988aa9aafd4ecd8c43c8bcc7c1605f"
+SRCREV = "b1662da58d05dd53b5d4c84a3518c65f417cefd8"