aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-12-20 12:01:21 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2018-12-21 21:01:45 +0000
commit6531fa731203debe1b42dedfa225bfa2e1847064 (patch)
tree86c78f54d737f7f49810289d47a561143bcfba0a
parentc8d5ef50d52bee6d8fc691cf08dcd0210ab14ce0 (diff)
qtbase: use v5.12.0 as base
* restore 0018-Fix-compile-issue-with-gcc-9.patch which is only in v5.12.1 * zlib detection got broken probably in: commit e80bf655e922e9864f8843b5e7bbb47019a6d95a Author: Oswald Buddenhagen <oswald.buddenhagen@qt.io> Date: Thu Dec 7 19:30:07 2017 +0100 configure: verify header presence against sources Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb9
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb12
-rw-r--r--recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch6
-rw-r--r--recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch6
-rw-r--r--recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch6
-rw-r--r--recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch4
-rw-r--r--recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch4
-rw-r--r--recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0013-Check-glibc-version-for-renameat2-statx-on-non-boots.patch4
-rw-r--r--recipes-qt/qt5/qtbase/0014-Disable-ltcg-for-host_build.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0015-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0016-corelib-Include-sys-types.h-for-uint32_t.patch4
-rw-r--r--recipes-qt/qt5/qtbase/0017-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch8
-rw-r--r--recipes-qt/qt5/qtbase/0018-Fix-compile-issue-with-gcc-9.patch28
-rw-r--r--recipes-qt/qt5/qtbase/0019-Always-build-uic-and-qvkgen.patch (renamed from recipes-qt/qt5/qtbase/0018-Always-build-uic-and-qvkgen.patch)2
-rw-r--r--recipes-qt/qt5/qtbase/0020-Bootstrap-without-linkat-feature.patch (renamed from recipes-qt/qt5/qtbase/0019-Bootstrap-without-linkat-feature.patch)4
-rw-r--r--recipes-qt/qt5/qtbase_git.bb5
23 files changed, 76 insertions, 44 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 91267a58..31687913 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -23,7 +23,7 @@ FILESEXTRAPATHS =. "${FILE_DIRNAME}/qtbase:"
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-shared
-# 5.12.meta-qt5-shared.1
+# 5.12.meta-qt5-shared.2
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -42,13 +42,14 @@ SRC_URI += "\
file://0015-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch \
file://0016-corelib-Include-sys-types.h-for-uint32_t.patch \
file://0017-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
+ file://0018-Fix-compile-issue-with-gcc-9.patch \
"
# common for qtbase-native and nativesdk-qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-native
-# 5.12.meta-qt5-native.1
+# 5.12.meta-qt5-native.2
SRC_URI += " \
- file://0018-Always-build-uic-and-qvkgen.patch \
+ file://0019-Always-build-uic-and-qvkgen.patch \
"
# CMake's toolchain configuration of nativesdk-qtbase
@@ -195,4 +196,4 @@ fakeroot do_generate_qt_environment_file() {
do_generate_qt_environment_file[umask] = "022"
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "7fc427ba23a624a433d93e1c604d870656835305"
+SRCREV = "13ed06640c6cf32ea8c784c896c6bf017053edb3"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index dcc102a9..3dc92499 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -18,7 +18,7 @@ require qt5-git.inc
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-shared
-# 5.12.meta-qt5-shared.1
+# 5.12.meta-qt5-shared.2
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -37,18 +37,19 @@ SRC_URI += "\
file://0015-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch \
file://0016-corelib-Include-sys-types.h-for-uint32_t.patch \
file://0017-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
+ file://0018-Fix-compile-issue-with-gcc-9.patch \
"
# common for qtbase-native and nativesdk-qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-native
-# 5.12.meta-qt5-native.1
+# 5.12.meta-qt5-native.2
SRC_URI += " \
- file://0018-Always-build-uic-and-qvkgen.patch \
+ file://0019-Always-build-uic-and-qvkgen.patch \
"
# only for qtbase-native
SRC_URI += " \
- file://0019-Bootstrap-without-linkat-feature.patch \
+ file://0020-Bootstrap-without-linkat-feature.patch \
"
CLEANBROKEN = "1"
@@ -59,6 +60,7 @@ XPLATFORM ?= "linux-oe-g++"
PACKAGECONFIG_CONFARGS = " \
-sysroot ${STAGING_DIR_NATIVE} \
-no-gcc-sysroot \
+ -system-zlib \
-qt-pcre \
-no-libjpeg \
-no-libpng \
@@ -138,4 +140,4 @@ do_install() {
echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
}
-SRCREV = "7fc427ba23a624a433d93e1c604d870656835305"
+SRCREV = "13ed06640c6cf32ea8c784c896c6bf017053edb3"
diff --git a/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch b/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
index ae4d89de..0a3cbf92 100644
--- a/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
+++ b/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
@@ -1,4 +1,4 @@
-From 9f6cab0c540e7367de851ef19fd2928087b0f307 Mon Sep 17 00:00:00 2001
+From 3701cce26ce6f90e4b5e4c71c73d333d43b5ac08 Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Mon, 15 Apr 2013 04:29:32 +0200
Subject: [PATCH] Add linux-oe-g++ platform
diff --git a/recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch b/recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch
index 26b487c5..ddeef281 100644
--- a/recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch
+++ b/recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch
@@ -1,4 +1,4 @@
-From 5d9dbd6fb7a069877f2e4e4880134c07343d8edc Mon Sep 17 00:00:00 2001
+From bd8119aaabd75c4a80141b25be48eb990e50ade8 Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Sat, 6 Apr 2013 13:15:07 +0200
Subject: [PATCH] cmake: Use OE_QMAKE_PATH_EXTERNAL_HOST_BINS
diff --git a/recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch b/recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch
index d49ec61e..fd2ed42a 100644
--- a/recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch
+++ b/recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch
@@ -1,4 +1,4 @@
-From 4bab728a4d9ecf3a4626a945a671d236458f74a2 Mon Sep 17 00:00:00 2001
+From 77eec5eff2a1e24911bc38f1f96e5bf055058274 Mon Sep 17 00:00:00 2001
From: Holger Freyther <zecke@selfish.org>
Date: Wed, 26 Sep 2012 17:22:30 +0200
Subject: [PATCH] qlibraryinfo: allow to set qt.conf from the outside using the
@@ -20,10 +20,10 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/src/corelib/global/qlibraryinfo.cpp b/src/corelib/global/qlibraryinfo.cpp
-index 4119012d85..6395d10561 100644
+index e727f00c8e..819dbb8aa3 100644
--- a/src/corelib/global/qlibraryinfo.cpp
+++ b/src/corelib/global/qlibraryinfo.cpp
-@@ -174,7 +174,10 @@ void QLibrarySettings::load()
+@@ -172,7 +172,10 @@ void QLibrarySettings::load()
QSettings *QLibraryInfoPrivate::findConfiguration()
{
#ifdef QT_BUILD_QMAKE
diff --git a/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch b/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch
index 4b48081e..eb866c7e 100644
--- a/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch
+++ b/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch
@@ -1,4 +1,4 @@
-From 3f34b8d782f26876e4e62c6201454ea74ef90ab3 Mon Sep 17 00:00:00 2001
+From 394f8c1f2faae7cf54dc6882b3817c226d84152c Mon Sep 17 00:00:00 2001
From: Denys Dmytriyenko <denys@ti.com>
Date: Tue, 25 Aug 2015 10:05:15 -0400
Subject: [PATCH] configure: bump path length from 256 to 512 characters
@@ -15,10 +15,10 @@ Signed-off-by: Denys Dmytriyenko <denys@ti.com>
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/configure.pri b/configure.pri
-index b3b3e27c44..45b5495bfd 100644
+index 64ed6b9ed8..bb2acbcd35 100644
--- a/configure.pri
+++ b/configure.pri
-@@ -837,10 +837,10 @@ defineTest(qtConfOutput_preparePaths) {
+@@ -838,10 +838,10 @@ defineTest(qtConfOutput_preparePaths) {
"static const char qt_configure_installation [12+11] = \"qt_instdate=2012-12-20\";" \
"" \
"/* Installation Info */" \
diff --git a/recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch b/recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch
index 0369e52c..3c1adaa2 100644
--- a/recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch
+++ b/recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch
@@ -1,4 +1,4 @@
-From 68a9d70b13773587c7be0f5dad1829e4081749d1 Mon Sep 17 00:00:00 2001
+From 13dc97ded965a67af44d8cecad2762dedc928701 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Mon, 24 Oct 2016 09:45:18 +0300
Subject: [PATCH] Disable all unknown features instead of erroring out
@@ -10,10 +10,10 @@ Change-Id: Ib884fe33cac74439f9592b145937f6b75ced8447
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/mkspecs/features/qt_configure.prf b/mkspecs/features/qt_configure.prf
-index fe14ea1f40..1ee89bac46 100644
+index 81b820978a..bec0fb1149 100644
--- a/mkspecs/features/qt_configure.prf
+++ b/mkspecs/features/qt_configure.prf
-@@ -1520,7 +1520,8 @@ defineReplace(qtConfEvaluateSingleExpression) {
+@@ -1301,7 +1301,8 @@ defineReplace(qtConfEvaluateSingleExpression) {
error("Expression '$$1' is accessing field '$$var' of non-local feature $${feature}.")
return($$result)
}
diff --git a/recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch b/recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch
index 25b44db3..18bbd8b0 100644
--- a/recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch
+++ b/recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch
@@ -1,4 +1,4 @@
-From 7406b73bc09b9b61b34417d384033b3f21959c6e Mon Sep 17 00:00:00 2001
+From 18ffe421246444e5f599fdb76d05a5981f4c611a Mon Sep 17 00:00:00 2001
From: Pascal Bach <pascal.bach@siemens.com>
Date: Wed, 11 May 2016 15:20:41 +0200
Subject: [PATCH] Pretend Qt5 wasn't found if OE_QMAKE_PATH_EXTERNAL_HOST_BINS
diff --git a/recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch b/recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch
index fdf8ac13..607b88a0 100644
--- a/recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch
+++ b/recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch
@@ -1,4 +1,4 @@
-From fdaadd9cd531866ac414970d1bec24a4b89a8538 Mon Sep 17 00:00:00 2001
+From b6cb180ea1fed0c7fa0e77ba9fbe36335b4f2780 Mon Sep 17 00:00:00 2001
From: Huang Qiyu <huangqy.fnst@cn.fujitsu.com>
Date: Wed, 7 Jun 2017 21:00:49 +0900
Subject: [PATCH] Delete qlonglong and qulonglong
diff --git a/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch b/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch
index 2da95175..ea58a9f1 100644
--- a/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch
+++ b/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch
@@ -1,4 +1,4 @@
-From 1caa83ba191dd4a819a6b7db5da8c293a1f46c57 Mon Sep 17 00:00:00 2001
+From ebe76b93dc894598b91cfd5934724ead5e4e62d0 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Thu, 27 Jul 2017 08:02:51 -0700
Subject: [PATCH] Replace pthread_yield with sched_yield
@@ -36,7 +36,7 @@ index 5d9b5ca95c..ffcbddc442 100644
QMetaType info(tp);
if (!info.isValid()) {
diff --git a/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp b/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp
-index c473230246..1db8d6f225 100644
+index 263a475435..11994b3c4f 100644
--- a/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp
+++ b/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp
@@ -78,6 +78,7 @@
diff --git a/recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch b/recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch
index 90b54fee..e0595715 100644
--- a/recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch
+++ b/recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch
@@ -1,4 +1,4 @@
-From b2bbab58fa5062011770b5a32d2d73e0c854623b Mon Sep 17 00:00:00 2001
+From 7aef68ed29b5fc96c99d65ccd5e217775044d27d Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Sun, 3 Sep 2017 09:11:44 -0700
Subject: [PATCH] Add OE specific specs for clang compiler
diff --git a/recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch b/recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch
index 0884863b..e984d315 100644
--- a/recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch
+++ b/recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch
@@ -1,4 +1,4 @@
-From 37dae545c6c5134b8c7aaac5e398cfec54349493 Mon Sep 17 00:00:00 2001
+From cb7f43dd24bc59baf1466b9f55c48b170c5912cf Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Sun, 3 Sep 2017 09:44:48 -0700
Subject: [PATCH] linux-clang: Invert conditional for defining QT_SOCKLEN_T
diff --git a/recipes-qt/qt5/qtbase/0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch b/recipes-qt/qt5/qtbase/0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch
index e6ded389..d988f514 100644
--- a/recipes-qt/qt5/qtbase/0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch
+++ b/recipes-qt/qt5/qtbase/0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch
@@ -1,4 +1,4 @@
-From bcb16ca13fd33efaf24f62fb8253d7aeae3e3c91 Mon Sep 17 00:00:00 2001
+From 784a7d274ae96a5598ff886be0fab100e4919c31 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Sun, 3 Sep 2017 10:11:50 -0700
Subject: [PATCH] tst_qlocale: Enable QT_USE_FENV only on glibc
@@ -11,7 +11,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tests/auto/corelib/tools/qlocale/tst_qlocale.cpp b/tests/auto/corelib/tools/qlocale/tst_qlocale.cpp
-index 5d344834e6..1afc70d255 100644
+index 261689d401..40537daef9 100644
--- a/tests/auto/corelib/tools/qlocale/tst_qlocale.cpp
+++ b/tests/auto/corelib/tools/qlocale/tst_qlocale.cpp
@@ -46,7 +46,7 @@
diff --git a/recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch b/recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch
index e652f97e..fa0f7bfa 100644
--- a/recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch
+++ b/recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch
@@ -1,4 +1,4 @@
-From 0ba4c8db7ec77d36e12fafd210ec189ccb176e96 Mon Sep 17 00:00:00 2001
+From 9b4355142608fecdf8353dc958f85b08a5bfb2b9 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Wed, 14 Feb 2018 17:08:43 -0800
Subject: [PATCH] mkspecs/common/gcc-base.conf: Use -I instead of -isystem
diff --git a/recipes-qt/qt5/qtbase/0013-Check-glibc-version-for-renameat2-statx-on-non-boots.patch b/recipes-qt/qt5/qtbase/0013-Check-glibc-version-for-renameat2-statx-on-non-boots.patch
index 27b354b2..c3f2aed0 100644
--- a/recipes-qt/qt5/qtbase/0013-Check-glibc-version-for-renameat2-statx-on-non-boots.patch
+++ b/recipes-qt/qt5/qtbase/0013-Check-glibc-version-for-renameat2-statx-on-non-boots.patch
@@ -1,4 +1,4 @@
-From ebd6d61f9031fec80c7dde35819cabec727179aa Mon Sep 17 00:00:00 2001
+From 4a810779f45444d3432ce14bf24d053f5d049ca8 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
Date: Tue, 21 Aug 2018 00:29:06 +0200
Subject: [PATCH] Check glibc version for renameat2/statx on non bootstrapped
@@ -15,7 +15,7 @@ Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
1 file changed, 11 insertions(+)
diff --git a/src/corelib/io/qfilesystemengine_unix.cpp b/src/corelib/io/qfilesystemengine_unix.cpp
-index b2d81066db..b90e3dc15d 100644
+index 5a5a3a82c6..e5469ff5d7 100644
--- a/src/corelib/io/qfilesystemengine_unix.cpp
+++ b/src/corelib/io/qfilesystemengine_unix.cpp
@@ -93,6 +93,17 @@ extern "C" NSString *NSTemporaryDirectory();
diff --git a/recipes-qt/qt5/qtbase/0014-Disable-ltcg-for-host_build.patch b/recipes-qt/qt5/qtbase/0014-Disable-ltcg-for-host_build.patch
index d4a47fb8..c73733dc 100644
--- a/recipes-qt/qt5/qtbase/0014-Disable-ltcg-for-host_build.patch
+++ b/recipes-qt/qt5/qtbase/0014-Disable-ltcg-for-host_build.patch
@@ -1,4 +1,4 @@
-From baa8339d0fda285b7410066827644aa8af0e5dfb Mon Sep 17 00:00:00 2001
+From 83f34d8a82867132b05394f9ce33b8b394454a8b Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Tue, 23 Oct 2018 09:54:57 +0300
Subject: [PATCH] Disable ltcg for host_build
diff --git a/recipes-qt/qt5/qtbase/0015-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch b/recipes-qt/qt5/qtbase/0015-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch
index f620b3d7..b8b5b39f 100644
--- a/recipes-qt/qt5/qtbase/0015-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch
+++ b/recipes-qt/qt5/qtbase/0015-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch
@@ -1,4 +1,4 @@
-From 744a866a54780ab2c1acf9da875be0845726b20f Mon Sep 17 00:00:00 2001
+From d7bd980370d701fa9aeea48f1494d2df6ce3dd2f Mon Sep 17 00:00:00 2001
From: Max Krummenacher <max.krummenacher@toradex.com>
Date: Sat, 27 Oct 2018 12:29:31 +0000
Subject: [PATCH] Qt5GuiConfigExtras.cmake.in: cope with variable path to
diff --git a/recipes-qt/qt5/qtbase/0016-corelib-Include-sys-types.h-for-uint32_t.patch b/recipes-qt/qt5/qtbase/0016-corelib-Include-sys-types.h-for-uint32_t.patch
index 10a7698e..855f8550 100644
--- a/recipes-qt/qt5/qtbase/0016-corelib-Include-sys-types.h-for-uint32_t.patch
+++ b/recipes-qt/qt5/qtbase/0016-corelib-Include-sys-types.h-for-uint32_t.patch
@@ -1,4 +1,4 @@
-From 10d6966a88bdc997d2fdade463d267c25ba86f7d Mon Sep 17 00:00:00 2001
+From a138a37e24dd3926e4b3818f99f33139e22e52dc Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Thu, 6 Dec 2018 11:47:52 -0800
Subject: [PATCH] corelib: Include sys/types.h for uint32_t
@@ -14,7 +14,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
1 file changed, 1 insertion(+)
diff --git a/src/corelib/global/qnumeric_p.h b/src/corelib/global/qnumeric_p.h
-index 0a6db9afcd..b791d0a172 100644
+index e318c3759b..1cf589c1e7 100644
--- a/src/corelib/global/qnumeric_p.h
+++ b/src/corelib/global/qnumeric_p.h
@@ -55,6 +55,7 @@
diff --git a/recipes-qt/qt5/qtbase/0017-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch b/recipes-qt/qt5/qtbase/0017-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch
index 7144fbe4..c6963f6d 100644
--- a/recipes-qt/qt5/qtbase/0017-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch
+++ b/recipes-qt/qt5/qtbase/0017-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch
@@ -1,4 +1,4 @@
-From c79578126a744dda2feeeff7521438714859508a Mon Sep 17 00:00:00 2001
+From d836722dee0305cec50c23620600743f363b35c6 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Thu, 6 Dec 2018 15:06:20 -0800
Subject: [PATCH] Define QMAKE_CXX.COMPILER_MACROS for clang on linux
@@ -13,10 +13,10 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
1 file changed, 9 insertions(+)
diff --git a/mkspecs/features/toolchain.prf b/mkspecs/features/toolchain.prf
-index c7ea20e180..8a6bb0052d 100644
+index 4ecfb8d889..5ed7e2f080 100644
--- a/mkspecs/features/toolchain.prf
+++ b/mkspecs/features/toolchain.prf
-@@ -210,6 +210,13 @@ defineReplace(qtVariablesFromGCC) {
+@@ -205,6 +205,13 @@ defineReplace(qtVariablesFromGCC) {
return($$ret)
}
@@ -30,7 +30,7 @@ index c7ea20e180..8a6bb0052d 100644
isEmpty($${target_prefix}.COMPILER_MACROS) {
msvc {
clang_cl {
-@@ -229,6 +236,8 @@ isEmpty($${target_prefix}.COMPILER_MACROS) {
+@@ -224,6 +231,8 @@ isEmpty($${target_prefix}.COMPILER_MACROS) {
} else {
vars = $$qtVariablesFromMSVC($$QMAKE_CXX)
}
diff --git a/recipes-qt/qt5/qtbase/0018-Fix-compile-issue-with-gcc-9.patch b/recipes-qt/qt5/qtbase/0018-Fix-compile-issue-with-gcc-9.patch
new file mode 100644
index 00000000..db79e846
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0018-Fix-compile-issue-with-gcc-9.patch
@@ -0,0 +1,28 @@
+From cde196cf74805cc0f47fbebce884a871859862b2 Mon Sep 17 00:00:00 2001
+From: Allan Sandfeld Jensen <allan.jensen@qt.io>
+Date: Tue, 13 Nov 2018 16:00:23 +0100
+Subject: [PATCH] Fix compile issue with gcc 9
+
+It appears messenne_twisters in the latest libstdc++ has one more
+requirement before it is willing to construct with our
+SystemGenerator struct as an sseq provider.
+
+Change-Id: If38151d1fa6f40a80274acc26d9ed6b4ac6049fe
+Reviewed-by: Giuseppe D'Angelo <giuseppe.dangelo@kdab.com>
+Reviewed-by: Thiago Macieira <thiago.macieira@intel.com>
+---
+ src/corelib/global/qrandom.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/corelib/global/qrandom.cpp b/src/corelib/global/qrandom.cpp
+index 23e5e499b2..03534cf453 100644
+--- a/src/corelib/global/qrandom.cpp
++++ b/src/corelib/global/qrandom.cpp
+@@ -218,6 +218,7 @@ struct QRandomGenerator::SystemGenerator
+ #endif // Q_OS_WINRT
+
+ static SystemGenerator &self();
++ typedef quint32 result_type;
+ void generate(quint32 *begin, quint32 *end) Q_DECL_NOEXCEPT_EXPR(FillBufferNoexcept);
+
+ // For std::mersenne_twister_engine implementations that use something
diff --git a/recipes-qt/qt5/qtbase/0018-Always-build-uic-and-qvkgen.patch b/recipes-qt/qt5/qtbase/0019-Always-build-uic-and-qvkgen.patch
index 15ddbf31..77437485 100644
--- a/recipes-qt/qt5/qtbase/0018-Always-build-uic-and-qvkgen.patch
+++ b/recipes-qt/qt5/qtbase/0019-Always-build-uic-and-qvkgen.patch
@@ -1,4 +1,4 @@
-From 9caf072bfa7393a70714ce1e10169be4bfb8c866 Mon Sep 17 00:00:00 2001
+From 3a870fb87411802a3e56b5bfa8423240c0036b44 Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Sat, 16 Nov 2013 00:32:30 +0100
Subject: [PATCH] Always build uic and qvkgen
diff --git a/recipes-qt/qt5/qtbase/0019-Bootstrap-without-linkat-feature.patch b/recipes-qt/qt5/qtbase/0020-Bootstrap-without-linkat-feature.patch
index 69cbfa38..afc2fcb9 100644
--- a/recipes-qt/qt5/qtbase/0019-Bootstrap-without-linkat-feature.patch
+++ b/recipes-qt/qt5/qtbase/0020-Bootstrap-without-linkat-feature.patch
@@ -1,4 +1,4 @@
-From b53e518a341d975298b804af6eb0d2f9a31abaf4 Mon Sep 17 00:00:00 2001
+From 8820b1008d832aeab005406fcce1f6b4520426d6 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Fri, 24 Nov 2017 15:16:31 +0200
Subject: [PATCH] Bootstrap without linkat feature
@@ -13,7 +13,7 @@ Upstream-Status: Inappropriate [OE specific]
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/corelib/global/qconfig-bootstrapped.h b/src/corelib/global/qconfig-bootstrapped.h
-index dfcc3c9c7f..1e5bc401b7 100644
+index f6a5d6b1d4..de0111cc3c 100644
--- a/src/corelib/global/qconfig-bootstrapped.h
+++ b/src/corelib/global/qconfig-bootstrapped.h
@@ -91,7 +91,7 @@
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index c7e9d366..d27b1fa6 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = " \
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-shared
-# 5.12.meta-qt5-shared.1
+# 5.12.meta-qt5-shared.2
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -33,6 +33,7 @@ SRC_URI += "\
file://0015-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch \
file://0016-corelib-Include-sys-types.h-for-uint32_t.patch \
file://0017-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
+ file://0018-Fix-compile-issue-with-gcc-9.patch \
"
@@ -259,4 +260,4 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps"
RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}"
-SRCREV = "7fc427ba23a624a433d93e1c604d870656835305"
+SRCREV = "13ed06640c6cf32ea8c784c896c6bf017053edb3"