aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-01-29 20:42:11 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2019-02-14 17:40:27 +0000
commit9a83f2d9a69988c2805003a5f9e26e1038deface (patch)
tree4a931948986ea9b451f070ab99e9c56a619367f6
parent080cc294b7e28eb4c77ccd2a3ea4d07b34c61738 (diff)
qtconnectivity: Fix build with clang/libc++
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-qt/qt5/qtconnectivity/0001-Add-missing-header-for-errno.patch26
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
2 files changed, 28 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtconnectivity/0001-Add-missing-header-for-errno.patch b/recipes-qt/qt5/qtconnectivity/0001-Add-missing-header-for-errno.patch
new file mode 100644
index 00000000..1b75095c
--- /dev/null
+++ b/recipes-qt/qt5/qtconnectivity/0001-Add-missing-header-for-errno.patch
@@ -0,0 +1,26 @@
+From 4c6aa68761d8a85bffe7d545c816522a793e94a9 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 29 Jan 2019 20:29:19 -0800
+Subject: [PATCH] Add missing header for errno
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/bluetooth/bluez/bluetoothmanagement.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/bluetooth/bluez/bluetoothmanagement.cpp b/src/bluetooth/bluez/bluetoothmanagement.cpp
+index 31d3dc02..75d762e5 100644
+--- a/src/bluetooth/bluez/bluetoothmanagement.cpp
++++ b/src/bluetooth/bluez/bluetoothmanagement.cpp
+@@ -45,6 +45,7 @@
+ #include "bluez_data_p.h"
+ #include "../qbluetoothsocketbase_p.h"
+
++#include <errno.h>
+ #include <unistd.h>
+ #include <sys/prctl.h>
+ #include <sys/syscall.h>
+--
+2.20.1
+
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index f2e00751..4d98b95a 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -10,6 +10,8 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \
"
+SRC_URI += "file://0001-Add-missing-header-for-errno.patch"
+
DEPENDS += "qtbase qtdeclarative"
inherit bluetooth