aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Giancane <francesco.giancane@polito.it>2019-03-08 15:47:17 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2019-03-18 11:26:44 +0000
commit0b0a608ddc55acf1f817aee03e65a06017239bed (patch)
tree8b04af84d92d3f9374119a78ae9ee80addc97362
parent47d1132b1dc2521299f5041dbb61c8afc29461fd (diff)
qtbase: let user decide how to link openssl to Qt5 libraries
Switch from the configure script was extended from -openssl to -openssl-{linked,runtime} so that one can select whether to enable ssl library at linking time or runtime (with dlopen()), or letting the build system decide if no flag is specified. Now with the OPENSSL_LINKING_MODE variable, it is possible to decide which linking mode to be used. Signed-off-by: Francesco Giancane <francesco.giancane@polito.it> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtbase_git.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 2f23fa88..821eb95c 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -94,6 +94,9 @@ PACKAGECONFIG ?= " \
${PACKAGECONFIG_SYSTEM} \
${PACKAGECONFIG_DISTRO} \
"
+# Choose whether to link to OpenSSL library at linking time or run time
+# Leave the variable empty to let the buildsystem decide, or specify -linked or -runtime
+OPENSSL_LINKING_MODE ??= ""
PACKAGECONFIG[static] = "-static,-shared"
PACKAGECONFIG[release] = "-release,-debug"
@@ -153,7 +156,7 @@ PACKAGECONFIG[kms] = "-kms,-no-kms,drm virtual/egl"
PACKAGECONFIG[gbm] = "-gbm,-no-gbm,virtual/libgbm"
PACKAGECONFIG[icu] = "-icu,-no-icu,icu"
PACKAGECONFIG[udev] = "-libudev,-no-libudev,udev"
-PACKAGECONFIG[openssl] = "-openssl,-no-openssl,openssl,libssl"
+PACKAGECONFIG[openssl] = "-openssl${OPENSSL_LINKING_MODE},-no-openssl,openssl,libssl"
PACKAGECONFIG[widgets] = "-widgets,-no-widgets"
PACKAGECONFIG[libproxy] = "-libproxy,-no-libproxy,libproxy"
PACKAGECONFIG[libinput] = "-libinput,-no-libinput,libinput"