aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2019-03-20 12:23:26 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2019-03-20 12:32:50 +0200
commitbd7a586d835d1dd0a5b201338e223fb94adc4380 (patch)
tree2ec50ae595f291ccc80f046f6824c7f03d7b1f2a
parent26205f49f51b5727d75bf8f02a894e04bf7b7942 (diff)
parent0b0a608ddc55acf1f817aee03e65a06017239bed (diff)
Merge remote-tracking branch 'qtyocto/upstream/master' into 5.12
* upstream/master: 0b0a608 qtbase: let user decide how to link openssl to Qt5 libraries 47d1132 qtbase: fix target mkspec adjustment 87f0462 qttools/cmake: use OE_QMAKE_PATH_EXTERNAL_HOST_BINS fe88b99 nativesdk-qtbase: use rpath for nativesdk Qt tools 92c34de qt5: cleanup mkspecs e117b58 qtbase: Fix test builds with clang/x86_64 6280bef qtscript: add fix for build with gcc 8.3 77ed8fb qtbase: Adjust target mkspec settings 75c7d00 qt5-creator: Do not ship two desktop files 6629131 packagegroup-qt5-toolchain-target: add qtbase-tools Conflicts: recipes-qt/qt5/nativesdk-qtbase_git.bb recipes-qt/qt5/qtbase-native_git.bb recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch recipes-qt/qt5/qtbase_git.bb Change-Id: Iaa69404f2d91bd492eea527548b7cf7c504b7bde
-rwxr-xr-xrecipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb1
-rw-r--r--recipes-qt/qt5/qt5-creator_git.bb5
-rw-r--r--recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch14
-rw-r--r--recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch6
-rw-r--r--recipes-qt/qt5/qtbase_git.bb23
-rw-r--r--recipes-qt/qt5/qtscript_git.bb2
6 files changed, 34 insertions, 17 deletions
diff --git a/recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb b/recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb
index 8067832c..b912d891 100755
--- a/recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb
+++ b/recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb
@@ -36,6 +36,7 @@ RDEPENDS_${PN} += " \
qtbase-mkspecs \
qtbase-plugins \
qtbase-staticdev \
+ qtbase-tools \
qttranslations-qtbase \
qttranslations-qthelp \
qtcharts-dev \
diff --git a/recipes-qt/qt5/qt5-creator_git.bb b/recipes-qt/qt5/qt5-creator_git.bb
index 344c956e..6a8887ed 100644
--- a/recipes-qt/qt5/qt5-creator_git.bb
+++ b/recipes-qt/qt5/qt5-creator_git.bb
@@ -27,7 +27,6 @@ SRC_URI = " \
git://code.qt.io/qt-creator/qt-creator.git;branch=4.7 \
file://0002-botan.pro-pass-QMAKE_AR.patch \
file://0001-botan-Always-define-BOTAN_ARCH_SWITCH-when-cross-bui.patch \
- file://qtcreator.desktop.in \
"
SRC_URI_append_libc-musl = " file://0003-Link-with-libexecinfo-on-musl.patch"
@@ -50,10 +49,6 @@ do_configure_append() {
do_install() {
oe_runmake install INSTALL_ROOT=${D}${prefix}
- # install desktop and ensure that qt-creator finds qmake
- install -d ${D}${datadir}/applications
- install -m 0644 ${WORKDIR}/qtcreator.desktop.in ${D}${datadir}/applications/qtcreator.desktop
- sed -i 's:@QT5_QMAKE@:${OE_QMAKE_PATH_QT_BINS}:g' ${D}${datadir}/applications/qtcreator.desktop
}
do_install_append_toolchain-clang () {
# Remove RPATHs embedded in bins
diff --git a/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch b/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
index acc532e3..3f35e7dd 100644
--- a/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
+++ b/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
@@ -1,4 +1,4 @@
-From 3701cce26ce6f90e4b5e4c71c73d333d43b5ac08 Mon Sep 17 00:00:00 2001
+From 5a9a1e8da67d2bf1672982f087995c8e0e8b3577 Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Mon, 15 Apr 2013 04:29:32 +0200
Subject: [PATCH] Add linux-oe-g++ platform
@@ -31,7 +31,7 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
create mode 100644 mkspecs/linux-oe-g++/qplatformdefs.h
diff --git a/configure b/configure
-index ef7bad1bfc..dcca0f9135 100755
+index ef7bad1bfce..dcca0f91359 100755
--- a/configure
+++ b/configure
@@ -712,7 +712,7 @@ fi
@@ -44,7 +44,7 @@ index ef7bad1bfc..dcca0f9135 100755
# build qmake
diff --git a/mkspecs/features/configure.prf b/mkspecs/features/configure.prf
-index 934a18a924..0f5b1b6333 100644
+index 934a18a9249..0f5b1b63334 100644
--- a/mkspecs/features/configure.prf
+++ b/mkspecs/features/configure.prf
@@ -46,14 +46,14 @@ defineTest(qtCompileTest) {
@@ -65,7 +65,7 @@ index 934a18a924..0f5b1b6333 100644
msg = "test $$1 succeeded"
write_file($$QMAKE_CONFIG_LOG, msg, append)
diff --git a/mkspecs/features/qt.prf b/mkspecs/features/qt.prf
-index d16b3cf1be..df219ce34c 100644
+index 90e318e2a48..3e8568ed675 100644
--- a/mkspecs/features/qt.prf
+++ b/mkspecs/features/qt.prf
@@ -147,7 +147,7 @@ import_plugins:qtConfig(static) {
@@ -89,7 +89,7 @@ index d16b3cf1be..df219ce34c 100644
# run qmlimportscanner
qtPrepareTool(QMLIMPORTSCANNER, qmlimportscanner, , system)
diff --git a/mkspecs/features/qt_functions.prf b/mkspecs/features/qt_functions.prf
-index 1903e509c8..c093dd4592 100644
+index 1903e509c8e..c093dd4592d 100644
--- a/mkspecs/features/qt_functions.prf
+++ b/mkspecs/features/qt_functions.prf
@@ -69,7 +69,7 @@ defineTest(qtHaveModule) {
@@ -103,7 +103,7 @@ index 1903e509c8..c093dd4592 100644
cmd = perl -w $$system_path($${cmd}.pl)
diff --git a/mkspecs/linux-oe-g++/qmake.conf b/mkspecs/linux-oe-g++/qmake.conf
new file mode 100644
-index 0000000000..c202c47fa1
+index 00000000000..c202c47fa15
--- /dev/null
+++ b/mkspecs/linux-oe-g++/qmake.conf
@@ -0,0 +1,39 @@
@@ -148,7 +148,7 @@ index 0000000000..c202c47fa1
+load(qt_config)
diff --git a/mkspecs/linux-oe-g++/qplatformdefs.h b/mkspecs/linux-oe-g++/qplatformdefs.h
new file mode 100644
-index 0000000000..5d22fb4101
+index 00000000000..5d22fb41013
--- /dev/null
+++ b/mkspecs/linux-oe-g++/qplatformdefs.h
@@ -0,0 +1 @@
diff --git a/recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch b/recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch
index fe5746e2..5a9eb404 100644
--- a/recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch
+++ b/recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch
@@ -1,4 +1,4 @@
-From 4486a9740b07aa7902f638efe23a51ee619f9600 Mon Sep 17 00:00:00 2001
+From 289f366363eeca03c27fd718c8b3ae53dcc28586 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Sun, 3 Sep 2017 09:11:44 -0700
Subject: [PATCH] Add OE specific specs for clang compiler
@@ -13,7 +13,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
diff --git a/mkspecs/linux-oe-clang/qmake.conf b/mkspecs/linux-oe-clang/qmake.conf
new file mode 100644
-index 0000000000..db02ab5215
+index 00000000000..db02ab5215f
--- /dev/null
+++ b/mkspecs/linux-oe-clang/qmake.conf
@@ -0,0 +1,39 @@
@@ -58,7 +58,7 @@ index 0000000000..db02ab5215
+load(qt_config)
diff --git a/mkspecs/linux-oe-clang/qplatformdefs.h b/mkspecs/linux-oe-clang/qplatformdefs.h
new file mode 100644
-index 0000000000..880c927b21
+index 00000000000..880c927b218
--- /dev/null
+++ b/mkspecs/linux-oe-clang/qplatformdefs.h
@@ -0,0 +1 @@
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 943ab08e..836f57fa 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -89,6 +89,9 @@ PACKAGECONFIG ?= " \
${PACKAGECONFIG_SYSTEM} \
${PACKAGECONFIG_DISTRO} \
"
+# Choose whether to link to OpenSSL library at linking time or run time
+# Leave the variable empty to let the buildsystem decide, or specify -linked or -runtime
+OPENSSL_LINKING_MODE ??= ""
PACKAGECONFIG[static] = "-static,-shared"
PACKAGECONFIG[release] = "-release,-debug"
@@ -148,7 +151,7 @@ PACKAGECONFIG[kms] = "-kms,-no-kms,drm virtual/egl"
PACKAGECONFIG[gbm] = "-gbm,-no-gbm,virtual/libgbm"
PACKAGECONFIG[icu] = "-icu,-no-icu,icu"
PACKAGECONFIG[udev] = "-libudev,-no-libudev,udev"
-PACKAGECONFIG[openssl] = "-openssl,-no-openssl,openssl,libssl"
+PACKAGECONFIG[openssl] = "-openssl${OPENSSL_LINKING_MODE},-no-openssl,openssl,libssl"
PACKAGECONFIG[widgets] = "-widgets,-no-widgets"
PACKAGECONFIG[libproxy] = "-libproxy,-no-libproxy,libproxy"
PACKAGECONFIG[libinput] = "-libinput,-no-libinput,libinput"
@@ -263,4 +266,22 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps"
RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}"
+TARGET_MKSPEC ?= "linux-g++"
+
+# use clean mkspecs on target
+pkg_postinst_${PN}-tools () {
+sed -i \
+ -e 's:HostSpec =.*:HostSpec = ${TARGET_MKSPEC}:g' \
+ -e 's:TargetSpec =.*:TargetSpec = ${TARGET_MKSPEC}:g' \
+ $D${bindir}/qt.conf
+}
+
+pkg_postinst_${PN}-mkspecs () {
+sed -i 's: cross_compile : :g' $D${OE_QMAKE_PATH_ARCHDATA}/mkspecs/qconfig.pri
+sed -i \
+ -e 's: cross_compile : :g' \
+ -e 's:HOST_QT_TOOLS =.*::g' \
+ $D${OE_QMAKE_PATH_ARCHDATA}/mkspecs/qmodule.pri
+}
+
SRCREV = "856fb1ab44722f5165fb6b5dec0bd748006acd10"
diff --git a/recipes-qt/qt5/qtscript_git.bb b/recipes-qt/qt5/qtscript_git.bb
index 132d69e2..67d17b28 100644
--- a/recipes-qt/qt5/qtscript_git.bb
+++ b/recipes-qt/qt5/qtscript_git.bb
@@ -12,7 +12,7 @@ LIC_FILES_CHKSUM = " \
"
# Patches from https://github.com/meta-qt5/qtscript/commits/b5.12
-# 5.12.meta-qt5.1
+# 5.12.meta-qt5.2
SRC_URI += " \
file://0001-Include-asm-sgidefs.h-on-non-glibc-systems.patch \
"