aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2020-12-23 08:31:41 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2020-12-29 07:55:22 +0200
commit41c0d8d277c76b0fda423f2aaa794d3f3889ce99 (patch)
tree819fa759b19a6832150157be8dbadbf68714b1af
parent1c4e93c70d71d085b50f2c63e5673491d15c4452 (diff)
qtserialbus: add PACKAGECONFIGs for modbus and socketcan5.15
Add new PACKAGECONFIGs to control modbus and socketcan features. Modbus depends on QtSerialPort and socketcan has runtime dependency to libsocketcan. Enable socketcan only if meta-oe layer is available. Change-Id: I746c9435d71eb96b71734dd9573b892e053e387a Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--recipes-qt/qt5/qtserialbus_git.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtserialbus_git.bb b/recipes-qt/qt5/qtserialbus_git.bb
index 94e0fbbd..2b0c2669 100644
--- a/recipes-qt/qt5/qtserialbus_git.bb
+++ b/recipes-qt/qt5/qtserialbus_git.bb
@@ -9,6 +9,12 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.LGPLv3;md5=e0459b45c5c4840b353141a8bbed91f0 \
"
-DEPENDS += "qtbase qtserialport"
+DEPENDS += "qtbase"
+
+PACKAGECONFIG ?= "modbus ${@bb.utils.contains('BBFILE_COLLECTIONS', 'openembedded-layer', 'socketcan', '', d)}"
+PACKAGECONFIG[modbus] = "-feature-modbus-serialport,-no-feature-modbus-serialport,qtserialport"
+PACKAGECONFIG[socketcan] = "-feature-socketcan,-no-feature-socketcan,,libsocketcan"
+
+EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
SRCREV = "1aa9b03756baead139943712839af5ecedeb2989"