aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2017-04-10 13:34:46 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2017-04-12 06:52:34 +0000
commit912db845e563f4df34f3cf761df8c563193c5044 (patch)
tree495e605d9e4b60ac44cdbf86f66ce6abcbe6af3b
parentc766188cbbc47f6a82539ee9baa5c1a511cfe4d1 (diff)
qt5: update submodules
* Updates submodules 5.9.0 Beta --> 5.9.0 Beta 2 (snapshot 1) * Package new qml cache files (.qmlc) introduced by qtgraphicaleffects module update Change-Id: I726e092db2dd1e9057d9a79321b38c69623f1077 Reviewed-by: Teemu Holappa <teemu.holappa@qt.io>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qt3d_git.bb2
-rw-r--r--recipes-qt/qt5/qt5.inc4
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtcharts_git.bb2
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
-rw-r--r--recipes-qt/qt5/qtdatavis3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtgraphicaleffects_git.bb2
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb4
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtnetworkauth_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols2_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols_git.bb2
-rw-r--r--recipes-qt/qt5/qtscxml_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialbus_git.bb2
-rw-r--r--recipes-qt/qt5/qttools_git.bb2
-rw-r--r--recipes-qt/qt5/qtvirtualkeyboard_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb4
21 files changed, 25 insertions, 23 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index b84c9bf5..424ccf75 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -191,4 +191,4 @@ fakeroot do_generate_qt_environment_file() {
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "8675e1c5ee7d1209784a2320f1ae3f486b1eaae4"
+SRCREV = "43a5fe258b7f48baad69ac040f395cb597022fa9"
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index 7ebbb288..67fbe04b 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -34,6 +34,6 @@ do_configure_prepend() {
${S}/src/quick3d/imports/input/importsinput.pro
}
-SRCREV = "3e664bf438d4a3ab9a5f1633f2db171632b777b8"
+SRCREV = "7cbbf942972b9619af9442218ff2e16857536fb8"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qt5.inc b/recipes-qt/qt5/qt5.inc
index 90d7896f..6630665f 100644
--- a/recipes-qt/qt5/qt5.inc
+++ b/recipes-qt/qt5/qt5.inc
@@ -97,19 +97,21 @@ FILES_${PN}-qmldesigner += " \
${OE_QMAKE_PATH_QML}/*/*/*/designer \
"
-# qmlplugins 1-4 levels of subdirs qmldir + *{.so,*.qmltypes,*.qml,*js}
+# qmlplugins 1-4 levels of subdirs qmldir + *{.so,*.qmltypes,*.qml,*.qmlc,*js}
FILES_${PN}-qmlplugins = " \
${OE_QMAKE_PATH_QML}/*.qmltypes \
${OE_QMAKE_PATH_QML}/*/*${SOLIBSDEV} \
${OE_QMAKE_PATH_QML}/*/qmldir \
${OE_QMAKE_PATH_QML}/*/*.qmltypes \
${OE_QMAKE_PATH_QML}/*/*.qml \
+ ${OE_QMAKE_PATH_QML}/*/*.qmlc \
${OE_QMAKE_PATH_QML}/*/*.js \
${OE_QMAKE_PATH_QML}/*/*.png \
${OE_QMAKE_PATH_QML}/*/*/*${SOLIBSDEV} \
${OE_QMAKE_PATH_QML}/*/*/qmldir \
${OE_QMAKE_PATH_QML}/*/*/*.qmltypes \
${OE_QMAKE_PATH_QML}/*/*/*.qml \
+ ${OE_QMAKE_PATH_QML}/*/*/*.qmlc \
${OE_QMAKE_PATH_QML}/*/*/*.js \
${OE_QMAKE_PATH_QML}/*/*/*.png \
${OE_QMAKE_PATH_QML}/*/*/*/*${SOLIBSDEV} \
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 610911e0..7675eb04 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -106,4 +106,4 @@ do_install() {
install -m 755 ${B}/bin/qfloat16-tables ${D}${OE_QMAKE_PATH_BINS}
}
-SRCREV = "8675e1c5ee7d1209784a2320f1ae3f486b1eaae4"
+SRCREV = "43a5fe258b7f48baad69ac040f395cb597022fa9"
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 0eb7dcf1..89439781 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -182,4 +182,4 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps"
RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}"
-SRCREV = "8675e1c5ee7d1209784a2320f1ae3f486b1eaae4"
+SRCREV = "43a5fe258b7f48baad69ac040f395cb597022fa9"
diff --git a/recipes-qt/qt5/qtcharts_git.bb b/recipes-qt/qt5/qtcharts_git.bb
index 1305af6e..c6f0d3da 100644
--- a/recipes-qt/qt5/qtcharts_git.bb
+++ b/recipes-qt/qt5/qtcharts_git.bb
@@ -8,4 +8,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia"
-SRCREV = "d7d8bb10b6d4413376624a85760df857096955cb"
+SRCREV = "cc4e79d6200b0495a5c4d1a7faa773906b1ac99e"
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index 9fec25ac..c9ea7e61 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -23,4 +23,4 @@ PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,${BLUEZ}"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "51914eff36cb99823757bf2c970df46081351d32"
+SRCREV = "8f09b31d98d50e9041d294e96eb0726cdf58f4b5"
diff --git a/recipes-qt/qt5/qtdatavis3d_git.bb b/recipes-qt/qt5/qtdatavis3d_git.bb
index f0d80524..53792794 100644
--- a/recipes-qt/qt5/qtdatavis3d_git.bb
+++ b/recipes-qt/qt5/qtdatavis3d_git.bb
@@ -8,4 +8,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia qtxmlpatterns"
-SRCREV = "1a4d36afc821d745fe304f222e73d6c2fa249afa"
+SRCREV = "73ec35fa12a4b150670ea93d3021ca8e658063e1"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 7a3c1a39..7b8a7328 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -32,6 +32,6 @@ do_install_append_class-nativesdk() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}"
-SRCREV = "f261a534cc96d41cee15462795844116887bd99a"
+SRCREV = "452a78d0ac4a1579733a8ab641be24c9b7c0dd96"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtgraphicaleffects_git.bb b/recipes-qt/qt5/qtgraphicaleffects_git.bb
index 6a55da6a..d0d46e5d 100644
--- a/recipes-qt/qt5/qtgraphicaleffects_git.bb
+++ b/recipes-qt/qt5/qtgraphicaleffects_git.bb
@@ -19,4 +19,4 @@ DEPENDS += "qtdeclarative"
RDEPENDS_${PN}-dev = ""
-SRCREV = "69bb8a63a5ff1a56629d58e4d03a3bee658c5447"
+SRCREV = "e66fd901fb9e18d45182db56ec3ce70f401d2ac4"
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index 23ac692c..83af0b69 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -24,7 +24,7 @@ SRC_URI += " \
${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=upstream/qt-staging;protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \
"
-SRCREV_qtlocation = "6bc54fc4b531e9cfeaa04296b4986ffb0f82dd3d"
-SRCREV_qtlocation-mapboxgl = "60320d74ba577185d1d90a7f234e182ca06d7d76"
+SRCREV_qtlocation = "8714cb31102026f96a3fbf10b8d715319d400536"
+SRCREV_qtlocation-mapboxgl = "fa9e435795a958b44d50a5cd9cfb4a83363c1923"
SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index e07faea4..7c90c49b 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -33,4 +33,4 @@ SRC_URI += "\
file://0001-qtmultimedia-fix-a-conflicting-declaration.patch \
"
-SRCREV = "6c3b0fdb5ceb9079241cb7136d756e9dba114cfe"
+SRCREV = "6de2c8aca6736550d87057b0a3f025464bf21246"
diff --git a/recipes-qt/qt5/qtnetworkauth_git.bb b/recipes-qt/qt5/qtnetworkauth_git.bb
index d7dca2fd..2ba626de 100644
--- a/recipes-qt/qt5/qtnetworkauth_git.bb
+++ b/recipes-qt/qt5/qtnetworkauth_git.bb
@@ -10,4 +10,4 @@ require qt5-git.inc
DEPENDS += "qtbase"
-SRCREV = "8847f1e54d27c43ef744c39d28033e48764a254a"
+SRCREV = "031ab0ce77da942d12e84cb18a76be71f7533544"
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb
index 34bdeb93..1174b430 100644
--- a/recipes-qt/qt5/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols2_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative"
-SRCREV = "f720bc8e38dfdc14c48ffe3178a704f5d130f932"
+SRCREV = "dcb0dd861bec6eb61b6bca6dad9399f59a5a1c2c"
diff --git a/recipes-qt/qt5/qtquickcontrols_git.bb b/recipes-qt/qt5/qtquickcontrols_git.bb
index 17c8c16c..bcfe61c7 100644
--- a/recipes-qt/qt5/qtquickcontrols_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols_git.bb
@@ -21,4 +21,4 @@ SRC_URI += " \
file://0001-texteditor-fix-invalid-use-of-incomplete-type-class-.patch \
"
-SRCREV = "8c37d58fa21fd3cf6897e2d7d4fe1f73c983d2f4"
+SRCREV = "da9183da38513d5531af3753d14d040991e04132"
diff --git a/recipes-qt/qt5/qtscxml_git.bb b/recipes-qt/qt5/qtscxml_git.bb
index 8c55526a..93cff7d4 100644
--- a/recipes-qt/qt5/qtscxml_git.bb
+++ b/recipes-qt/qt5/qtscxml_git.bb
@@ -10,7 +10,7 @@ require qt5-git.inc
DEPENDS += "qtbase qtdeclarative qtxmlpatterns qtscxml-native"
-SRCREV = "06ee5829c54e1aafeb03d387a8f5d6377a7ed115"
+SRCREV = "e9406368d46e806835c703e387b00598647cd446"
SRC_URI += "file://0001-Use-external-host-bin-path-for-cmake-file.patch"
diff --git a/recipes-qt/qt5/qtserialbus_git.bb b/recipes-qt/qt5/qtserialbus_git.bb
index e6cadb6a..0cf6432e 100644
--- a/recipes-qt/qt5/qtserialbus_git.bb
+++ b/recipes-qt/qt5/qtserialbus_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtserialport"
-SRCREV = "943518be292f929ff49a589eaa39f7de8a2a14a1"
+SRCREV = "e6a10bc0b5c7be73c5a58f8e565c1d571723bc4a"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 9d79f48a..e8393096 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -29,6 +29,6 @@ PACKAGECONFIG[qtwebkit] = ",,qtwebkit"
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)}"
-SRCREV = "92efbd613a7f1aa3f8b0f54beeb2ae77ca98812a"
+SRCREV = "5c7b771829c52400ddd8f441972b37ce92da3b78"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qtvirtualkeyboard_git.bb b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
index 0a42d7a6..1a735d62 100644
--- a/recipes-qt/qt5/qtvirtualkeyboard_git.bb
+++ b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
@@ -49,4 +49,4 @@ FILES_${PN} += "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/lipi_toolkit"
DEPENDS += "qtbase qtdeclarative qtmultimedia qtquickcontrols qtsvg qtxmlpatterns"
-SRCREV = "1efffb8fea600c77925422cdf85f6c024ab3d8b2"
+SRCREV = "0e27ca2c843d4e1b29276a8e175ce3360b6aecca"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 620a985b..29b1b4a4 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -41,7 +41,7 @@ PACKAGECONFIG[libhybris-egl-server] = "-feature-libhybris-egl-server,-no-feature
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "ec81bfafe16ca021b529813228a095177e302d42"
+SRCREV = "c26f8dbd5c5ff15167e90db529845091705cbe46"
# From https://bugreports.qt.io/browse/QTBUG-57767
SRC_URI += "file://0001-fix-build-without-xkbcommon-evdev.patch"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 7eee8129..1e7f268f 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -111,8 +111,8 @@ SRC_URI += " \
file://0002-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch \
"
-SRCREV_qtwebengine = "a76a364d4fcecf7603e5c9bf888c19802559603b"
-SRCREV_chromium = "bba44efa6bb5707bf6fb4e92627e3326be3f3a3b"
+SRCREV_qtwebengine = "2d235e2112b71e0011c3c31f8d496680091dac66"
+SRCREV_chromium = "853d4069e45b06106f33611c458f5480f71e7c57"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"