aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2017-03-30 08:43:15 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2017-03-31 05:28:04 +0000
commit9b12e74031f12c6ced4d69ee0a0780113501ee18 (patch)
tree55c506ef9ae52ceb9c7d5df5054a3a958b855e6e
parent7d49e81ca5fcd639aea6f5e2e24677dbc90f4c17 (diff)
qt5: update submodules
* Update submodules to 5.9.0 Beta RC1 * Removed obsolete temporary build fix patch from qt3d Change-Id: Iee1e0c64792ee17fce947d9e68a143b09e77c31a Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qt3d/0002-qt3d-include-qcoreapplication.h-header-in-qtquicksce.patch26
-rw-r--r--recipes-qt/qt5/qt3d_git.bb3
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtdatavis3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb2
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtquick1_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols2_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols_git.bb2
-rw-r--r--recipes-qt/qt5/qtscript_git.bb2
-rw-r--r--recipes-qt/qt5/qtscxml_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialbus_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialport_git.bb2
-rw-r--r--recipes-qt/qt5/qttools_git.bb2
-rw-r--r--recipes-qt/qt5/qtvirtualkeyboard_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb4
20 files changed, 20 insertions, 47 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 0788794b..ee6c1730 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -191,4 +191,4 @@ fakeroot do_generate_qt_environment_file() {
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "c1a2f97a3b3a8c058b1760b57e5c83bf7815b84a"
+SRCREV = "bae0c4c11a6dda52e5d1e9d6d7d0de3ebd47642b"
diff --git a/recipes-qt/qt5/qt3d/0002-qt3d-include-qcoreapplication.h-header-in-qtquicksce.patch b/recipes-qt/qt5/qt3d/0002-qt3d-include-qcoreapplication.h-header-in-qtquicksce.patch
deleted file mode 100644
index 0d8d0837..00000000
--- a/recipes-qt/qt5/qt3d/0002-qt3d-include-qcoreapplication.h-header-in-qtquicksce.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 6a1c600bcb6288c021eafdef516b8313c60505a3 Mon Sep 17 00:00:00 2001
-From: Mikko Gronoff <mikko.gronoff@qt.io>
-Date: Fri, 17 Mar 2017 14:42:12 +0200
-Subject: [PATCH] qt3d: include qcoreapplication.h header in
- qtquickscene2dplugin.cpp
-
-Fix build break in qt3d:
-Add #include <QtCore/qcoreapplication.h> to qtquickscene2dplugin.cpp
-to prevent build break due unknown Q_COREAPP_STARTUP_FUNCTION macro.
----
- src/quick3d/imports/scene2d/qtquickscene2dplugin.cpp | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/src/quick3d/imports/scene2d/qtquickscene2dplugin.cpp b/src/quick3d/imports/scene2d/qtquickscene2dplugin.cpp
-index c67271a..224b24f 100644
---- a/src/quick3d/imports/scene2d/qtquickscene2dplugin.cpp
-+++ b/src/quick3d/imports/scene2d/qtquickscene2dplugin.cpp
-@@ -40,6 +40,8 @@
- #include <private/qrenderaspect_p.h>
- #include <Qt3DQuickScene2D/private/qt3dquick3dscene2d_p.h>
-
-+#include <QtCore/qcoreapplication.h>
-+
- QT_BEGIN_NAMESPACE
-
- static void initScene2dPlugin()
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index 10ffd9c9..ee757437 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -13,7 +13,6 @@ DEPENDS_class-target += "qtdeclarative qt3d-native"
SRC_URI += " \
file://0001-Allow-a-tools-only-build.patch \
- file://0002-qt3d-include-qcoreapplication.h-header-in-qtquicksce.patch \
"
PACKAGECONFIG ??= ""
@@ -35,6 +34,6 @@ do_configure_prepend() {
${S}/src/quick3d/imports/input/importsinput.pro
}
-SRCREV = "fd39bbaca2fe8e29bb9b603340ed94c7480b6da5"
+SRCREV = "873e8ac06c606e71aafb9be9baa21143e6757df5"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 32c59498..88ff4231 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -106,4 +106,4 @@ do_install() {
install -m 755 ${B}/bin/qfloat16-tables ${D}${OE_QMAKE_PATH_BINS}
}
-SRCREV = "c1a2f97a3b3a8c058b1760b57e5c83bf7815b84a"
+SRCREV = "bae0c4c11a6dda52e5d1e9d6d7d0de3ebd47642b"
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index a6375a6c..36a9f3cb 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -182,4 +182,4 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps"
RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}"
-SRCREV = "c1a2f97a3b3a8c058b1760b57e5c83bf7815b84a"
+SRCREV = "bae0c4c11a6dda52e5d1e9d6d7d0de3ebd47642b"
diff --git a/recipes-qt/qt5/qtdatavis3d_git.bb b/recipes-qt/qt5/qtdatavis3d_git.bb
index 29c0a985..f0d80524 100644
--- a/recipes-qt/qt5/qtdatavis3d_git.bb
+++ b/recipes-qt/qt5/qtdatavis3d_git.bb
@@ -8,4 +8,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia qtxmlpatterns"
-SRCREV = "fb9e66188e0582a6b80ad3b8b3ac80024180a9df"
+SRCREV = "1a4d36afc821d745fe304f222e73d6c2fa249afa"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 6ef0f60e..6fd2866c 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -32,6 +32,6 @@ do_install_append_class-nativesdk() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}"
-SRCREV = "7a125135e1ef592aa20a29f7aac1a6117a6b1770"
+SRCREV = "73f365f9f2d04131ae27a5dba26255feda18baa2"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index 93a9a7c2..24e14225 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -24,7 +24,7 @@ SRC_URI += " \
${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=upstream/qt-staging;protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \
"
-SRCREV_qtlocation = "51052caaa27c639c10f7618a853d0b374720c6ea"
+SRCREV_qtlocation = "a7cadd6f5f5278220847dcb2c4897a3c40896ea3"
SRCREV_qtlocation-mapboxgl = "60320d74ba577185d1d90a7f234e182ca06d7d76"
SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index 6f156f22..e07faea4 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -33,4 +33,4 @@ SRC_URI += "\
file://0001-qtmultimedia-fix-a-conflicting-declaration.patch \
"
-SRCREV = "03560060a1702af5190b60fec74f9e71b3c2e104"
+SRCREV = "6c3b0fdb5ceb9079241cb7136d756e9dba114cfe"
diff --git a/recipes-qt/qt5/qtquick1_git.bb b/recipes-qt/qt5/qtquick1_git.bb
index 89ee7818..2f16a36f 100644
--- a/recipes-qt/qt5/qtquick1_git.bb
+++ b/recipes-qt/qt5/qtquick1_git.bb
@@ -23,4 +23,4 @@ do_configure_prepend() {
}
QT_MODULE_BRANCH = "dev"
-SRCREV = "a0783470449a911fce09d6328abfcff17973d421"
+SRCREV = "695460401d9a89d2f156016d51601b2e59b64105"
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb
index 7158bdc3..a67fb368 100644
--- a/recipes-qt/qt5/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols2_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative"
-SRCREV = "9df0f8cb35ee1c134f772f432272e6e020bf9c52"
+SRCREV = "40f454dbfe0e3c73e9d8a77d58938736000a70f4"
diff --git a/recipes-qt/qt5/qtquickcontrols_git.bb b/recipes-qt/qt5/qtquickcontrols_git.bb
index eca7e818..329b4b66 100644
--- a/recipes-qt/qt5/qtquickcontrols_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols_git.bb
@@ -21,4 +21,4 @@ SRC_URI += " \
file://0001-texteditor-fix-invalid-use-of-incomplete-type-class-.patch \
"
-SRCREV = "b7ce67c2774197026885e500e9ef495460eb0d33"
+SRCREV = "b84d25b20ed316529ae2fa091c5d9e2fbf45e023"
diff --git a/recipes-qt/qt5/qtscript_git.bb b/recipes-qt/qt5/qtscript_git.bb
index 089ee4f8..ae5e0da4 100644
--- a/recipes-qt/qt5/qtscript_git.bb
+++ b/recipes-qt/qt5/qtscript_git.bb
@@ -25,4 +25,4 @@ ARM_INSTRUCTION_SET_armv5 = "arm"
DEPENDS += "qtbase"
-SRCREV = "5cde7e8668c0d8729674e4fdd96ee6de52e6c2c3"
+SRCREV = "e00ca9b6bec2adf78fd14e02376ecf1b55a93b0c"
diff --git a/recipes-qt/qt5/qtscxml_git.bb b/recipes-qt/qt5/qtscxml_git.bb
index 368a1e9d..8c55526a 100644
--- a/recipes-qt/qt5/qtscxml_git.bb
+++ b/recipes-qt/qt5/qtscxml_git.bb
@@ -10,7 +10,7 @@ require qt5-git.inc
DEPENDS += "qtbase qtdeclarative qtxmlpatterns qtscxml-native"
-SRCREV = "34e9418cd669a706dd407f0032c5de564212369e"
+SRCREV = "06ee5829c54e1aafeb03d387a8f5d6377a7ed115"
SRC_URI += "file://0001-Use-external-host-bin-path-for-cmake-file.patch"
diff --git a/recipes-qt/qt5/qtserialbus_git.bb b/recipes-qt/qt5/qtserialbus_git.bb
index c9ced273..20468e18 100644
--- a/recipes-qt/qt5/qtserialbus_git.bb
+++ b/recipes-qt/qt5/qtserialbus_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtserialport"
-SRCREV = "71a31bf19bb0cce506638bc79ba96bc5e5da92fe"
+SRCREV = "dc124162efeabe90b9025789391d1f0e15cef0f1"
diff --git a/recipes-qt/qt5/qtserialport_git.bb b/recipes-qt/qt5/qtserialport_git.bb
index 4b79b0bc..76e6dd6f 100644
--- a/recipes-qt/qt5/qtserialport_git.bb
+++ b/recipes-qt/qt5/qtserialport_git.bb
@@ -15,4 +15,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "5c6a433d6a6a4176082036ae94931467101a199a"
+SRCREV = "d320f01018f0273e4fea2e0a7aa8f30ee8129587"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 0667ac00..81c14d79 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -29,6 +29,6 @@ PACKAGECONFIG[qtwebkit] = ",,qtwebkit"
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)}"
-SRCREV = "c5e54d58e8763898db81e1f3b5b5460d6e4b9455"
+SRCREV = "224a4bdc0380b15e6a8f07dc0d4bf9ae4dae1996"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qtvirtualkeyboard_git.bb b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
index 741ff86a..0a42d7a6 100644
--- a/recipes-qt/qt5/qtvirtualkeyboard_git.bb
+++ b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
@@ -49,4 +49,4 @@ FILES_${PN} += "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/lipi_toolkit"
DEPENDS += "qtbase qtdeclarative qtmultimedia qtquickcontrols qtsvg qtxmlpatterns"
-SRCREV = "956a6a04a7a98be7c05320b504674260b4322851"
+SRCREV = "1efffb8fea600c77925422cdf85f6c024ab3d8b2"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 80278935..5c10bb41 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -41,7 +41,7 @@ PACKAGECONFIG[libhybris-egl-server] = "-feature-libhybris-egl-server,-no-feature
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "dfcda81c5b13ad15517a37bcc45f3bf5f550466c"
+SRCREV = "50fea6ae0e9ee863f02d0343baa06ccdf06b7238"
# From https://bugreports.qt.io/browse/QTBUG-57767
SRC_URI += "file://0001-fix-build-without-xkbcommon-evdev.patch"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 60815e7f..f1bdedbd 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -111,8 +111,8 @@ SRC_URI += " \
file://0002-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch \
"
-SRCREV_qtwebengine = "140d12802c9ebc54f5816fbf1a410c5bdc730ec6"
-SRCREV_chromium = "8d882ead843178d1ba30f0d80d722e147788e6d1"
+SRCREV_qtwebengine = "57fee86eb2756a2f102e2bbeb16a443b84a17e01"
+SRCREV_chromium = "bba44efa6bb5707bf6fb4e92627e3326be3f3a3b"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"