aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2021-04-25 20:56:07 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2021-04-29 10:54:51 +0200
commit100c1dce31998a0f742ff40ff19cf82f0a8839de (patch)
tree8bb1c4273e0fbf1e2511a5d14eac70b6850c6ceb
parent08550c223c4528ed76d45a981aff65c8857b9195 (diff)
qt5-creator: Fix build with LLVM 12 / clang PACKAGECONFIG enabled
Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
-rw-r--r--recipes-qt/qt5/qt5-creator/0002-clangformat-Fix-build-with-LLVM-12.patch45
-rw-r--r--recipes-qt/qt5/qt5-creator_git.bb1
2 files changed, 46 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qt5-creator/0002-clangformat-Fix-build-with-LLVM-12.patch b/recipes-qt/qt5/qt5-creator/0002-clangformat-Fix-build-with-LLVM-12.patch
new file mode 100644
index 00000000..e204d5e6
--- /dev/null
+++ b/recipes-qt/qt5/qt5-creator/0002-clangformat-Fix-build-with-LLVM-12.patch
@@ -0,0 +1,45 @@
+From 25e7b2c5d608f71aba694224e5160fc430731b6a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Bj=C3=B6rn=20Sch=C3=A4pers?= <bjoern@hazardy.de>
+Date: Fri, 29 Jan 2021 18:01:37 +0100
+Subject: [PATCH] clangformat: Fix build with LLVM 12
+
+Change-Id: I493afce92b16291cf66fc510129f2154a7162847
+Reviewed-by: David Schulz <david.schulz@qt.io>
+
+Fixes:
+| ../../../../git/src/plugins/clangformat/clangformatutils.cpp: In function 'clang::format::FormatStyle ClangFormat::qtcStyle()':
+| ../../../../git/src/plugins/clangformat/clangformatutils.cpp:54:41: error: cannot convert 'bool' to 'clang::format::FormatStyle::AlignConsecutiveStyle' in assignment
+| 54 | style.AlignConsecutiveAssignments = false;
+| | ^~~~~
+| ../../../../git/src/plugins/clangformat/clangformatutils.cpp:55:42: error: cannot convert 'bool' to 'clang::format::FormatStyle::AlignConsecutiveStyle' in assignment
+| 55 | style.AlignConsecutiveDeclarations = false;
+| | ^~~~~
+
+Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
+
+Upstream-Status: Backport
+---
+ src/plugins/clangformat/clangformatutils.cpp | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/src/plugins/clangformat/clangformatutils.cpp b/src/plugins/clangformat/clangformatutils.cpp
+index 8e11c15364..a249327d0e 100644
+--- a/src/plugins/clangformat/clangformatutils.cpp
++++ b/src/plugins/clangformat/clangformatutils.cpp
+@@ -51,8 +51,13 @@ static clang::format::FormatStyle qtcStyle()
+ style.Language = FormatStyle::LK_Cpp;
+ style.AccessModifierOffset = -4;
+ style.AlignAfterOpenBracket = FormatStyle::BAS_Align;
++#if LLVM_VERSION_MAJOR >= 12
++ style.AlignConsecutiveAssignments = FormatStyle::ACS_None;
++ style.AlignConsecutiveDeclarations = FormatStyle::ACS_None;
++#else
+ style.AlignConsecutiveAssignments = false;
+ style.AlignConsecutiveDeclarations = false;
++#endif
+ style.AlignEscapedNewlines = FormatStyle::ENAS_DontAlign;
+ #if LLVM_VERSION_MAJOR >= 11
+ style.AlignOperands = FormatStyle::OAS_Align;
+--
+2.30.2
+
diff --git a/recipes-qt/qt5/qt5-creator_git.bb b/recipes-qt/qt5/qt5-creator_git.bb
index 5b337ca3..9566fa5d 100644
--- a/recipes-qt/qt5/qt5-creator_git.bb
+++ b/recipes-qt/qt5/qt5-creator_git.bb
@@ -24,6 +24,7 @@ PV = "4.14.0+git${SRCPV}"
SRC_URI = " \
git://code.qt.io/qt-creator/qt-creator.git;branch=4.14 \
file://0001-app-Use-malloc_trim-only-on-glibc.patch \
+ file://0002-clangformat-Fix-build-with-LLVM-12.patch \
"
SRC_URI_append_libc-musl = " file://0001-Link-with-libexecinfo-on-musl.patch"