aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2020-03-10 09:34:19 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2020-03-17 10:12:45 +0200
commit6fb095e3bda4104776b2fbabf9179f6c6eca05d7 (patch)
treea03b3eee5a1abed3232c3ecfac9ffa9a25acf507
parent65028944ee13f5fa7939aa0b669ecc8ad358012d (diff)
qt5: update submodulesv5.15.0-beta2
Update to latest content in Qt 5.15 branch. Task-number: QTBUG-80823 Change-Id: I30451a35af341a3ffc7636bb5018611ef6bc0016 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qt3d_git.bb2
-rw-r--r--recipes-qt/qt5/qt5-creator/0002-Fix-QPainterPath-related-compilation-errors-in-Qt-5..patch115
-rw-r--r--recipes-qt/qt5/qt5-creator_git.bb1
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtcoap_git.bb2
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtmqtt_git.bb2
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtopcua_git.bb2
-rw-r--r--recipes-qt/qt5/qtpurchasing_git.bb2
-rw-r--r--recipes-qt/qt5/qtquick3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols2_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols_git.bb2
-rw-r--r--recipes-qt/qt5/qtquicktimeline_git.bb2
-rw-r--r--recipes-qt/qt5/qtremoteobjects_git.bb2
-rw-r--r--recipes-qt/qt5/qtscxml_git.bb2
-rw-r--r--recipes-qt/qt5/qtsensors_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialbus_git.bb2
-rw-r--r--recipes-qt/qt5/qtsvg_git.bb2
-rw-r--r--recipes-qt/qt5/qttools_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb4
-rw-r--r--recipes-qt/qt5/qtwebsockets_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebview_git.bb2
-rw-r--r--recipes-qt/qwt/qwt-qt5/0001-fix-qpainterpath-build-issues.patch228
-rw-r--r--recipes-qt/qwt/qwt-qt5_6.1.4.bb1
29 files changed, 371 insertions, 26 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 47b0a823..c99a99b6 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -195,4 +195,4 @@ fakeroot do_generate_qt_environment_file() {
do_generate_qt_environment_file[umask] = "022"
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "c58249c32774646a4be5c7504339b483d658a4da"
+SRCREV = "7cec37572a8231b53fc64254bc874de599bc3af5"
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index f3ba96f4..e0d6d1dd 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -36,6 +36,6 @@ do_configure_prepend() {
${S}/src/quick3d/imports/input/importsinput.pro
}
-SRCREV = "76b39dd90f613f340066cc5a4ceed65ff778bdd4"
+SRCREV = "8b122b9b53687285953140b2130be6541a938737"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qt5-creator/0002-Fix-QPainterPath-related-compilation-errors-in-Qt-5..patch b/recipes-qt/qt5/qt5-creator/0002-Fix-QPainterPath-related-compilation-errors-in-Qt-5..patch
new file mode 100644
index 00000000..aa21ef5e
--- /dev/null
+++ b/recipes-qt/qt5/qt5-creator/0002-Fix-QPainterPath-related-compilation-errors-in-Qt-5..patch
@@ -0,0 +1,115 @@
+From db11c16b977e204c7000ef689452045f85ba98b7 Mon Sep 17 00:00:00 2001
+From: Friedemann Kleint <Friedemann.Kleint@qt.io>
+Date: Thu, 12 Mar 2020 09:26:58 +0100
+Subject: [PATCH] Fix QPainterPath-related compilation errors in Qt 5.15
+
+Some include of QPainterPath was removed in Qt, causing errors like:
+
+easingpane\easinggraph.cpp(258): error C2079: 'path' uses undefined class 'QPainterPath'
+easingpane\easinggraph.cpp(275): error C2027: use of undefined type 'QPainterPath'
+easingpane\easinggraph.cpp(305): error C2664: 'void QPainter::drawPath(const QPainterPath &)': cannot convert argument 1 from 'int'
+to 'const QPainterPath &'
+easingpane\easinggraph.cpp(305): note: Reason: cannot convert from 'int' to 'const QPainterPath'
+easingpane\easinggraph.cpp(305): note: use of undefined type 'QPainterPath'
+...
+
+Add the missing include statements.
+
+Change-Id: I4f3383cbcec891a52480a683c9c76ed5deee2b2a
+Reviewed-by: Eike Ziller <eike.ziller@qt.io>
+(cherry picked from commit b8ad0fdae90679b18238f58522058ea9b5934646)
+---
+ src/libs/modelinglib/qmt/stereotype/shapepaintvisitor.cpp | 2 ++
+ src/libs/qmleditorwidgets/easingpane/easingcontextpane.cpp | 1 +
+ src/libs/qmleditorwidgets/easingpane/easinggraph.cpp | 1 +
+ src/plugins/coreplugin/fancyactionbar.cpp | 1 +
+ src/plugins/coreplugin/manhattanstyle.cpp | 1 +
+ src/plugins/texteditor/texteditor.cpp | 1 +
+ src/plugins/texteditor/texteditoroverlay.cpp | 1 +
+ 7 files changed, 8 insertions(+)
+
+diff --git a/src/libs/modelinglib/qmt/stereotype/shapepaintvisitor.cpp b/src/libs/modelinglib/qmt/stereotype/shapepaintvisitor.cpp
+index 880835287a..930f8450ad 100644
+--- a/src/libs/modelinglib/qmt/stereotype/shapepaintvisitor.cpp
++++ b/src/libs/modelinglib/qmt/stereotype/shapepaintvisitor.cpp
+@@ -27,6 +27,8 @@
+
+ #include "shapes.h"
+
++#include <QPainterPath>
++
+ namespace qmt {
+
+ ShapePaintVisitor::ShapePaintVisitor(QPainter *painter, const QPointF &scaledOrigin, const QSizeF &originalSize,
+diff --git a/src/libs/qmleditorwidgets/easingpane/easingcontextpane.cpp b/src/libs/qmleditorwidgets/easingpane/easingcontextpane.cpp
+index d43b458881..ded1b544af 100644
+--- a/src/libs/qmleditorwidgets/easingpane/easingcontextpane.cpp
++++ b/src/libs/qmleditorwidgets/easingpane/easingcontextpane.cpp
+@@ -30,6 +30,7 @@
+
+ #include <QGraphicsPixmapItem>
+ #include <QGraphicsScene>
++#include <QPainterPath>
+ #include <QPropertyAnimation>
+ #include <QSequentialAnimationGroup>
+
+diff --git a/src/libs/qmleditorwidgets/easingpane/easinggraph.cpp b/src/libs/qmleditorwidgets/easingpane/easinggraph.cpp
+index 4163569c04..e8360e0db6 100644
+--- a/src/libs/qmleditorwidgets/easingpane/easinggraph.cpp
++++ b/src/libs/qmleditorwidgets/easingpane/easinggraph.cpp
+@@ -26,6 +26,7 @@
+ #include "easinggraph.h"
+
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QStyleOptionGraphicsItem>
+ #include <math.h>
+
+diff --git a/src/plugins/coreplugin/fancyactionbar.cpp b/src/plugins/coreplugin/fancyactionbar.cpp
+index 8d496ea3d2..72875823a2 100644
+--- a/src/plugins/coreplugin/fancyactionbar.cpp
++++ b/src/plugins/coreplugin/fancyactionbar.cpp
+@@ -38,6 +38,7 @@
+ #include <QEvent>
+ #include <QMouseEvent>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QPixmapCache>
+ #include <QPropertyAnimation>
+ #include <QStyle>
+diff --git a/src/plugins/coreplugin/manhattanstyle.cpp b/src/plugins/coreplugin/manhattanstyle.cpp
+index 709dcf62aa..156cac322e 100644
+--- a/src/plugins/coreplugin/manhattanstyle.cpp
++++ b/src/plugins/coreplugin/manhattanstyle.cpp
+@@ -43,6 +43,7 @@
+ #include <QLineEdit>
+ #include <QMenuBar>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QPixmap>
+ #include <QStatusBar>
+ #include <QStyleFactory>
+diff --git a/src/plugins/texteditor/texteditor.cpp b/src/plugins/texteditor/texteditor.cpp
+index 59926e31ea..576dea22d8 100644
+--- a/src/plugins/texteditor/texteditor.cpp
++++ b/src/plugins/texteditor/texteditor.cpp
+@@ -98,6 +98,7 @@
+ #include <QMessageBox>
+ #include <QMimeData>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QPrintDialog>
+ #include <QPrinter>
+ #include <QPropertyAnimation>
+diff --git a/src/plugins/texteditor/texteditoroverlay.cpp b/src/plugins/texteditor/texteditoroverlay.cpp
+index a33ca13810..431045f1db 100644
+--- a/src/plugins/texteditor/texteditoroverlay.cpp
++++ b/src/plugins/texteditor/texteditoroverlay.cpp
+@@ -30,6 +30,7 @@
+ #include <QDebug>
+ #include <QMap>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QTextBlock>
+
+ #include <algorithm>
diff --git a/recipes-qt/qt5/qt5-creator_git.bb b/recipes-qt/qt5/qt5-creator_git.bb
index 5c11e4e8..927f101f 100644
--- a/recipes-qt/qt5/qt5-creator_git.bb
+++ b/recipes-qt/qt5/qt5-creator_git.bb
@@ -26,6 +26,7 @@ PV = "4.9.2+git${SRCPV}"
SRC_URI = " \
git://code.qt.io/qt-creator/qt-creator.git;branch=4.9 \
file://0001-clangformat-AllowShortIfStatementsOnASingleLine-is-n.patch \
+ file://0002-Fix-QPainterPath-related-compilation-errors-in-Qt-5..patch \
"
SRC_URI_append_libc-musl = " file://0001-Link-with-libexecinfo-on-musl.patch"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 0f13be32..dd1201af 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -142,4 +142,4 @@ do_install() {
echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
}
-SRCREV = "c58249c32774646a4be5c7504339b483d658a4da"
+SRCREV = "7cec37572a8231b53fc64254bc874de599bc3af5"
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 2446ca43..479e3631 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -295,4 +295,4 @@ sed -i \
$D${OE_QMAKE_PATH_ARCHDATA}/mkspecs/qmodule.pri
}
-SRCREV = "c58249c32774646a4be5c7504339b483d658a4da"
+SRCREV = "7cec37572a8231b53fc64254bc874de599bc3af5"
diff --git a/recipes-qt/qt5/qtcoap_git.bb b/recipes-qt/qt5/qtcoap_git.bb
index 875d8da9..dea81794 100644
--- a/recipes-qt/qt5/qtcoap_git.bb
+++ b/recipes-qt/qt5/qtcoap_git.bb
@@ -11,4 +11,4 @@ PACKAGECONFIG[qtdeclarative] = ",,qtdeclarative"
DEPENDS += "qtbase"
-SRCREV = "8d3da74a5828b4c09847342bc45855d0889ede7d"
+SRCREV = "02dbe3346c414d9c606acd5bc799a79a67ad3c1c"
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index 5466217e..f22c38b6 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -19,4 +19,4 @@ PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,bluez5"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "531443d1f00c0ebc6a56ebc30e5eea85b318b73e"
+SRCREV = "35fe7d452d5b85eabe1c3ec9d09019fe4f3e2d2e"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 9a4a264f..6c4bff81 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -31,6 +31,6 @@ do_install_append_class-nativesdk() {
rm -rf ${D}${OE_QMAKE_PATH_QML}
}
-SRCREV = "1fef24732bb5114392626a7fef956625a6cc66ac"
+SRCREV = "4482aa576b2e0e6f5b30675d2681599daaf23762"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtmqtt_git.bb b/recipes-qt/qt5/qtmqtt_git.bb
index a550e720..338d5abc 100644
--- a/recipes-qt/qt5/qtmqtt_git.bb
+++ b/recipes-qt/qt5/qtmqtt_git.bb
@@ -9,4 +9,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "2bba786b2543811c28f379fa12f3c7110ff0664f"
+SRCREV = "7467bbdc843afeee748eff38f741e2417357de7a"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index f2539ac2..942a0b84 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -37,4 +37,4 @@ SRC_URI += "\
# http://errors.yoctoproject.org/Errors/Build/44914/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "19477de84a64f412bca9ce2df62ab9adb3859da2"
+SRCREV = "6a7d1bd6acbe7bfa9bdab8c5d2e96216bc73ce69"
diff --git a/recipes-qt/qt5/qtopcua_git.bb b/recipes-qt/qt5/qtopcua_git.bb
index 3d0d6f09..8e50721d 100644
--- a/recipes-qt/qt5/qtopcua_git.bb
+++ b/recipes-qt/qt5/qtopcua_git.bb
@@ -18,4 +18,4 @@ SECURITY_STRINGFORMAT = ""
DEPENDS += "qtbase"
-SRCREV = "7edb958482ddf3670a6a366d186883478aab1441"
+SRCREV = "9ae4d93b0b3155716495dce6336859f9d2c4db6c"
diff --git a/recipes-qt/qt5/qtpurchasing_git.bb b/recipes-qt/qt5/qtpurchasing_git.bb
index a22d61f6..17ed8bc3 100644
--- a/recipes-qt/qt5/qtpurchasing_git.bb
+++ b/recipes-qt/qt5/qtpurchasing_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "0fd1c5413bd433755e54c7d69493efc45c432764"
+SRCREV = "6ec39500b6cb3ffc274b7c3c0de39beb6cc1ef00"
diff --git a/recipes-qt/qt5/qtquick3d_git.bb b/recipes-qt/qt5/qtquick3d_git.bb
index 2686de7a..f21588cf 100644
--- a/recipes-qt/qt5/qtquick3d_git.bb
+++ b/recipes-qt/qt5/qtquick3d_git.bb
@@ -22,7 +22,7 @@ FILES_${PN}-qmlplugins += " \
${OE_QMAKE_PATH_QML}/QtQuick3D/Helpers/meshes/*.mesh \
"
-SRCREV_qtquick3d = "a24fc6de882bd1a5265dabd26855997d6879d906"
+SRCREV_qtquick3d = "a77e066c15472dafa238c65e42c251592f61af0c"
SRCREV_assimp = "8f0c6b04b2257a520aaab38421b2e090204b69df"
SRCREV_FORMAT = "qtquick3d_assimp"
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb
index 3c81446e..391cbffd 100644
--- a/recipes-qt/qt5/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols2_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative qtdeclarative-native"
-SRCREV = "814682bb9a5c9ccaff30662dd757cd827f39aad0"
+SRCREV = "6cdd4b53031de17b36b30b00de0a6945470a35ad"
diff --git a/recipes-qt/qt5/qtquickcontrols_git.bb b/recipes-qt/qt5/qtquickcontrols_git.bb
index 6d26cea7..ce46b008 100644
--- a/recipes-qt/qt5/qtquickcontrols_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols_git.bb
@@ -17,4 +17,4 @@ FILES_${PN}-qmlplugins += " \
${OE_QMAKE_PATH_QML}/QtQuick/Dialogs/qml/icons.ttf \
"
-SRCREV = "d286adc5c7c27fdbbb7887f3a77212a49726cede"
+SRCREV = "eb554a20ec5c48643784ce7b29f97ccfb31e7f89"
diff --git a/recipes-qt/qt5/qtquicktimeline_git.bb b/recipes-qt/qt5/qtquicktimeline_git.bb
index 726dce33..14817e72 100644
--- a/recipes-qt/qt5/qtquicktimeline_git.bb
+++ b/recipes-qt/qt5/qtquicktimeline_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS = "qtbase qtdeclarative"
-SRCREV = "649afa13b841cdf8339cfb605ef2ecba81768846"
+SRCREV = "973e5e6da27cee94d95ed05cc4251c70381e9ad9"
diff --git a/recipes-qt/qt5/qtremoteobjects_git.bb b/recipes-qt/qt5/qtremoteobjects_git.bb
index 292b5c79..85be89e3 100644
--- a/recipes-qt/qt5/qtremoteobjects_git.bb
+++ b/recipes-qt/qt5/qtremoteobjects_git.bb
@@ -25,6 +25,6 @@ PACKAGECONFIG[tools-only] = "CONFIG+=tools-only"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "09838389f3b9eaf67ad2e0b02a85a62a63fbfc38"
+SRCREV = "15e437e870279937b15674c32783c776512ca20d"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtscxml_git.bb b/recipes-qt/qt5/qtscxml_git.bb
index ff36414f..c95fd63a 100644
--- a/recipes-qt/qt5/qtscxml_git.bb
+++ b/recipes-qt/qt5/qtscxml_git.bb
@@ -10,7 +10,7 @@ require qt5-git.inc
DEPENDS += "qtbase qtdeclarative qtxmlpatterns qtscxml-native"
-SRCREV = "61ed1a9e09fe54b0d52afbf865de03c8c4eaed82"
+SRCREV = "85ef74c296716081b044db5fd9db4692443c229f"
# Patches from https://github.com/meta-qt5/qtscxml/commits/b5.14
# 5.14.meta-qt5.1
diff --git a/recipes-qt/qt5/qtsensors_git.bb b/recipes-qt/qt5/qtsensors_git.bb
index 9c352599..32280080 100644
--- a/recipes-qt/qt5/qtsensors_git.bb
+++ b/recipes-qt/qt5/qtsensors_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "53ce60e9f9bf8a6c6b6f1c293564998b431987be"
+SRCREV = "3c7ddeeeb9fe0f7667495d187b0c94ee3c5d4837"
diff --git a/recipes-qt/qt5/qtserialbus_git.bb b/recipes-qt/qt5/qtserialbus_git.bb
index affc5381..f1d81038 100644
--- a/recipes-qt/qt5/qtserialbus_git.bb
+++ b/recipes-qt/qt5/qtserialbus_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtserialport"
-SRCREV = "8b1a6de795523156a5a74dd2a544d866a8beeb53"
+SRCREV = "3653815f3cd12291790180456fe18df9e95f82ab"
diff --git a/recipes-qt/qt5/qtsvg_git.bb b/recipes-qt/qt5/qtsvg_git.bb
index 425f7fdd..7c1d9115 100644
--- a/recipes-qt/qt5/qtsvg_git.bb
+++ b/recipes-qt/qt5/qtsvg_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "215a6642a48b1272a54ce2d125346fa0b8c89847"
+SRCREV = "8dbfbe633ee7cd1853354830872fc1c60f9e2139"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 9662480c..8f148b6b 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -49,7 +49,7 @@ EXTRA_QMAKEVARS_PRE_append_class-target = "\
${@bb.utils.contains('PACKAGECONFIG', 'clang', 'CONFIG+=config_clang', 'CONFIG+=config_clang_done CONFIG-=config_clang', d)} \
"
-SRCREV = "94ee5927f5551d32876f5854c8b0f630b68b4659"
+SRCREV = "98a4e4291da098b19a4a60fa8dbfcbdfa3b6a123"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index a5636d80..f4a56600 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -43,7 +43,7 @@ PACKAGECONFIG[wayland-vulkan-server-buffer] = "-feature-wayland-vulkan-server-bu
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "7458370a6facf4261df90eea7230382756608a2e"
+SRCREV = "f195b7db8a206a6aad7734db24d611b8f9594aa1"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index f6b77b6b..ae7c2316 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -189,8 +189,8 @@ SRC_URI_append_libc-musl = "\
file://chromium/0023-chromium-musl-pread-pwrite.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "795d5e2666cababe4fbf8533d8a49fdc40d8d4c1"
-SRCREV_chromium = "07787da493d9a71b994582904a188a53aae9e473"
+SRCREV_qtwebengine = "0e59294a0f88ba167dad4279372021841f51c82e"
+SRCREV_chromium = "9424dc7ceeccf6e6d5edc7757edb39a7ae4983ab"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"
diff --git a/recipes-qt/qt5/qtwebsockets_git.bb b/recipes-qt/qt5/qtwebsockets_git.bb
index dfeec8b0..0537f8fc 100644
--- a/recipes-qt/qt5/qtwebsockets_git.bb
+++ b/recipes-qt/qt5/qtwebsockets_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "5bc1a1f85fedd7d65298f0a4c8ea79fb0670c0d7"
+SRCREV = "ad75d2712a838787488e817eec318fc27bae1786"
diff --git a/recipes-qt/qt5/qtwebview_git.bb b/recipes-qt/qt5/qtwebview_git.bb
index 5a4edc46..762e5c94 100644
--- a/recipes-qt/qt5/qtwebview_git.bb
+++ b/recipes-qt/qt5/qtwebview_git.bb
@@ -19,7 +19,7 @@ COMPATIBLE_MACHINE_armv7a = "(.*)"
COMPATIBLE_MACHINE_armv7ve = "(.*)"
COMPATIBLE_MACHINE_aarch64 = "(.*)"
-SRCREV = "3de65bf9daf1d0e61300cdfe44d3eca51636d438"
+SRCREV = "04b529214db0f20cce4d229a6035825390048217"
python() {
if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
diff --git a/recipes-qt/qwt/qwt-qt5/0001-fix-qpainterpath-build-issues.patch b/recipes-qt/qwt/qwt-qt5/0001-fix-qpainterpath-build-issues.patch
new file mode 100644
index 00000000..71a5c7ba
--- /dev/null
+++ b/recipes-qt/qwt/qwt-qt5/0001-fix-qpainterpath-build-issues.patch
@@ -0,0 +1,228 @@
+From 4f432cfcb19f41e6a4ec8d3c7f871f66e461fb63 Mon Sep 17 00:00:00 2001
+From: Mikko Gronoff <mikko.gronoff@qt.io>
+Date: Thu, 12 Mar 2020 13:14:29 +0200
+Subject: [PATCH] fix qpainterpath build issues
+
+---
+ examples/dials/attitude_indicator.cpp | 1 +
+ examples/itemeditor/editor.cpp | 1 +
+ examples/sinusplot/sinusplot.cpp | 1 +
+ src/qwt_compass_rose.cpp | 1 +
+ src/qwt_dial_needle.cpp | 1 +
+ src/qwt_null_paintdevice.cpp | 1 +
+ src/qwt_painter.cpp | 1 +
+ src/qwt_painter_command.cpp | 1 +
+ src/qwt_painter_command.h | 1 +
+ src/qwt_picker.cpp | 1 +
+ src/qwt_plot_canvas.cpp | 1 +
+ src/qwt_plot_glcanvas.cpp | 1 +
+ src/qwt_plot_glcanvas.h | 1 +
+ src/qwt_plot_panner.cpp | 1 +
+ src/qwt_plot_renderer.cpp | 1 +
+ src/qwt_plot_shapeitem.cpp | 1 +
+ src/qwt_widget_overlay.cpp | 1 +
+ 17 files changed, 17 insertions(+)
+
+diff --git a/examples/dials/attitude_indicator.cpp b/examples/dials/attitude_indicator.cpp
+index ea0d5ab..a01611e 100644
+--- a/examples/dials/attitude_indicator.cpp
++++ b/examples/dials/attitude_indicator.cpp
+@@ -3,6 +3,7 @@
+ #include <qwt_round_scale_draw.h>
+ #include <qevent.h>
+ #include <qpainter.h>
++#include <qpainterpath.h>
+ #include <qpolygon.h>
+
+ AttitudeIndicatorNeedle::AttitudeIndicatorNeedle( const QColor &color )
+diff --git a/examples/itemeditor/editor.cpp b/examples/itemeditor/editor.cpp
+index bd06372..7c4a6ef 100644
+--- a/examples/itemeditor/editor.cpp
++++ b/examples/itemeditor/editor.cpp
+@@ -4,6 +4,7 @@
+ #include <qwt_scale_map.h>
+ #include <qwt_plot_shapeitem.h>
+ #include <qevent.h>
++#include <qpainterpath.h>
+
+ class Overlay: public QwtWidgetOverlay
+ {
+diff --git a/examples/sinusplot/sinusplot.cpp b/examples/sinusplot/sinusplot.cpp
+index 119fa4a..6a9bfe7 100644
+--- a/examples/sinusplot/sinusplot.cpp
++++ b/examples/sinusplot/sinusplot.cpp
+@@ -1,5 +1,6 @@
+ #include <qapplication.h>
+ #include <qlayout.h>
++#include <qpainterpath.h>
+ #include <qwt_plot.h>
+ #include <qwt_plot_marker.h>
+ #include <qwt_plot_curve.h>
+diff --git a/src/qwt_compass_rose.cpp b/src/qwt_compass_rose.cpp
+index 05f7039..fbd30fe 100644
+--- a/src/qwt_compass_rose.cpp
++++ b/src/qwt_compass_rose.cpp
+@@ -11,6 +11,7 @@
+ #include "qwt_point_polar.h"
+ #include "qwt_painter.h"
+ #include <qpainter.h>
++#include <qpainterpath.h>
+
+ static QPointF qwtIntersection(
+ QPointF p11, QPointF p12, QPointF p21, QPointF p22 )
+diff --git a/src/qwt_dial_needle.cpp b/src/qwt_dial_needle.cpp
+index 49dd44a..d98f68c 100644
+--- a/src/qwt_dial_needle.cpp
++++ b/src/qwt_dial_needle.cpp
+@@ -13,6 +13,7 @@
+ #include "qwt_painter.h"
+ #include <qapplication.h>
+ #include <qpainter.h>
++#include <qpainterpath.h>
+
+ #if QT_VERSION < 0x040601
+ #define qFastSin(x) qSin(x)
+diff --git a/src/qwt_null_paintdevice.cpp b/src/qwt_null_paintdevice.cpp
+index 3baf0e9..468a838 100644
+--- a/src/qwt_null_paintdevice.cpp
++++ b/src/qwt_null_paintdevice.cpp
+@@ -9,6 +9,7 @@
+
+ #include "qwt_null_paintdevice.h"
+ #include <qpaintengine.h>
++#include <qpainterpath.h>
+ #include <qpixmap.h>
+
+ class QwtNullPaintDevice::PrivateData
+diff --git a/src/qwt_painter.cpp b/src/qwt_painter.cpp
+index 7959fe5..626677f 100644
+--- a/src/qwt_painter.cpp
++++ b/src/qwt_painter.cpp
+@@ -17,6 +17,7 @@
+ #include <qframe.h>
+ #include <qrect.h>
+ #include <qpainter.h>
++#include <qpainterpath.h>
+ #include <qpalette.h>
+ #include <qpaintdevice.h>
+ #include <qpixmap.h>
+diff --git a/src/qwt_painter_command.cpp b/src/qwt_painter_command.cpp
+index 39faca9..fcd068d 100644
+--- a/src/qwt_painter_command.cpp
++++ b/src/qwt_painter_command.cpp
+@@ -7,6 +7,7 @@
+ * modify it under the terms of the Qwt License, Version 1.0
+ *****************************************************************************/
+
++#include <qpainterpath.h>
+ #include "qwt_painter_command.h"
+
+ //! Construct an invalid command
+diff --git a/src/qwt_painter_command.h b/src/qwt_painter_command.h
+index a2f509a..fab52a8 100644
+--- a/src/qwt_painter_command.h
++++ b/src/qwt_painter_command.h
+@@ -12,6 +12,7 @@
+
+ #include "qwt_global.h"
+ #include <qpaintengine.h>
++#include <qpainterpath.h>
+ #include <qpixmap.h>
+ #include <qimage.h>
+ #include <qpolygon.h>
+diff --git a/src/qwt_picker.cpp b/src/qwt_picker.cpp
+index dfd7e9b..3e20578 100644
+--- a/src/qwt_picker.cpp
++++ b/src/qwt_picker.cpp
+@@ -15,6 +15,7 @@
+ #include <qapplication.h>
+ #include <qevent.h>
+ #include <qpainter.h>
++#include <qpainterpath.h>
+ #include <qframe.h>
+ #include <qcursor.h>
+ #include <qbitmap.h>
+diff --git a/src/qwt_plot_canvas.cpp b/src/qwt_plot_canvas.cpp
+index 9438f15..bfe660d 100644
+--- a/src/qwt_plot_canvas.cpp
++++ b/src/qwt_plot_canvas.cpp
+@@ -13,6 +13,7 @@
+ #include "qwt_math.h"
+ #include "qwt_plot.h"
+ #include <qpainter.h>
++#include <qpainterpath.h>
+ #include <qstyle.h>
+ #include <qstyleoption.h>
+ #include <qpaintengine.h>
+diff --git a/src/qwt_plot_glcanvas.cpp b/src/qwt_plot_glcanvas.cpp
+index 996c0ad..6975863 100644
+--- a/src/qwt_plot_glcanvas.cpp
++++ b/src/qwt_plot_glcanvas.cpp
+@@ -12,6 +12,7 @@
+ #include "qwt_painter.h"
+ #include <qevent.h>
+ #include <qpainter.h>
++#include <qpainterpath.h>
+ #include <qdrawutil.h>
+ #include <qstyle.h>
+ #include <qstyleoption.h>
+diff --git a/src/qwt_plot_glcanvas.h b/src/qwt_plot_glcanvas.h
+index 7ca9b5a..a2dfeda 100644
+--- a/src/qwt_plot_glcanvas.h
++++ b/src/qwt_plot_glcanvas.h
+@@ -12,6 +12,7 @@
+
+ #include "qwt_global.h"
+ #include <qframe.h>
++#include <qpainterpath.h>
+ #include <qgl.h>
+
+ class QwtPlot;
+diff --git a/src/qwt_plot_panner.cpp b/src/qwt_plot_panner.cpp
+index b7daa05..59bd2df 100644
+--- a/src/qwt_plot_panner.cpp
++++ b/src/qwt_plot_panner.cpp
+@@ -12,6 +12,7 @@
+ #include "qwt_plot.h"
+ #include "qwt_painter.h"
+ #include <qbitmap.h>
++#include <qpainterpath.h>
+ #include <qstyle.h>
+ #include <qstyleoption.h>
+
+diff --git a/src/qwt_plot_renderer.cpp b/src/qwt_plot_renderer.cpp
+index 549c4bc..71cadec 100644
+--- a/src/qwt_plot_renderer.cpp
++++ b/src/qwt_plot_renderer.cpp
+@@ -20,6 +20,7 @@
+ #include "qwt_math.h"
+
+ #include <qpainter.h>
++#include <qpainterpath.h>
+ #include <qtransform.h>
+ #include <qprinter.h>
+ #include <qfiledialog.h>
+diff --git a/src/qwt_plot_shapeitem.cpp b/src/qwt_plot_shapeitem.cpp
+index db7896b..56bc208 100644
+--- a/src/qwt_plot_shapeitem.cpp
++++ b/src/qwt_plot_shapeitem.cpp
+@@ -7,6 +7,7 @@
+ * modify it under the terms of the Qwt License, Version 1.0
+ *****************************************************************************/
+
++#include <qpainterpath.h>
+ #include "qwt_plot_shapeitem.h"
+ #include "qwt_scale_map.h"
+ #include "qwt_painter.h"
+diff --git a/src/qwt_widget_overlay.cpp b/src/qwt_widget_overlay.cpp
+index 5974413..fa6da48 100644
+--- a/src/qwt_widget_overlay.cpp
++++ b/src/qwt_widget_overlay.cpp
+@@ -10,6 +10,7 @@
+ #include "qwt_widget_overlay.h"
+ #include "qwt_painter.h"
+ #include <qpainter.h>
++#include <qpainterpath.h>
+ #include <qpaintengine.h>
+ #include <qimage.h>
+ #include <qevent.h>
diff --git a/recipes-qt/qwt/qwt-qt5_6.1.4.bb b/recipes-qt/qwt/qwt-qt5_6.1.4.bb
index 623b45e5..682ab566 100644
--- a/recipes-qt/qwt/qwt-qt5_6.1.4.bb
+++ b/recipes-qt/qwt/qwt-qt5_6.1.4.bb
@@ -16,6 +16,7 @@ inherit qmake5
SRC_URI = " \
${SOURCEFORGE_MIRROR}/qwt/qwt-${PV}.tar.bz2;name=qwt \
file://0001-Remove-rpath-from-binaries-they-point-to-buuild-area.patch \
+ file://0001-fix-qpainterpath-build-issues.patch \
"
SRC_URI[qwt.md5sum] = "4fb1852f694420e3ab9c583526edecc5"
SRC_URI[qwt.sha256sum] = "1529215329e51fc562e0009505a838f427919a18b362afff441f035b2d9b5bd9"