aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2023-01-11 09:20:54 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2023-01-11 13:00:46 +0200
commit7b36bfcfaeac2c470a2bde9f96eac13434986154 (patch)
treec1ca107a7d4032e27bb29b4e7902c28371290643
parenta02581b881e2bc7026eba1db8a66dcfce1012ce2 (diff)
parent1d1b19ff577835bf847152eed44d52e8267d9093 (diff)
Merge remote-tracking branch 'qt/upstream/master' into lts-5.15
* Removed pyqtchart receipe from build as updated dependency (sip3 -> sip) is not present in meta-openembedded dunfell branch. * Removed Creator patch for API change that got fixed in updated creator revision. changelog: 1d1b19ff qtwebkit: Add packageconfig to build tools 88c8564e qtwebkit: Fix build with ruby 3.2+ b119822b qtpdf,qtwebengine: Fix build with 64bit time_t f1ac1203 qtbase: Fix build with 64bit time_t on glibc 8159b71f layer.conf: update LAYERSERIES_COMPAT for mickledore c22b8fac qt5-creator: bump SRCREV to fix compatibility with newer qt c555401f qtbase: add -DUSE_X11 Flag 2df0f760 qt5: upgrade to v5.15.7-lts-lgpl 1a917695 packagegroup-qt5-toolchain-target: Add qtquickcontrols2-qmlplugins RRECOMMENDS:${PN} 8363b198 qtbase-native: Reduce TMPDIR QA false positives for rcc generated files Task-number: QTBUG-109765 Change-Id: I97f2ef1f1d572768eacfd75e483ef341342c54bd
-rw-r--r--coin/module_config.yaml1
-rw-r--r--conf/layer.conf2
-rw-r--r--recipes-python/pyqt5/python3-pyqt5_5.15.1.bb67
-rw-r--r--recipes-python/pyqtchart/python3-pyqtchart_5.15.1.bb4
-rwxr-xr-xrecipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb1
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb10
-rw-r--r--recipes-qt/qt5/qt5-creator/0001-Fix-interface-of-propertyNameListForWritableProperti.patch53
-rw-r--r--recipes-qt/qt5/qt5-creator_git.bb3
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb12
-rw-r--r--recipes-qt/qt5/qtbase/0021-rcc-Just-dcument-file-name-without-full-path-to-redu.patch29
-rw-r--r--recipes-qt/qt5/qtbase/0022-testlib-don-t-track-the-build-or-source-directories.patch (renamed from recipes-qt/qt5/qtbase/0005-testlib-don-t-track-the-build-or-source-directories.patch)2
-rw-r--r--recipes-qt/qt5/qtbase/0023-Always-build-uic-and-qvkgen.patch (renamed from recipes-qt/qt5/qtbase/0021-Always-build-uic-and-qvkgen.patch)2
-rw-r--r--recipes-qt/qt5/qtbase/0023-zlib-Do-not-undefine-_FILE_OFFSET_BITS.patch34
-rw-r--r--recipes-qt/qt5/qtbase/0024-Avoid-renameeat2-for-native-sdk-builds.patch (renamed from recipes-qt/qt5/qtbase/0022-Avoid-renameeat2-for-native-sdk-builds.patch)2
-rw-r--r--recipes-qt/qt5/qtbase/0025-Bootstrap-without-linkat-feature.patch (renamed from recipes-qt/qt5/qtbase/0023-Bootstrap-without-linkat-feature.patch)2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb8
-rw-r--r--recipes-qt/qt5/qtpdf_git.bb1
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0013-Remove-unsetting-_FILE_OFFSET_BITS.patch37
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
-rw-r--r--recipes-qt/qt5/qtwebkit/0001-Offlineasm-warnings-with-newer-Ruby-versions-https-b.patch47
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb2
21 files changed, 179 insertions, 141 deletions
diff --git a/coin/module_config.yaml b/coin/module_config.yaml
index 8f2a7bbd..3f7f7976 100644
--- a/coin/module_config.yaml
+++ b/coin/module_config.yaml
@@ -151,6 +151,7 @@ instructions:
# EXCLUDE_FROM_WORLD
rm -fv ${SOURCE_DIR}/recipes-qt/examples/qt5-opengles2-test_git.bb
+ rm -rv ${SOURCE_DIR}/recipes-python/pyqtchart/python3-pyqtchart_*.bb
rm -rv ${SOURCE_DIR}/recipes-python/pytest-qt/python3-pytest-qt_*.bb
# build all recipes found in the layer
diff --git a/conf/layer.conf b/conf/layer.conf
index 607e5384..c6b8b60d 100644
--- a/conf/layer.conf
+++ b/conf/layer.conf
@@ -29,7 +29,7 @@ LAYERVERSION_qt5-layer = "1"
LAYERDEPENDS_qt5-layer = "core"
-LAYERSERIES_COMPAT_qt5-layer = "dunfell gatesgarth hardknott honister kirkstone langdale"
+LAYERSERIES_COMPAT_qt5-layer = "dunfell gatesgarth hardknott honister kirkstone langdale mickledore"
LICENSE_PATH += "${LAYERDIR}/licenses"
diff --git a/recipes-python/pyqt5/python3-pyqt5_5.15.1.bb b/recipes-python/pyqt5/python3-pyqt5_5.15.1.bb
deleted file mode 100644
index b751268d..00000000
--- a/recipes-python/pyqt5/python3-pyqt5_5.15.1.bb
+++ /dev/null
@@ -1,67 +0,0 @@
-SUMMARY = "Python Qt5 Bindings"
-AUTHOR = "Phil Thomson @ riverbank.co.uk"
-HOMEPAGE = "https://www.riverbankcomputing.com/software/pyqt"
-SECTION = "devel/python"
-LICENSE = "GPL-3.0-only"
-LIC_FILES_CHKSUM = "\
- file://LICENSE;md5=d32239bcb673463ab874e80d47fae504 \
-"
-
-inherit pypi
-
-PYPI_PACKAGE = "PyQt5"
-
-SRC_URI[md5sum] = "b60f895e70d31d774e6cd374efd17c65"
-SRC_URI[sha256sum] = "d9a76b850246d08da9863189ecb98f6c2aa9b4d97a3e85e29330a264aed0f9a1"
-
-S = "${WORKDIR}/PyQt5-${PV}"
-
-inherit qmake5
-inherit python3native python3-dir
-
-DEPENDS = "qtbase qtdeclarative qtquickcontrols2"
-DEPENDS += "sip3 sip3-native python3"
-
-export BUILD_SYS
-export HOST_SYS
-export STAGING_INCDIR
-export STAGING_LIBDIR
-
-PARALLEL_MAKEINST = ""
-
-DISABLED_FEATURES = "PyQt_Desktop_OpenGL PyQt_Accessibility PyQt_SessionManager ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', '', 'PyQt_OpenGL', d)}"
-
-PYQT_MODULES = "QtCore QtGui QtNetwork QtXml QtNetwork QtQml ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'QtQuick QtWidgets QtQuickWidgets', '', d)}"
-
-do_configure:prepend() {
- cd ${S}
- echo "py_platform = linux" > pyqt.cfg
- echo "py_inc_dir = %(sysroot)/$includedir/python%(py_major).%(py_minor)${PYTHON_ABI}" >> pyqt.cfg
- echo "py_pylib_dir = %(sysroot)/${libdir}/python%(py_major).%(py_minor)" >> pyqt.cfg
- echo "py_pylib_lib = python$%(py_major).%(py_minor)" >> pyqt.cfg
- echo "pyqt_module_dir = ${D}/${libdir}/python%(py_major).%(py_minor)/site-packages" >> pyqt.cfg
- echo "pyqt_bin_dir = ${D}/${bindir}" >> pyqt.cfg
- echo "pyqt_sip_dir = ${D}/${datadir}/sip/PyQt5" >> pyqt.cfg
- echo "pyuic_interpreter = ${D}/${bindir}/python%(py_major).%(py_minor)" >> pyqt.cfg
- echo "pyqt_disabled_features = ${DISABLED_FEATURES}" >> pyqt.cfg
- echo "qt_shared = True" >> pyqt.cfg
- QT_VERSION=`${OE_QMAKE_QMAKE} -query QT_VERSION`
- echo "[Qt $QT_VERSION]" >> pyqt.cfg
- echo "pyqt_modules = ${PYQT_MODULES}" >> pyqt.cfg
- echo yes | ${PYTHON} configure.py --verbose --qmake ${STAGING_BINDIR_NATIVE}/${QT_DIR_NAME}/qmake --configuration pyqt.cfg --sysroot ${STAGING_DIR_HOST}
-}
-
-do_compile() {
- cd ${S}
- oe_runmake
-}
-
-do_install() {
- cd ${S}
- oe_runmake MAKEFLAGS='-j 1' install
-}
-
-FILES:${PN} += "${libdir}/${PYTHON_DIR}/site-packages ${datadir}/sip/PyQt5/"
-
-RDEPENDS:${PN} = "qtbase qtdeclarative qtquickcontrols2 qtquickcontrols2-mkspecs"
-RDEPENDS:${PN} += "python3-core python3-sip3"
diff --git a/recipes-python/pyqtchart/python3-pyqtchart_5.15.1.bb b/recipes-python/pyqtchart/python3-pyqtchart_5.15.1.bb
index 03497034..0bb84fe0 100644
--- a/recipes-python/pyqtchart/python3-pyqtchart_5.15.1.bb
+++ b/recipes-python/pyqtchart/python3-pyqtchart_5.15.1.bb
@@ -20,7 +20,7 @@ inherit qmake5
inherit python3native python3-dir
DEPENDS = "qtcharts"
-DEPENDS += "sip3 sip3-native python3 python3-pyqt5"
+DEPENDS += "sip sip-native python3 python3-pyqt5"
export BUILD_SYS
export HOST_SYS
@@ -66,4 +66,4 @@ do_install() {
FILES:${PN} += "${libdir}/${PYTHON_DIR}/site-packages ${datadir}/"
RDEPENDS:${PN} = "qtbase qtdeclarative qtquickcontrols2 qtquickcontrols2-mkspecs qtcharts"
-RDEPENDS:${PN} += "python3-core python3-sip3 python3-pyqt5"
+RDEPENDS:${PN} += "python3-core sip python3-pyqt5"
diff --git a/recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb b/recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb
index 35f14fd3..98f7be2c 100755
--- a/recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb
+++ b/recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb
@@ -105,6 +105,7 @@ RDEPENDS:${PN}:remove:toolchain-clang:riscv64 = "qttools-dev qttools-mkspecs qtt
RRECOMMENDS:${PN} += " \
qtquickcontrols-qmlplugins \
+ qtquickcontrols2-qmlplugins \
qttools-plugins \
"
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index d0b02287..dc8e0f41 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -25,7 +25,7 @@ FILESEXTRAPATHS =. "${FILE_DIRNAME}/qtbase:"
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.15-shared
-# 5.15.meta-qt5-shared.3
+# 5.15.meta-qt5-shared.4
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -45,14 +45,16 @@ SRC_URI += "\
file://0017-Define-__NR_futex-if-it-does-not-exist.patch \
file://0018-Revert-Fix-workaround-in-pthread-destructor.patch \
file://0019-tst_QPluginLoader-Simplify-creating-a-fake-pointer-i.patch \
+ file://0021-rcc-Just-dcument-file-name-without-full-path-to-redu.patch \
+ file://0022-testlib-don-t-track-the-build-or-source-directories.patch \
"
# common for qtbase-native and nativesdk-qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.15-native
-# 5.15.meta-qt5-native.3
+# 5.15.meta-qt5-native.4
SRC_URI += " \
- file://0021-Always-build-uic-and-qvkgen.patch \
- file://0022-Avoid-renameeat2-for-native-sdk-builds.patch \
+ file://0023-Always-build-uic-and-qvkgen.patch \
+ file://0024-Avoid-renameeat2-for-native-sdk-builds.patch \
"
# CMake's toolchain configuration of nativesdk-qtbase
diff --git a/recipes-qt/qt5/qt5-creator/0001-Fix-interface-of-propertyNameListForWritableProperti.patch b/recipes-qt/qt5/qt5-creator/0001-Fix-interface-of-propertyNameListForWritableProperti.patch
deleted file mode 100644
index 28fe7844..00000000
--- a/recipes-qt/qt5/qt5-creator/0001-Fix-interface-of-propertyNameListForWritableProperti.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From aa1f4a5dc09d8ded55384bd2172bea431ffa479c Mon Sep 17 00:00:00 2001
-From: Jani Suonpera <jani.suonpera@qt.io>
-Date: Wed, 15 Sep 2021 13:54:30 +0300
-Subject: [PATCH] Fix interface of propertyNameListForWritablePropertie
-
-There are show compiling error:
-Compiling error:
-|build/tmp/work/armv7vet2hf-neon-poky-linux-gnueabi/qt5-creator/4.15.0+gitAUTOINC+978f6caf1e-r0/git/share/qtcreator/qml/qmlpuppet/qmlprivategate/qmlprivategate_56.cpp: In function 'QmlDesigner::PropertyNameList QmlDesigner::Internal::QmlPrivateGate::propertyNameListForWritableProperties(QObject*, const PropertyName&, QObjectList*)':
-| build/tmp/work/armv7vet2hf-neon-poky-linux-gnueabi/qt5-creator/4.15.0+gitAUTOINC+978f6caf1e-r0/git/share/qtcreator/qml/qmlpuppet/qmlprivategate/qmlprivategate_56.cpp:156:117: error: no matching function for call to 'QQuickDesignerSupportProperties::propertyNameListForWritableProperties(QObject*&, const PropertyName&, QObjectList*&)'
-| 156 | return QQuickDesignerSupportProperties::propertyNameListForWritableProperties(object, baseName, inspectedObjects);
-
-This is cause of interface changes. There are drop out parameters
-baseName and inspectedObjects from
-QQuickDesignerSupportProperties::propertyNameListForWritableProperties.
-
----
- .../qtcreator/qml/qmlpuppet/qmlprivategate/qmlprivategate.h | 4 +---
- .../qml/qmlpuppet/qmlprivategate/qmlprivategate_56.cpp | 6 ++----
- 2 files changed, 3 insertions(+), 7 deletions(-)
-
-diff --git a/share/qtcreator/qml/qmlpuppet/qmlprivategate/qmlprivategate.h b/share/qtcreator/qml/qmlpuppet/qmlprivategate/qmlprivategate.h
-index b0b68907ed..e600db3c60 100644
---- a/share/qtcreator/qml/qmlpuppet/qmlprivategate/qmlprivategate.h
-+++ b/share/qtcreator/qml/qmlpuppet/qmlprivategate/qmlprivategate.h
-@@ -68,9 +68,7 @@ public:
- QObject *createComponent(const QUrl &componentUrl, QQmlContext *context);
- void tweakObjects(QObject *object);
- bool isPropertyBlackListed(const QmlDesigner::PropertyName &propertyName);
-- PropertyNameList propertyNameListForWritableProperties(QObject *object,
-- const PropertyName &baseName = PropertyName(),
-- QObjectList *inspectedObjects = nullptr);
-+ PropertyNameList propertyNameListForWritableProperties(QObject *object);
- PropertyNameList allPropertyNames(QObject *object,
- const PropertyName &baseName = PropertyName(),
- QObjectList *inspectedObjects = nullptr);
-diff --git a/share/qtcreator/qml/qmlpuppet/qmlprivategate/qmlprivategate_56.cpp b/share/qtcreator/qml/qmlpuppet/qmlprivategate/qmlprivategate_56.cpp
-index 7e5af01944..b9d6b75596 100644
---- a/share/qtcreator/qml/qmlpuppet/qmlprivategate/qmlprivategate_56.cpp
-+++ b/share/qtcreator/qml/qmlpuppet/qmlprivategate/qmlprivategate_56.cpp
-@@ -149,11 +149,9 @@ PropertyNameList allPropertyNames(QObject *object,
- #endif
- }
-
--PropertyNameList propertyNameListForWritableProperties(QObject *object,
-- const PropertyName &baseName,
-- QObjectList *inspectedObjects)
-+PropertyNameList propertyNameListForWritableProperties(QObject *object)
- {
-- return QQuickDesignerSupportProperties::propertyNameListForWritableProperties(object, baseName, inspectedObjects);
-+ return QQuickDesignerSupportProperties::propertyNameListForWritableProperties(object);
- }
-
- void tweakObjects(QObject *object)
diff --git a/recipes-qt/qt5/qt5-creator_git.bb b/recipes-qt/qt5/qt5-creator_git.bb
index ea656493..85bfcc35 100644
--- a/recipes-qt/qt5/qt5-creator_git.bb
+++ b/recipes-qt/qt5/qt5-creator_git.bb
@@ -17,14 +17,13 @@ inherit qmake5 pkgconfig mime-xdg
DEPENDS += "qtbase qtscript qtxmlpatterns qtx11extras qtdeclarative qttools qttools-native qtsvg chrpath-replacement-native zlib"
DEPENDS:append:libc-musl = " libexecinfo"
-SRCREV = "94d227cd434d09717de95529e5210ec530451e1c"
+SRCREV = "39ac7b1bf6add473026687003311b702742b6b21"
PV = "4.15.2+git${SRCPV}"
# Patches from https://github.com/meta-qt5/qtcreator/commits/b4.9.2
# 4.9.2.meta-qt5.1
SRC_URI = " \
git://code.qt.io/qt-creator/qt-creator.git;branch=4.15 \
file://0001-app-Use-malloc_trim-only-on-glibc.patch \
- file://0001-Fix-interface-of-propertyNameListForWritableProperti.patch \
file://0002-clangformat-Fix-build-with-LLVM-13.patch \
file://0003-clangformat-Fix-build-with-LLVM-13.patch \
"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 993912a8..09eeb9b1 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -18,7 +18,7 @@ require qt5-lts.inc
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.15-shared
-# 5.15.meta-qt5-shared.3
+# 5.15.meta-qt5-shared.4
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -38,19 +38,21 @@ SRC_URI += "\
file://0017-Define-__NR_futex-if-it-does-not-exist.patch \
file://0018-Revert-Fix-workaround-in-pthread-destructor.patch \
file://0019-tst_QPluginLoader-Simplify-creating-a-fake-pointer-i.patch \
+ file://0021-rcc-Just-dcument-file-name-without-full-path-to-redu.patch \
+ file://0022-testlib-don-t-track-the-build-or-source-directories.patch \
"
# common for qtbase-native and nativesdk-qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.15-native
-# 5.15.meta-qt5-native.3
+# 5.15.meta-qt5-native.4
SRC_URI += " \
- file://0021-Always-build-uic-and-qvkgen.patch \
- file://0022-Avoid-renameeat2-for-native-sdk-builds.patch \
+ file://0023-Always-build-uic-and-qvkgen.patch \
+ file://0024-Avoid-renameeat2-for-native-sdk-builds.patch \
"
# only for qtbase-native
SRC_URI += " \
- file://0023-Bootstrap-without-linkat-feature.patch \
+ file://0025-Bootstrap-without-linkat-feature.patch \
"
CLEANBROKEN = "1"
diff --git a/recipes-qt/qt5/qtbase/0021-rcc-Just-dcument-file-name-without-full-path-to-redu.patch b/recipes-qt/qt5/qtbase/0021-rcc-Just-dcument-file-name-without-full-path-to-redu.patch
new file mode 100644
index 00000000..521e6cc3
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0021-rcc-Just-dcument-file-name-without-full-path-to-redu.patch
@@ -0,0 +1,29 @@
+From a2b11501812e0e34bd49b1950bac52dadd4e3cff Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
+Date: Sat, 15 Oct 2022 15:50:34 +0200
+Subject: [PATCH] rcc: Just dcument file name without full path to reduce qa
+ warnings
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Upstream-Status: Inappropriate [OE specific]
+
+Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
+---
+ src/tools/rcc/rcc.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/tools/rcc/rcc.cpp b/src/tools/rcc/rcc.cpp
+index c5e3d2ae4c..2d76cfd081 100644
+--- a/src/tools/rcc/rcc.cpp
++++ b/src/tools/rcc/rcc.cpp
+@@ -344,7 +344,7 @@ qint64 RCCFileInfo::writeDataBlob(RCCResourceLibrary &lib, qint64 offset,
+ // some info
+ if (text || pass1) {
+ lib.writeString(" // ");
+- lib.writeByteArray(m_fileInfo.absoluteFilePath().toLocal8Bit());
++ lib.writeByteArray(m_fileInfo.baseName().toLocal8Bit());
+ lib.writeString("\n ");
+ }
+
diff --git a/recipes-qt/qt5/qtbase/0005-testlib-don-t-track-the-build-or-source-directories.patch b/recipes-qt/qt5/qtbase/0022-testlib-don-t-track-the-build-or-source-directories.patch
index d6715460..f0d5404a 100644
--- a/recipes-qt/qt5/qtbase/0005-testlib-don-t-track-the-build-or-source-directories.patch
+++ b/recipes-qt/qt5/qtbase/0022-testlib-don-t-track-the-build-or-source-directories.patch
@@ -1,4 +1,4 @@
-From 8b2ff0bb21fa447d4383aa5c749f3dcec52fe525 Mon Sep 17 00:00:00 2001
+From 7d4da27df6ab641390de75dd7c04b755295a653b Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Mon, 22 Aug 2022 15:01:28 +0300
Subject: [PATCH] testlib: don't track the build or source directories
diff --git a/recipes-qt/qt5/qtbase/0021-Always-build-uic-and-qvkgen.patch b/recipes-qt/qt5/qtbase/0023-Always-build-uic-and-qvkgen.patch
index 5c878d72..268b2347 100644
--- a/recipes-qt/qt5/qtbase/0021-Always-build-uic-and-qvkgen.patch
+++ b/recipes-qt/qt5/qtbase/0023-Always-build-uic-and-qvkgen.patch
@@ -1,4 +1,4 @@
-From 418c46b025edadc142ac60a6eb4c553dad19efed Mon Sep 17 00:00:00 2001
+From 5f415fb09ea64765e60d1d52721064f53545a413 Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Sat, 16 Nov 2013 00:32:30 +0100
Subject: [PATCH] Always build uic and qvkgen
diff --git a/recipes-qt/qt5/qtbase/0023-zlib-Do-not-undefine-_FILE_OFFSET_BITS.patch b/recipes-qt/qt5/qtbase/0023-zlib-Do-not-undefine-_FILE_OFFSET_BITS.patch
new file mode 100644
index 00000000..fbef6bb0
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0023-zlib-Do-not-undefine-_FILE_OFFSET_BITS.patch
@@ -0,0 +1,34 @@
+From 6822e78d1e0e67d14bb06f74a02cf48875e901c5 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sun, 1 Jan 2023 21:30:23 -0800
+Subject: [PATCH] zlib: Do not undefine _FILE_OFFSET_BITS
+
+This is required for 64bit time_t to work with glibc as it needs
+_FILE_OFFSET_BITS to be defined as 64 as well.
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/3rdparty/zlib/src/gzguts.h | 9 ---------
+ 1 file changed, 9 deletions(-)
+
+diff --git a/src/3rdparty/zlib/src/gzguts.h b/src/3rdparty/zlib/src/gzguts.h
+index 3ec32af25f..d1916b215e 100644
+--- a/src/3rdparty/zlib/src/gzguts.h
++++ b/src/3rdparty/zlib/src/gzguts.h
+@@ -22,15 +22,6 @@
+ #define HAVE_HIDDEN
+ #endif
+
+-#ifdef _LARGEFILE64_SOURCE
+-# ifndef _LARGEFILE_SOURCE
+-# define _LARGEFILE_SOURCE 1
+-# endif
+-# ifdef _FILE_OFFSET_BITS
+-# undef _FILE_OFFSET_BITS
+-# endif
+-#endif
+-
+ #ifdef HAVE_HIDDEN
+ # define ZLIB_INTERNAL __attribute__((visibility ("hidden")))
+ #else
diff --git a/recipes-qt/qt5/qtbase/0022-Avoid-renameeat2-for-native-sdk-builds.patch b/recipes-qt/qt5/qtbase/0024-Avoid-renameeat2-for-native-sdk-builds.patch
index fab399a2..97e4ff6c 100644
--- a/recipes-qt/qt5/qtbase/0022-Avoid-renameeat2-for-native-sdk-builds.patch
+++ b/recipes-qt/qt5/qtbase/0024-Avoid-renameeat2-for-native-sdk-builds.patch
@@ -1,4 +1,4 @@
-From 9ff02d5ebc1d0969306c57cbf77df861ec3924fc Mon Sep 17 00:00:00 2001
+From 77196464454a1c66e57ad5aac237a55de211a107 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
Date: Sun, 14 Apr 2019 13:27:58 +0200
Subject: [PATCH] Avoid renameeat2 for native(sdk) builds
diff --git a/recipes-qt/qt5/qtbase/0023-Bootstrap-without-linkat-feature.patch b/recipes-qt/qt5/qtbase/0025-Bootstrap-without-linkat-feature.patch
index f5e5268b..bd14bfb3 100644
--- a/recipes-qt/qt5/qtbase/0023-Bootstrap-without-linkat-feature.patch
+++ b/recipes-qt/qt5/qtbase/0025-Bootstrap-without-linkat-feature.patch
@@ -1,4 +1,4 @@
-From f992d0551cd14c11fdb61511ac1d36ecf853089a Mon Sep 17 00:00:00 2001
+From a052a876d0639db2f919aada2ae0afe1718928af Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Fri, 24 Nov 2017 15:16:31 +0200
Subject: [PATCH] Bootstrap without linkat feature
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index c24fc1ec..dec78474 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = " \
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.15-shared
-# 5.15.meta-qt5-shared.3
+# 5.15.meta-qt5-shared.4
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -34,7 +34,9 @@ SRC_URI += "\
file://0017-Define-__NR_futex-if-it-does-not-exist.patch \
file://0018-Revert-Fix-workaround-in-pthread-destructor.patch \
file://0019-tst_QPluginLoader-Simplify-creating-a-fake-pointer-i.patch \
- file://0005-testlib-don-t-track-the-build-or-source-directories.patch \
+ file://0021-rcc-Just-dcument-file-name-without-full-path-to-redu.patch \
+ file://0022-testlib-don-t-track-the-build-or-source-directories.patch \
+ file://0023-zlib-Do-not-undefine-_FILE_OFFSET_BITS.patch \
"
# Disable LTO for now, QT5 patches are being worked upstream, perhaps revisit with
@@ -114,7 +116,7 @@ PACKAGECONFIG[no-opengl] = "-no-opengl"
PACKAGECONFIG[tslib] = "-tslib,-no-tslib,tslib"
PACKAGECONFIG[cups] = "-cups,-no-cups,cups"
PACKAGECONFIG[dbus] = "-dbus,-no-dbus,dbus"
-PACKAGECONFIG[xcb] = "-xcb -xcb-xlib -no-bundled-xcb-xinput,-no-xcb,libxcb xcb-util-wm xcb-util-image xcb-util-keysyms xcb-util-renderutil libxext"
+PACKAGECONFIG[xcb] = "-xcb -xcb-xlib -no-bundled-xcb-xinput -DUSE_X11=ON,-no-xcb,libxcb xcb-util-wm xcb-util-image xcb-util-keysyms xcb-util-renderutil libxext"
PACKAGECONFIG[sql-ibase] = "-sql-ibase,-no-sql-ibase"
PACKAGECONFIG[sql-mysql] = "-sql-mysql -mysql_config ${STAGING_BINDIR_CROSS}/mysql_config,-no-sql-mysql,mysql5"
PACKAGECONFIG[sql-psql] = "-sql-psql,-no-sql-psql,postgresql"
diff --git a/recipes-qt/qt5/qtpdf_git.bb b/recipes-qt/qt5/qtpdf_git.bb
index 4b35c0a1..c65293b4 100644
--- a/recipes-qt/qt5/qtpdf_git.bb
+++ b/recipes-qt/qt5/qtpdf_git.bb
@@ -162,6 +162,7 @@ SRC_URI += " \
file://chromium/0010-chromium-icu-use-system-library-only-targets.patch;patchdir=src/3rdparty \
file://chromium/0011-chromium-Remove-TRUE-to-prep-landing-of-icu68.patch;patchdir=src/3rdparty \
file://chromium/0012-chromium-skia-Fix-build-with-gcc-12.patch;patchdir=src/3rdparty \
+ file://chromium/0013-Remove-unsetting-_FILE_OFFSET_BITS.patch;patchdir=src/3rdparty \
"
# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/87-based
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0013-Remove-unsetting-_FILE_OFFSET_BITS.patch b/recipes-qt/qt5/qtwebengine/chromium/0013-Remove-unsetting-_FILE_OFFSET_BITS.patch
new file mode 100644
index 00000000..4484d4ee
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/chromium/0013-Remove-unsetting-_FILE_OFFSET_BITS.patch
@@ -0,0 +1,37 @@
+From a6ed61f9435d25abdb71c2a2b84b204f180eb822 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 3 Jan 2023 14:10:23 -0800
+Subject: [PATCH] Remove unsetting _FILE_OFFSET_BITS
+
+This does not work when enabling 64bit time_t with glibc which is enabled with -D_TIME_BITS=64, since it also needs
+_FILE_OFFSET_BITS=64 and this does not work when its undefined explicitly
+
+Upstream-Status: Submitted [https://github.com/madler/zlib/pull/764]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ chromium/third_party/zlib/gzguts.h | 9 ---------
+ 1 file changed, 9 deletions(-)
+
+diff --git a/chromium/third_party/zlib/gzguts.h b/chromium/third_party/zlib/gzguts.h
+index 990a4d25149..a03d5005070 100644
+--- a/chromium/third_party/zlib/gzguts.h
++++ b/chromium/third_party/zlib/gzguts.h
+@@ -3,15 +3,6 @@
+ * For conditions of distribution and use, see copyright notice in zlib.h
+ */
+
+-#ifdef _LARGEFILE64_SOURCE
+-# ifndef _LARGEFILE_SOURCE
+-# define _LARGEFILE_SOURCE 1
+-# endif
+-# ifdef _FILE_OFFSET_BITS
+-# undef _FILE_OFFSET_BITS
+-# endif
+-#endif
+-
+ #ifdef HAVE_HIDDEN
+ # define ZLIB_INTERNAL __attribute__((visibility ("hidden")))
+ #else
+--
+2.39.0
+
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 1cf6184f..0fec81bd 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -180,6 +180,7 @@ SRC_URI += " \
file://chromium/0011-chromium-Add-missing-include-for-C-strncpy.patch;patchdir=src/3rdparty \
file://chromium/0011-chromium-Remove-TRUE-to-prep-landing-of-icu68.patch;patchdir=src/3rdparty \
file://chromium/0012-chromium-skia-Fix-build-with-gcc-12.patch;patchdir=src/3rdparty \
+ file://chromium/0013-Remove-unsetting-_FILE_OFFSET_BITS.patch;patchdir=src/3rdparty \
"
# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/87-based
diff --git a/recipes-qt/qt5/qtwebkit/0001-Offlineasm-warnings-with-newer-Ruby-versions-https-b.patch b/recipes-qt/qt5/qtwebkit/0001-Offlineasm-warnings-with-newer-Ruby-versions-https-b.patch
new file mode 100644
index 00000000..cbe72874
--- /dev/null
+++ b/recipes-qt/qt5/qtwebkit/0001-Offlineasm-warnings-with-newer-Ruby-versions-https-b.patch
@@ -0,0 +1,47 @@
+From 330bdeeaa4389225c27d27188499543ddd184f69 Mon Sep 17 00:00:00 2001
+From: Adrian Perez de Castro <aperez@igalia.com>
+Date: Wed, 15 Jan 2020 22:15:38 +0000
+Subject: [PATCH] Offlineasm warnings with newer Ruby versions
+ https://bugs.webkit.org/show_bug.cgi?id=206233
+
+Reviewed by Yusuke Suzuki.
+
+Avoid a warning about using Object#=~ on Annotation instances, which
+has been deprecated in Ruby 2.7.
+
+* offlineasm/parser.rb: Swap checks to prevent applying the =~ operator
+to Annotation instances, which do not define it.
+
+Canonical link: https://commits.webkit.org/219400@main
+git-svn-id: https://svn.webkit.org/repository/webkit/trunk@254637 268f45cc-cd09-0410-ab3c-d52691b4dbfc
+---
+ Source/JavaScriptCore/offlineasm/parser.rb | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Source/JavaScriptCore/offlineasm/parser.rb b/Source/JavaScriptCore/offlineasm/parser.rb
+index b44511245..cd1cffaec 100644
+--- a/Source/JavaScriptCore/offlineasm/parser.rb
++++ b/Source/JavaScriptCore/offlineasm/parser.rb
+@@ -584,9 +584,7 @@ class Parser
+ firstCodeOrigin = @tokens[@idx].codeOrigin
+ list = []
+ loop {
+- if (@idx == @tokens.length and not final) or (final and @tokens[@idx] =~ final)
+- break
+- elsif @tokens[@idx].is_a? Annotation
++ if @tokens[@idx].is_a? Annotation
+ # This is the only place where we can encounter a global
+ # annotation, and hence need to be able to distinguish between
+ # them.
+@@ -600,6 +598,8 @@ class Parser
+ list << Instruction.new(codeOrigin, annotationOpcode, [], @tokens[@idx].string)
+ @annotation = nil
+ @idx += 2 # Consume the newline as well.
++ elsif (@idx == @tokens.length and not final) or (final and @tokens[@idx] =~ final)
++ break
+ elsif @tokens[@idx] == "\n"
+ # ignore
+ @idx += 1
+--
+2.39.0
+
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index ee69a6a2..dddafbe6 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -24,6 +24,7 @@ SRC_URI += "\
file://0008-Fix-build-with-icu-68.patch \
file://0009-Riscv-Add-support-for-riscv.patch \
file://mips-atomic.patch \
+ file://0001-Offlineasm-warnings-with-newer-Ruby-versions-https-b.patch \
"
SRC_URI:append:riscv32 = " file://0010-webdriver-libatomic.patch "
@@ -94,6 +95,7 @@ PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,libxcomposi
PACKAGECONFIG[fontconfig] = "-DENABLE_TEST_SUPPORT=ON,-DENABLE_TEST_SUPPORT=OFF,fontconfig"
# hyphen is only in meta-office currently!
PACKAGECONFIG[hyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,hyphen"
+PACKAGECONFIG[tools] = "-DENABLE_TOOLS=ON,-DENABLE_TOOLS=OFF,"
# remove default ${PN}-examples* set in qt5.inc, because they conflicts with ${PN} from separate webkit-examples recipe
PACKAGES:remove = "${PN}-examples"