aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJani Suonpera <jani.suonpera@qt.io>2021-09-22 13:44:05 +0300
committerJani Suonpera <jani.suonpera@qt.io>2021-09-23 06:30:11 +0000
commit9155b94538e1834f3b2027f13699727772d3ecbc (patch)
tree6fbece63baeb3154ad0c04ace28c98bc196fab0b
parent1a30142e7cfd82962fbacfc6b65f5c1fc046aa5d (diff)
parent10f3673fd4b6c6e1e61c23478802f83652475a5f (diff)
Merge commit '10f3673f' into lts-5.15
10f3673f is last SHA1 in upstream master, which does not include Yocto branch Honister. Task-number: QTBUG-96310 Change-Id: I6c9cb67693d8594d727d91e559b190db633a0f67
-rw-r--r--classes/cmake_qt5.bbclass5
-rw-r--r--recipes-qt/qt5/qt5-creator/0002-clangformat-Fix-build-with-LLVM-13.patch49
-rw-r--r--recipes-qt/qt5/qt5-creator/0003-clangformat-Fix-build-with-LLVM-13.patch32
-rw-r--r--recipes-qt/qt5/qt5-creator_git.bb6
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
-rw-r--r--recipes-qt/qwt/qwt-qt5/0001-missing-qpainterpath.h-include-added-needed-with-Qt-.patch131
-rw-r--r--recipes-qt/qwt/qwt-qt5_6.1.5.bb (renamed from recipes-qt/qwt/qwt-qt5_6.1.4.bb)4
8 files changed, 92 insertions, 138 deletions
diff --git a/classes/cmake_qt5.bbclass b/classes/cmake_qt5.bbclass
index 5ba960ec..e380a0ef 100644
--- a/classes/cmake_qt5.bbclass
+++ b/classes/cmake_qt5.bbclass
@@ -1,7 +1,10 @@
inherit cmake
inherit qmake5_paths
-DEPENDS_prepend = "qtbase qtbase-native "
+DEPENDS_prepend = "${QTBASEDEPENDS} "
+QTBASEDEPENDS = "qtbase qtbase-native"
+QTBASEDEPENDS_class-native = "qtbase-native"
+QTBASEDEPENDS_class-nativesdk = "nativesdk-qtbase qtbase-native"
EXTRA_OECMAKE_prepend = " \
-DOE_QMAKE_PATH_PREFIX=${OE_QMAKE_PATH_PREFIX} \
diff --git a/recipes-qt/qt5/qt5-creator/0002-clangformat-Fix-build-with-LLVM-13.patch b/recipes-qt/qt5/qt5-creator/0002-clangformat-Fix-build-with-LLVM-13.patch
new file mode 100644
index 00000000..e03ef5b7
--- /dev/null
+++ b/recipes-qt/qt5/qt5-creator/0002-clangformat-Fix-build-with-LLVM-13.patch
@@ -0,0 +1,49 @@
+From 14eb5b382cabf90352634393c19bf87a4c15766a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Bj=C3=B6rn=20Sch=C3=A4pers?= <bjoern@hazardy.de>
+Date: Mon, 8 Mar 2021 21:56:06 +0100
+Subject: [PATCH] clangformat: Fix build with LLVM 13
+
+Change-Id: I5eaad17a6f240aa1e3f246492b69f093b4f59fee
+Reviewed-by: David Schulz <david.schulz@qt.io>
+
+Upstream-Status: Accepted [https://code.qt.io/cgit/qt-creator/qt-creator.git/commit/?id=14eb5b382cabf90352634393c19bf87a4c15766a]
+---
+ src/plugins/clangformat/clangformatbaseindenter.cpp | 4 ++++
+ src/plugins/clangformat/clangformatutils.cpp | 4 ++++
+ 2 files changed, 8 insertions(+)
+
+diff --git a/src/plugins/clangformat/clangformatbaseindenter.cpp b/src/plugins/clangformat/clangformatbaseindenter.cpp
+index fb8e693809..6378b2af53 100644
+--- a/src/plugins/clangformat/clangformatbaseindenter.cpp
++++ b/src/plugins/clangformat/clangformatbaseindenter.cpp
+@@ -42,7 +42,11 @@ void adjustFormatStyleForLineBreak(clang::format::FormatStyle &style,
+ ReplacementsToKeep replacementsToKeep)
+ {
+ style.MaxEmptyLinesToKeep = 100;
++#if LLVM_VERSION_MAJOR >= 13
++ style.SortIncludes = clang::format::FormatStyle::SI_Never;
++#else
+ style.SortIncludes = false;
++#endif
+ style.SortUsingDeclarations = false;
+
+ // This is a separate pass, don't do it unless it's the full formatting.
+diff --git a/src/plugins/clangformat/clangformatutils.cpp b/src/plugins/clangformat/clangformatutils.cpp
+index a249327d0e..770e75908c 100644
+--- a/src/plugins/clangformat/clangformatutils.cpp
++++ b/src/plugins/clangformat/clangformatutils.cpp
+@@ -145,7 +145,11 @@ static clang::format::FormatStyle qtcStyle()
+ style.PenaltyReturnTypeOnItsOwnLine = 300;
+ style.PointerAlignment = FormatStyle::PAS_Right;
+ style.ReflowComments = false;
++#ifdef LLVM_VERSION_MAJOR >= 13
++ style.SortIncludes = FormatStyle::SI_CaseSensitive;
++#else
+ style.SortIncludes = true;
++#endif
+ style.SortUsingDeclarations = true;
+ style.SpaceAfterCStyleCast = true;
+ style.SpaceAfterTemplateKeyword = false;
+--
+2.31.1
+
diff --git a/recipes-qt/qt5/qt5-creator/0003-clangformat-Fix-build-with-LLVM-13.patch b/recipes-qt/qt5/qt5-creator/0003-clangformat-Fix-build-with-LLVM-13.patch
new file mode 100644
index 00000000..33761797
--- /dev/null
+++ b/recipes-qt/qt5/qt5-creator/0003-clangformat-Fix-build-with-LLVM-13.patch
@@ -0,0 +1,32 @@
+From 55b91a76172a3235b4879daf0b675519d5b02db7 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Bj=C3=B6rn=20Sch=C3=A4pers?= <bjoern@hazardy.de>
+Date: Wed, 16 Jun 2021 20:59:29 +0200
+Subject: [PATCH] clangformat: Fix build with LLVM 13
+
+Change-Id: Ia9db10696fd129c8b989ecc4c9ecbb7f1f10e68c
+Reviewed-by: David Schulz <david.schulz@qt.io>
+
+Upstream-Status: Accepted [https://code.qt.io/cgit/qt-creator/qt-creator.git/commit/?id=55b91a76172a3235b4879daf0b675519d5b02db7]
+---
+ src/plugins/clangformat/clangformatutils.cpp | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/plugins/clangformat/clangformatutils.cpp b/src/plugins/clangformat/clangformatutils.cpp
+index 2f9a306b99..3905ae5f6a 100644
+--- a/src/plugins/clangformat/clangformatutils.cpp
++++ b/src/plugins/clangformat/clangformatutils.cpp
+@@ -157,7 +157,11 @@ static clang::format::FormatStyle qtcStyle()
+ style.SpaceBeforeParens = FormatStyle::SBPO_ControlStatements;
+ style.SpaceInEmptyParentheses = false;
+ style.SpacesBeforeTrailingComments = 1;
++#if LLVM_VERSION_MAJOR >= 13
++ style.SpacesInAngles = FormatStyle::SIAS_Never;
++#else
+ style.SpacesInAngles = false;
++#endif
+ style.SpacesInContainerLiterals = false;
+ style.SpacesInCStyleCastParentheses = false;
+ style.SpacesInParentheses = false;
+--
+2.31.1
+
diff --git a/recipes-qt/qt5/qt5-creator_git.bb b/recipes-qt/qt5/qt5-creator_git.bb
index d89b0758..1d0e2216 100644
--- a/recipes-qt/qt5/qt5-creator_git.bb
+++ b/recipes-qt/qt5/qt5-creator_git.bb
@@ -17,14 +17,16 @@ inherit qmake5 mime-xdg
DEPENDS += "qtbase qtscript qtxmlpatterns qtx11extras qtdeclarative qttools qttools-native qtsvg chrpath-replacement-native zlib"
DEPENDS_append_libc-musl = " libexecinfo"
-SRCREV = "978f6caf1e18ad0b0415fde60a8c130448969c6d"
-PV = "4.15.0+git${SRCPV}"
+SRCREV = "94d227cd434d09717de95529e5210ec530451e1c"
+PV = "4.15.2+git${SRCPV}"
# Patches from https://github.com/meta-qt5/qtcreator/commits/b4.9.2
# 4.9.2.meta-qt5.1
SRC_URI = " \
git://code.qt.io/qt-creator/qt-creator.git;branch=4.15 \
file://0001-app-Use-malloc_trim-only-on-glibc.patch \
file://0001-Fix-interface-of-propertyNameListForWritableProperti.patch \
+ file://0002-clangformat-Fix-build-with-LLVM-13.patch \
+ file://0003-clangformat-Fix-build-with-LLVM-13.patch \
"
SRC_URI_append_libc-musl = " file://0001-Link-with-libexecinfo-on-musl.patch"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 4982dfd1..d5559279 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -20,7 +20,7 @@ SRC_URI += "file://0001-tst_seatv4-Include-array.patch"
PACKAGECONFIG ?= " \
wayland-client \
wayland-server \
- ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'wayland-egl', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'opengl wayland', 'wayland-egl', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xcomposite-egl xcomposite-glx', '', d)} \
${@bb.utils.contains('DISTRO_FEATURES', 'vulkan', 'wayland-vulkan-server-buffer', '', d)} \
"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 5f4bb9d2..1a74af97 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -12,6 +12,7 @@ LIC_FILES_CHKSUM = " \
"
DEPENDS += " \
+ dbus \
libpng-native \
nss-native \
nspr-native \
diff --git a/recipes-qt/qwt/qwt-qt5/0001-missing-qpainterpath.h-include-added-needed-with-Qt-.patch b/recipes-qt/qwt/qwt-qt5/0001-missing-qpainterpath.h-include-added-needed-with-Qt-.patch
deleted file mode 100644
index 5caf7930..00000000
--- a/recipes-qt/qwt/qwt-qt5/0001-missing-qpainterpath.h-include-added-needed-with-Qt-.patch
+++ /dev/null
@@ -1,131 +0,0 @@
-From c44af9a6f0eff02b439ef770755da551f281e9ad Mon Sep 17 00:00:00 2001
-From: rathmann <rathmann@29e17f8d-cf37-471e-a288-72cc03a76eda>
-Date: Sun, 29 Mar 2020 09:11:29 +0000
-Subject: [PATCH] missing qpainterpath.h include added needed with Qt 5.15
- Beta2
-
-Partial backport from
-https://sourceforge.net/p/qwt/code/3187/
-
----
-diff -uNr qwt-6.1.4.orig/src/qwt_compass_rose.cpp qwt-6.1.4/src/qwt_compass_rose.cpp
---- qwt-6.1.4.orig/src/qwt_compass_rose.cpp 2019-01-02 17:21:31.280460826 +0100
-+++ qwt-6.1.4/src/qwt_compass_rose.cpp 2020-04-14 13:33:27.214932546 +0200
-@@ -11,6 +11,7 @@
- #include "qwt_point_polar.h"
- #include "qwt_painter.h"
- #include <qpainter.h>
-+#include <qpainterpath.h>
-
- static QPointF qwtIntersection(
- QPointF p11, QPointF p12, QPointF p21, QPointF p22 )
-diff -uNr qwt-6.1.4.orig/src/qwt_dial_needle.cpp qwt-6.1.4/src/qwt_dial_needle.cpp
---- qwt-6.1.4.orig/src/qwt_dial_needle.cpp 2019-01-02 17:21:31.284460922 +0100
-+++ qwt-6.1.4/src/qwt_dial_needle.cpp 2020-04-14 13:33:37.006864250 +0200
-@@ -13,6 +13,7 @@
- #include "qwt_painter.h"
- #include <qapplication.h>
- #include <qpainter.h>
-+#include <qpainterpath.h>
-
- #if QT_VERSION < 0x040601
- #define qFastSin(x) qSin(x)
-diff -uNr qwt-6.1.4.orig/src/qwt_null_paintdevice.cpp qwt-6.1.4/src/qwt_null_paintdevice.cpp
---- qwt-6.1.4.orig/src/qwt_null_paintdevice.cpp 2019-01-02 17:21:31.296461212 +0100
-+++ qwt-6.1.4/src/qwt_null_paintdevice.cpp 2020-04-14 13:31:21.983807348 +0200
-@@ -9,6 +9,7 @@
-
- #include "qwt_null_paintdevice.h"
- #include <qpaintengine.h>
-+#include <qpainterpath.h>
- #include <qpixmap.h>
-
- class QwtNullPaintDevice::PrivateData
-diff -uNr qwt-6.1.4.orig/src/qwt_painter_command.h qwt-6.1.4/src/qwt_painter_command.h
---- qwt-6.1.4.orig/src/qwt_painter_command.h 2020-04-14 13:29:35.128556140 +0200
-+++ qwt-6.1.4/src/qwt_painter_command.h 2020-04-14 13:28:23.957056341 +0200
-@@ -15,6 +15,7 @@
- #include <qpixmap.h>
- #include <qimage.h>
- #include <qpolygon.h>
-+#include <qpainterpath.h>
-
- class QPainterPath;
-
-diff -uNr qwt-6.1.4.orig/src/qwt_painter.cpp qwt-6.1.4/src/qwt_painter.cpp
---- qwt-6.1.4.orig/src/qwt_painter.cpp 2019-01-02 17:21:31.452464985 +0100
-+++ qwt-6.1.4/src/qwt_painter.cpp 2020-04-14 13:30:22.356224890 +0200
-@@ -19,6 +19,7 @@
- #include <qpainter.h>
- #include <qpalette.h>
- #include <qpaintdevice.h>
-+#include <qpainterpath.h>
- #include <qpixmap.h>
- #include <qstyle.h>
- #include <qtextdocument.h>
-diff -uNr qwt-6.1.4.orig/src/qwt_plot_glcanvas.cpp qwt-6.1.4/src/qwt_plot_glcanvas.cpp
---- qwt-6.1.4.orig/src/qwt_plot_glcanvas.cpp 2019-01-02 17:21:31.300461309 +0100
-+++ qwt-6.1.4/src/qwt_plot_glcanvas.cpp 2020-04-14 13:33:14.947018129 +0200
-@@ -12,6 +12,7 @@
- #include "qwt_painter.h"
- #include <qevent.h>
- #include <qpainter.h>
-+#include <qpainterpath.h>
- #include <qdrawutil.h>
- #include <qstyle.h>
- #include <qstyleoption.h>
-diff -uNr qwt-6.1.4.orig/src/qwt_plot_panner.cpp qwt-6.1.4/src/qwt_plot_panner.cpp
---- qwt-6.1.4.orig/src/qwt_plot_panner.cpp 2019-01-02 17:21:31.468465371 +0100
-+++ qwt-6.1.4/src/qwt_plot_panner.cpp 2020-04-14 13:32:33.259309129 +0200
-@@ -14,6 +14,7 @@
- #include <qbitmap.h>
- #include <qstyle.h>
- #include <qstyleoption.h>
-+#include <qpainterpath.h>
-
- #if QT_VERSION >= 0x050000
- #if QT_VERSION < 0x050100
-diff -uNr qwt-6.1.4.orig/src/qwt_plot_renderer.cpp qwt-6.1.4/src/qwt_plot_renderer.cpp
---- qwt-6.1.4.orig/src/qwt_plot_renderer.cpp 2019-01-02 17:21:31.352462567 +0100
-+++ qwt-6.1.4/src/qwt_plot_renderer.cpp 2020-04-14 13:31:51.019604276 +0200
-@@ -20,6 +20,7 @@
- #include "qwt_math.h"
-
- #include <qpainter.h>
-+#include <qpainterpath.h>
- #include <qtransform.h>
- #include <qprinter.h>
- #include <qfiledialog.h>
-diff -uNr qwt-6.1.4.orig/src/qwt_widget_overlay.cpp qwt-6.1.4/src/qwt_widget_overlay.cpp
---- qwt-6.1.4.orig/src/qwt_widget_overlay.cpp 2019-01-02 17:21:31.388463437 +0100
-+++ qwt-6.1.4/src/qwt_widget_overlay.cpp 2020-04-14 13:31:07.091911561 +0200
-@@ -11,6 +11,7 @@
- #include "qwt_painter.h"
- #include <qpainter.h>
- #include <qpaintengine.h>
-+#include <qpainterpath.h>
- #include <qimage.h>
- #include <qevent.h>
-
-diff -uNr qwt-6.1.4.orig/examples/dials/attitude_indicator.cpp qwt-6.1.4/examples/dials/attitude_indicator.cpp
---- qwt-6.1.4.orig/examples/dials/attitude_indicator.cpp 2019-01-02 17:21:31.164458020 +0100
-+++ qwt-6.1.4/examples/dials/attitude_indicator.cpp 2020-04-14 13:44:46.354218570 +0200
-@@ -3,6 +3,7 @@
- #include <qwt_round_scale_draw.h>
- #include <qevent.h>
- #include <qpainter.h>
-+#include <qpainterpath.h>
- #include <qpolygon.h>
-
- AttitudeIndicatorNeedle::AttitudeIndicatorNeedle( const QColor &color )
-diff -uNr qwt-6.1.4.orig/src/qwt_plot_glcanvas.h qwt-6.1.4/src/qwt_plot_glcanvas.h
---- qwt-6.1.4.orig/src/qwt_plot_glcanvas.h 2020-04-14 13:44:26.642354964 +0200
-+++ qwt-6.1.4/src/qwt_plot_glcanvas.h 2020-04-14 13:42:38.555103164 +0200
-@@ -12,6 +12,7 @@
-
- #include "qwt_global.h"
- #include <qframe.h>
-+#include <qpainterpath.h>
- #include <qgl.h>
-
- class QwtPlot;
diff --git a/recipes-qt/qwt/qwt-qt5_6.1.4.bb b/recipes-qt/qwt/qwt-qt5_6.1.5.bb
index 18eebbf1..b483af59 100644
--- a/recipes-qt/qwt/qwt-qt5_6.1.4.bb
+++ b/recipes-qt/qwt/qwt-qt5_6.1.5.bb
@@ -16,10 +16,8 @@ inherit qmake5
SRC_URI = " \
${SOURCEFORGE_MIRROR}/qwt/qwt-${PV}.tar.bz2;name=qwt \
file://0001-Remove-rpath-from-binaries-they-point-to-buuild-area.patch \
- file://0001-missing-qpainterpath.h-include-added-needed-with-Qt-.patch \
"
-SRC_URI[qwt.md5sum] = "4fb1852f694420e3ab9c583526edecc5"
-SRC_URI[qwt.sha256sum] = "1529215329e51fc562e0009505a838f427919a18b362afff441f035b2d9b5bd9"
+SRC_URI[qwt.sha256sum] = "4076de63ec2b5e84379ddfebf27c7b29b8dc9074f3db7e2ca61d11a1d8adc041"
S = "${WORKDIR}/qwt-${PV}"