aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-05-24 13:57:28 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2022-05-25 09:19:43 +0200
commit918021201021ed95b73eec700a6384d2e93bf942 (patch)
tree08300c0bad80b8cc9690f2dde08224bc8a92c3d9
parentc432d1488baa5a45079bff65e14e6f6c20d86bed (diff)
qtwayland: Include locale.h for LC_CTYPE define
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwayland/0001-qwaylandinputcontext-Include-missing-header-locale.h.patch36
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb1
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwayland/0001-qwaylandinputcontext-Include-missing-header-locale.h.patch b/recipes-qt/qt5/qtwayland/0001-qwaylandinputcontext-Include-missing-header-locale.h.patch
new file mode 100644
index 00000000..9d11c423
--- /dev/null
+++ b/recipes-qt/qt5/qtwayland/0001-qwaylandinputcontext-Include-missing-header-locale.h.patch
@@ -0,0 +1,36 @@
+From 99f9a859b860b98880859bda847a341f460b9637 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 24 May 2022 13:54:17 -0700
+Subject: [PATCH] qwaylandinputcontext: Include missing header locale.h for
+ LC_CTYPE
+
+This issue is unraveled with musl, but is a general problem
+
+Fixes
+/mnt/b/yoe/master/build/tmp/work/cortexa72-yoe-linux-musl/qtwayland/5.15.4+gitAUTOINC+f1e6c8764d-r0/git/src/client/qwaylandinputcontext.cpp:584:36: error: use of undeclared identifier 'LC_CTYPE'
+ const char *locale = setlocale(LC_CTYPE, "");
+ ^
+/mnt/b/yoe/master/build/tmp/work/cortexa72-yoe-linux-musl/qtwayland/5.15.4+gitAUTOINC+f1e6c8764d-r0/git/src/client/qwaylandinputcontext.cpp:586:28: error: use of undeclared identifier 'LC_CTYPE'
+ locale = setlocale(LC_CTYPE, nullptr);
+ ^
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/client/qwaylandinputcontext.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/client/qwaylandinputcontext.cpp b/src/client/qwaylandinputcontext.cpp
+index ef5aa375..d8e55357 100644
+--- a/src/client/qwaylandinputcontext.cpp
++++ b/src/client/qwaylandinputcontext.cpp
+@@ -37,6 +37,7 @@
+ **
+ ****************************************************************************/
+
++#include <locale.h>
+
+ #include "qwaylandinputcontext_p.h"
+
+--
+2.36.1
+
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index fc8305a0..d2a44621 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -20,6 +20,7 @@ LIC_FILES_CHKSUM = " \
SRC_URI += "file://0001-tst_seatv4-Include-array.patch \
file://0001-linux-dmabuf-unstable-v1-Include-missing-array-heade.patch \
file://0001-Fix-vulkan-buffer-formats-for-GLES2.patch \
+ file://0001-qwaylandinputcontext-Include-missing-header-locale.h.patch \
"
PACKAGECONFIG ?= " \