aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2023-05-02 08:22:34 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2023-05-02 05:38:35 +0000
commitc1d26389b932757bbaba36830d9bc7a2716fc6f8 (patch)
tree7f2d2fece9bc0e100ae31a44c7753175c1692000
parent8bcd605984af55001ff94c9127590eec29547a91 (diff)
parentcf6ffcbad5275a3428f6046468a0c9d572e813d1 (diff)
Merge remote-tracking branch 'qt/upstream/master' into lts-5.15
The qtbase patch was removed in a change in previous upstream merge commit. This merge brings it back with necessary SRC_URI updates. changelog: cf6ffcba qt3d,qtquick3d: Update assimp SRC_URI 7b83cadb qtbase: Fix build on 32bit arches with 64bit time_t 77b6060c qtsmarthome: update SRC_URI Change-Id: I0d9d5d61655b7699e96b2a0fc7554be8a49da1c7
-rw-r--r--recipes-qt/examples/qtsmarthome_1.0.bb2
-rw-r--r--recipes-qt/qt5/qt3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase/0023-Remove-unsetting-_FILE_OFFSET_BITS.patch26
-rw-r--r--recipes-qt/qt5/qtbase_git.bb1
-rw-r--r--recipes-qt/qt5/qtquick3d_git.bb2
5 files changed, 30 insertions, 3 deletions
diff --git a/recipes-qt/examples/qtsmarthome_1.0.bb b/recipes-qt/examples/qtsmarthome_1.0.bb
index a6361aa5..2f95be4c 100644
--- a/recipes-qt/examples/qtsmarthome_1.0.bb
+++ b/recipes-qt/examples/qtsmarthome_1.0.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING.DOC;md5=ad1419ecc56e060eccf8184a87c4285f \
DEPENDS = "qtdeclarative qtgraphicaleffects"
-SRC_URI = "http://share.basyskom.com/demos/smarthome_src.tar.gz"
+SRC_URI = "https://artifacts.toradex.com/artifactory/tdxref-oe-prod-frankfurt/dunfell-5.x.y/release/4/sources/smarthome_src.tar.gz"
SRC_URI[md5sum] = "883b0376239baec20ebec072e938a995"
SRC_URI[sha256sum] = "fceaa813c33e462bad6c0383eaef81a6f6e586c15d1fa73898173b517fc1cda6"
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index e0144a5b..910f8896 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -19,7 +19,7 @@ SRC_URI += " \
# For assimp submodule
SRC_URI += " \
- git://github.com/assimp/assimp.git;name=assimp;branch=assimp_5.0_release;protocol=https;destsuffix=git/src/3rdparty/assimp/src \
+ git://code.qt.io/qt/qtquick3d-assimp.git;name=assimp;branch=qt6_assimp;protocol=https;destsuffix=git/src/3rdparty/assimp/src \
"
SRC_URI:append:riscv64 = " file://0001-renderers-opengl-Link-in-libatomic-on-riscv.patch"
diff --git a/recipes-qt/qt5/qtbase/0023-Remove-unsetting-_FILE_OFFSET_BITS.patch b/recipes-qt/qt5/qtbase/0023-Remove-unsetting-_FILE_OFFSET_BITS.patch
new file mode 100644
index 00000000..423db6e4
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0023-Remove-unsetting-_FILE_OFFSET_BITS.patch
@@ -0,0 +1,26 @@
+Remove unsetting _FILE_OFFSET_BITS
+This does not work when enabling 64bit time_t with glibc which is
+enabled with -D_TIME_BITS=64, since it also needs
+_FILE_OFFSET_BITS=64 and this does not work when its undefined
+explicitly
+
+Upstream-Status: Submitted [https://github.com/madler/zlib/pull/764]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+--- a/src/3rdparty/zlib/src/gzguts.h
++++ b/src/3rdparty/zlib/src/gzguts.h
+@@ -22,15 +22,6 @@
+ #define HAVE_HIDDEN
+ #endif
+
+-#ifdef _LARGEFILE64_SOURCE
+-# ifndef _LARGEFILE_SOURCE
+-# define _LARGEFILE_SOURCE 1
+-# endif
+-# ifdef _FILE_OFFSET_BITS
+-# undef _FILE_OFFSET_BITS
+-# endif
+-#endif
+-
+ #ifdef HAVE_HIDDEN
+ # define ZLIB_INTERNAL __attribute__((visibility ("hidden")))
+ #else
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 703c28d6..55e58d4a 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -36,6 +36,7 @@ SRC_URI += "\
file://0019-tst_QPluginLoader-Simplify-creating-a-fake-pointer-i.patch \
file://0021-rcc-Just-dcument-file-name-without-full-path-to-redu.patch \
file://0022-testlib-don-t-track-the-build-or-source-directories.patch \
+ file://0023-Remove-unsetting-_FILE_OFFSET_BITS.patch \
"
# Disable LTO for now, QT5 patches are being worked upstream, perhaps revisit with
diff --git a/recipes-qt/qt5/qtquick3d_git.bb b/recipes-qt/qt5/qtquick3d_git.bb
index 25e1a0bd..8ff0a7f6 100644
--- a/recipes-qt/qt5/qtquick3d_git.bb
+++ b/recipes-qt/qt5/qtquick3d_git.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtquickcontrols2"
SRC_URI += " \
- git://github.com/assimp/assimp.git;name=assimp;branch=assimp_5.0_release;protocol=https;destsuffix=git/src/3rdparty/assimp/src \
+ git://code.qt.io/qt/qtquick3d-assimp.git;name=assimp;branch=qt6_assimp;protocol=https;destsuffix=git/src/3rdparty/assimp/src \
"
PACKAGECONFIG ??= ""