aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-03-13 13:04:44 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2021-04-10 01:39:16 +0200
commitd404dc581116014b814f05ed780bc9691006f12c (patch)
tree7b22abf0be3ff541b783288bfed62756d66ec07c
parentfd463388e1ecbe7f8c0749f1805a48531e48ed75 (diff)
ogl-runtime: Fix build on ppc64
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-qt/qt5/ogl-runtime/0001-Qt3D-Add-support-to-fix-build-on-ppc64.patch59
-rw-r--r--recipes-qt/qt5/ogl-runtime_git.bb1
2 files changed, 60 insertions, 0 deletions
diff --git a/recipes-qt/qt5/ogl-runtime/0001-Qt3D-Add-support-to-fix-build-on-ppc64.patch b/recipes-qt/qt5/ogl-runtime/0001-Qt3D-Add-support-to-fix-build-on-ppc64.patch
new file mode 100644
index 00000000..494d598a
--- /dev/null
+++ b/recipes-qt/qt5/ogl-runtime/0001-Qt3D-Add-support-to-fix-build-on-ppc64.patch
@@ -0,0 +1,59 @@
+From c70df6bf52cdcdceb73ed965a28642177df32943 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 13 Mar 2021 12:58:32 -0800
+Subject: [PATCH] Qt3D: Add support to fix build on ppc64
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/foundation/Qt3DSPreprocessor.h | 2 +-
+ src/foundation/Qt3DSSystem.cpp | 8 +++++++-
+ 2 files changed, 8 insertions(+), 2 deletions(-)
+
+diff --git a/src/foundation/Qt3DSPreprocessor.h b/src/foundation/Qt3DSPreprocessor.h
+index 066a38e..98ff573 100644
+--- a/src/foundation/Qt3DSPreprocessor.h
++++ b/src/foundation/Qt3DSPreprocessor.h
+@@ -114,7 +114,7 @@ Platform define
+ #define QT3DS_X64
+ #elif defined(__ppc__)
+ #define QT3DS_PPC
+-#elif defined(__ppc64__)
++#elif defined(__powerpc64__)
+ #define QT3DS_PPC
+ #define QT3DS_PPC64
+ //# elif defined(__aarch64__)
+diff --git a/src/foundation/Qt3DSSystem.cpp b/src/foundation/Qt3DSSystem.cpp
+index e87a25e..81f563f 100644
+--- a/src/foundation/Qt3DSSystem.cpp
++++ b/src/foundation/Qt3DSSystem.cpp
+@@ -62,6 +62,10 @@ const char *qt3ds::foundation::System::g_FloatingPointModel = "";
+ const char *qt3ds::foundation::System::g_Processor = "x64";
+ const char *qt3ds::foundation::System::g_BitWidth = "64";
+ const char *qt3ds::foundation::System::g_FloatingPointModel = "";
++#elif defined(QT3DS_PPC64)
++const char *qt3ds::foundation::System::g_Processor = "ppc64";
++const char *qt3ds::foundation::System::g_BitWidth = "64";
++const char *qt3ds::foundation::System::g_FloatingPointModel = "";
+ #elif defined(QT3DS_ARM)
+ #if defined(__aarch64__) || defined(__ARM64__)
+ const char *qt3ds::foundation::System::g_Processor = "arm";
+@@ -97,6 +101,8 @@ const char *qt3ds::foundation::System::g_GPUType = "gles3";
+ const char *qt3ds::foundation::System::g_GPUType = "";
+ #elif defined(QT3DS_X64)
+ const char *qt3ds::foundation::System::g_GPUType = "";
++#elif defined(QT3DS_PPC64)
++const char *qt3ds::foundation::System::g_GPUType = "";
+ #else
+ #error "Must define a processor type (QT3DS_ARM or QT3DS_X86)"
+ #endif
+@@ -136,4 +142,4 @@ const char *System::getPlatformGLStr()
+ strcpy(text, str.c_str());
+ }
+ return text;
+-}
+\ No newline at end of file
++}
+--
+2.30.2
+
diff --git a/recipes-qt/qt5/ogl-runtime_git.bb b/recipes-qt/qt5/ogl-runtime_git.bb
index 1669382e..fd362864 100644
--- a/recipes-qt/qt5/ogl-runtime_git.bb
+++ b/recipes-qt/qt5/ogl-runtime_git.bb
@@ -20,6 +20,7 @@ SRC_URI += " \
${QT_GIT}/qt3dstudio-eastl.git;name=EASTL;branch=${QT_MODULE_BRANCH_EASTL};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/EASTL \
file://0001-Fix-examples-build-error.patch \
file://0001-Qt3DSSimpleTypes-make-QT3DSU64-as-unsigned-long-on-l.patch \
+ file://0001-Qt3D-Add-support-to-fix-build-on-ppc64.patch \
"
SRCREV_ogl-runtime = "b53aeb784f950d7b2a5ebe38ea37c5bb6f456c9c"