aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2022-07-06 13:35:05 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2022-07-06 13:35:06 +0200
commitd466c12ed432f6d811dac6a80528a637ef5c658d (patch)
treeeb733eb0f1a23f248e4f2659c4c9b5cb060c8769
parent9102fd45055df452b60c53b67d118d9a4153e4cf (diff)
libconnman-qt5: pass VERSION in EXTRA_QMAKEVARS_PRE
* the version in .pro and .spec doesn't match with the git tag: https://github.com/sailfishos/libconnman-qt/pull/9#issuecomment-1175243813 sailfish passes the version based on git tag: https://github.com/sailfishos/libconnman-qt/pull/9#issuecomment-1175827075 lets do the same Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-connectivity/libconnman-qt/libconnman-qt5_git.bb9
1 files changed, 5 insertions, 4 deletions
diff --git a/recipes-connectivity/libconnman-qt/libconnman-qt5_git.bb b/recipes-connectivity/libconnman-qt/libconnman-qt5_git.bb
index 7230d85a..a3d7f279 100644
--- a/recipes-connectivity/libconnman-qt/libconnman-qt5_git.bb
+++ b/recipes-connectivity/libconnman-qt/libconnman-qt5_git.bb
@@ -5,17 +5,18 @@ HOMEPAGE = "https://github.com/sailfishos/libconnman-qt"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://libconnman-qt/clockmodel.h;endline=8;md5=ea9f724050803f15d2d900ce3c5dac88"
DEPENDS += "qtbase qtdeclarative"
-PV = "1.2.46+git${SRCPV}"
+
+VERSION = "1.2.46"
+PV = "${VERSION}+git${SRCPV}"
SRCREV = "6786936cba9048ee943c0cd5d051c0b8fc70896f"
-SRC_URI = "git://github.com/sailfishos/libconnman-qt.git;protocol=https;branch=master \
-"
+SRC_URI = "git://github.com/sailfishos/libconnman-qt.git;protocol=https;branch=master"
S = "${WORKDIR}/git"
inherit pkgconfig
-EXTRA_QMAKEVARS_PRE = "CONFIG+=no-module-prefix"
+EXTRA_QMAKEVARS_PRE = "CONFIG+=no-module-prefix VERSION=${VERSION}"
RDEPENDS:${PN} += "connman"