aboutsummaryrefslogtreecommitdiffstats
path: root/classes/qmake5_base.bbclass
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-22 09:14:48 +0200
committerSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-22 12:47:16 +0200
commitddbe177dae46353f08f7326a11d3b3fd5a1f8435 (patch)
tree89ceddbc93150e1d6fe7dccb15fea1ec59b3c839 /classes/qmake5_base.bbclass
parent72ac998cef3306e6e4d2f3760af1c21cedfc330f (diff)
parent52b0e06d02e7f43cf54f447e0487c40c2c1fed00 (diff)
Merge remote-tracking branch 'meta-qt5/master' into master-mingw
* meta-qt5/master: qttransltations: Add PACKAGE for qtwebengine and qtquickcontrols2 qtwebengine: Hide textrel QA warning until there is proper fix for it qtwebengine: Fix QA warning qtwebkit: Fix QA Warning examples: fix few thousands host-user-contaminated QA warnings qtbase: Don't install libQt* files twice qtbase: Resolve QA warning about /bin/bash dependency qtbase: Fix WORKDIR references in pkg-config files qt5: upgrade to latest revisions in 5.6 branch (5.6 RC) qmake5_base: delete *.la files qt5: add Qml support to lupdate qt3d: support qgltf in native and nativesdk builds qt5: use common PACKAGECONFIG to build examples qt5-git.inc: Ensure we export the SRCREV as the module name qtbase: Fix installation of fonts and libraries Conflicts: classes/qmake5_base.bbclass recipes-qt/qt5/nativesdk-qtbase_git.bb recipes-qt/qt5/qt3d_git.bb recipes-qt/qt5/qt5-git.inc recipes-qt/qt5/qtbase-native_git.bb recipes-qt/qt5/qtbase/0002-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch recipes-qt/qt5/qtbase/0003-Add-external-hostbindir-option.patch recipes-qt/qt5/qtbase/0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch recipes-qt/qt5/qtbase/0010-Add-external-hostbindir-option-for-native-sdk.patch recipes-qt/qt5/qtbase_git.bb recipes-qt/qt5/qtcanvas3d_git.bb recipes-qt/qt5/qtconnectivity_git.bb recipes-qt/qt5/qtdeclarative_git.bb recipes-qt/qt5/qtenginio_git.bb recipes-qt/qt5/qtgraphicaleffects_git.bb recipes-qt/qt5/qtimageformats_git.bb recipes-qt/qt5/qtlocation_git.bb recipes-qt/qt5/qtmultimedia_git.bb recipes-qt/qt5/qtquick1_git.bb recipes-qt/qt5/qtquickcontrols_git.bb recipes-qt/qt5/qtscript_git.bb recipes-qt/qt5/qtsensors_git.bb recipes-qt/qt5/qtserialport_git.bb recipes-qt/qt5/qtsvg_git.bb recipes-qt/qt5/qtsystems_git.bb recipes-qt/qt5/qttools_git.bb recipes-qt/qt5/qttranslations_git.bb recipes-qt/qt5/qtwayland-native_git.bb recipes-qt/qt5/qtwayland_git.bb recipes-qt/qt5/qtwebchannel_git.bb recipes-qt/qt5/qtwebengine_git.bb recipes-qt/qt5/qtwebkit_git.bb recipes-qt/qt5/qtxmlpatterns_git.bb Change-Id: I0a7763f973c32df796cb3e37c753ddbfe43c4521
Diffstat (limited to 'classes/qmake5_base.bbclass')
-rw-r--r--classes/qmake5_base.bbclass8
1 files changed, 5 insertions, 3 deletions
diff --git a/classes/qmake5_base.bbclass b/classes/qmake5_base.bbclass
index 13bb0abc..cbee35f3 100644
--- a/classes/qmake5_base.bbclass
+++ b/classes/qmake5_base.bbclass
@@ -173,6 +173,7 @@ qmake5_base_do_configure () {
qmake5_base_native_do_install() {
oe_runmake install INSTALL_ROOT=${D}
+ find "${D}" -ignore_readdir_race -name "*.la" -delete
}
qmake5_base_fix_install() {
@@ -192,11 +193,12 @@ qmake5_base_fix_install() {
qmake5_base_do_install() {
# Fix install paths for all
- find -name "Makefile*" | xargs -r sed -i "s,(INSTALL_ROOT)${STAGING_DIR_TARGET},(INSTALL_ROOT),g"
- find -name "Makefile*" | xargs -r sed -i "s,(INSTALL_ROOT)${STAGING_DIR_HOST},(INSTALL_ROOT),g"
- find -name "Makefile*" | xargs -r sed -i "s,(INSTALL_ROOT)${STAGING_DIR_NATIVE},(INSTALL_ROOT),g"
+ find . -name "Makefile*" | xargs -r sed -i "s,(INSTALL_ROOT)${STAGING_DIR_TARGET},(INSTALL_ROOT),g"
+ find . -name "Makefile*" | xargs -r sed -i "s,(INSTALL_ROOT)${STAGING_DIR_HOST},(INSTALL_ROOT),g"
+ find . -name "Makefile*" | xargs -r sed -i "s,(INSTALL_ROOT)${STAGING_DIR_NATIVE},(INSTALL_ROOT),g"
oe_runmake install INSTALL_ROOT=${D}
+ find "${D}" -ignore_readdir_race -name "*.la" -delete
# everything except HostData and HostBinaries is prefixed with sysroot value,
# but we cannot remove sysroot override, because that's useful for pkg-config etc