aboutsummaryrefslogtreecommitdiffstats
path: root/classes
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2017-11-02 11:13:33 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2017-11-02 11:15:16 +0200
commitec328d9677f39c223a697bbe1cbf8952631e9817 (patch)
tree02053800a6baa93715ddffaae4fcfa0b03a3d23e /classes
parente0db5666f9c04c92683514ca220b0aafd0a49df2 (diff)
parentd87335a50a9dd35d890786edbd79b8953fdaa11a (diff)
Merge remote-tracking branch 'qtyocto/upstream/master' into 5.9
* qtyocto/upstream/master: qt5-ptest.inc: fix qtxmlpatterns:do_install_ptest out-of-order call meta-qt5: Update to 5.9.2 release qt5: add missing commercial license qtxmlpatterns: Add HOMEPAGE info into recipe file. qttools: Add HOMEPAGE info into recipe file. qtsvg: Add HOMEPAGE info into recipe file. qtscript: Add HOMEPAGE info into recipe file. qtquick1: Add HOMEPAGE info into recipe file. qtdeclarative: Add HOMEPAGE info into recipe file. meta: drop a useless file qtbase-native: Force use of built-in pcre qtbase-native: set path to mkspec for cmake properly again qtbase: Fix build with musl/clang qtbase: Add OE clang specific mkspecs Conflicts: recipes-qt/qt5/qtcharts_git.bb recipes-qt/qt5/qtwebengine_git.bb Change-Id: I78ce0587cf7468bfdc22156ee8bbd24872f79c6a
Diffstat (limited to 'classes')
-rw-r--r--classes/qmake5_base.bbclass7
1 files changed, 5 insertions, 2 deletions
diff --git a/classes/qmake5_base.bbclass b/classes/qmake5_base.bbclass
index 538c9489..3bc1279d 100644
--- a/classes/qmake5_base.bbclass
+++ b/classes/qmake5_base.bbclass
@@ -1,6 +1,9 @@
# hardcode linux, because that's what 0001-Add-linux-oe-g-platform.patch adds
-OE_QMAKE_PLATFORM_NATIVE = "linux-oe-g++"
-OE_QMAKE_PLATFORM = "linux-oe-g++"
+XPLATFORM_toolchain-clang = "linux-oe-clang"
+XPLATFORM ?= "linux-oe-g++"
+
+OE_QMAKE_PLATFORM_NATIVE = "${XPLATFORM}"
+OE_QMAKE_PLATFORM = "${XPLATFORM}"
# Add -d to show debug output from every qmake call, but it prints *a lot*, better to add it only to debugged recipe
OE_QMAKE_DEBUG_OUTPUT ?= ""