aboutsummaryrefslogtreecommitdiffstats
path: root/coin
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2020-03-06 12:32:13 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2020-03-10 09:03:25 +0200
commit5114e3057ceb4afc7f2ae9f71bb351f9e5c7f553 (patch)
tree970f133c757794bcdc024acff5e053ca621ad47d /coin
parentc29bdf41c4494e278a17a233048205bf212e040f (diff)
parentde2ecaa13fde8f30b1a6558bbbbdfecfd3cd4bd8 (diff)
Merge remote-tracking branch 'qt/5.14' into 5.15
* qt/5.14: de2ecaa1 coin: update module_config.yaml with meta-python2 support f9a58d62 Merge remote-tracking branch 'qt/upstream/master' into 5.14 2da972e5 qt5: update submodules 9be6548e qt5: update submodules b5e4f925 qtquicktimeline: add recipe abb42351 (qt/upstream/master) qtwebview: Skip if meta-python is not present caf09cd5 Add PyQtChart. f18d5948 qtbase: fix build with platform where FE macro are not defined c8cd55b0 qtwebkit: build with python3 0bbd0ebe qtwebengine: Link libatomic on x86/32bit 23914740 Revert "qtwebkit: remove" 8cadcbcb qt5: upgrade to 5.14.1 f13a3cec packagegroup-qt5-toolchain-target: Use TUNE_PKGARCH instead of MACHINE_ARCH a35403dc qtwebkit: remove a797f85c python-pyqt5, qtwebengine, qtwebkit, qt-kiosk-browser: skip without meta-python2 b1f4f1fd Revert "recipes: Use python3 during build" 47fb26de recipes: Use python3 during build 4060f68d qt-kiosk-browser: Only support arm/x86 fd376e15 qtwebengine: Fix missing headers found in build with clang 7f324f11 gstreamer1.0-plugins-good: Adjust bbappend for meson migration in core 1365691f qttools: remove ptest installation 254576f9 qt-kiosk-browser: Add recipe 47399df9 nativesdk-packagegroup: fix cmake builds using sdk Conflicts: recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb recipes-qt/qt5/nativesdk-qtbase_git.bb recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch recipes-qt/qt5/qt3d_git.bb recipes-qt/qt5/qtbase-native_git.bb recipes-qt/qt5/qtbase_git.bb recipes-qt/qt5/qtcharts_git.bb recipes-qt/qt5/qtcoap_git.bb recipes-qt/qt5/qtconnectivity_git.bb recipes-qt/qt5/qtdeclarative_git.bb recipes-qt/qt5/qtimageformats_git.bb recipes-qt/qt5/qtknx_git.bb recipes-qt/qt5/qtlocation_git.bb recipes-qt/qt5/qtmultimedia_git.bb recipes-qt/qt5/qtquick3d_git.bb recipes-qt/qt5/qtquickcontrols2_git.bb recipes-qt/qt5/qtremoteobjects_git.bb recipes-qt/qt5/qtscript_git.bb recipes-qt/qt5/qtserialbus_git.bb recipes-qt/qt5/qtsvg_git.bb recipes-qt/qt5/qttools_git.bb recipes-qt/qt5/qtwebengine_git.bb recipes-qt/qt5/qtwebsockets_git.bb recipes-qt/qt5/qtwebview_git.bb Change-Id: I41b3b999dc1278342e33dda3b66af1990e8da090
Diffstat (limited to 'coin')
-rw-r--r--coin/module_config.yaml6
1 files changed, 6 insertions, 0 deletions
diff --git a/coin/module_config.yaml b/coin/module_config.yaml
index 6ce600eb..51579be0 100644
--- a/coin/module_config.yaml
+++ b/coin/module_config.yaml
@@ -22,6 +22,9 @@ environment: &environment
variableName: OE_SHA1
variableValue: b2baaae2711d098c06423858662e29a8375fe6b8
- type: EnvironmentVariable
+ variableName: PYTHON2_SHA1
+ variableValue: 8fc9be701d430388b4c5234c97e623debd26a1df
+ - type: EnvironmentVariable
variableName: MACHINE
variableValue: qemuarm64
enable_if:
@@ -144,6 +147,8 @@ build_instructions:
(cd poky; git checkout ${POKY_SHA1})
git clone git://github.com/openembedded/meta-openembedded --reference /mnt/yocto-cache/mirror/meta-openembedded.git
(cd meta-openembedded; git checkout ${OE_SHA1})
+ git clone git://git.openembedded.org/meta-python2 --reference /mnt/yocto-cache/mirror/meta-python2.git
+ (cd meta-python2; git checkout ${PYTHON2_SHA1})
source ./poky/oe-init-build-env
export BB_ENV_EXTRAWHITE="$BB_ENV_EXTRAWHITE SSTATE_DIR DL_DIR"
@@ -151,6 +156,7 @@ build_instructions:
export BB_GENERATE_MIRROR_TARBALLS=1
export SSTATE_DIR=/mnt/yocto-cache/sstate-caches/$(sed -n -e "s/DISTRO_CODENAME.*\"\(.*\)\"/\1/p" ../poky/meta-*/conf/distro/poky.conf)
bitbake-layers add-layer ../meta-openembedded/meta-oe
+ bitbake-layers add-layer ../meta-python2
bitbake-layers add-layer ${SOURCE_DIR}
echo 'require ../world_fixes.inc' >> conf/local.conf