aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-10-29 12:16:06 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2013-11-03 22:39:09 +0100
commitfaa07fc3a61f16a5de5b548f74c155a81dd86190 (patch)
treec36de8675bc1b0affdc42c42797a501d7cadbd51 /recipes-devtools
parentf11778340c574de8cf46b9980a4f8c5b1fa50410 (diff)
cmake: Rename and update .bbappend to match new version from oe-core
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/cmake/cmake_2.8.11.2.bbappend7
-rw-r--r--recipes-devtools/cmake/cmake_2.8.12.bbappend20
2 files changed, 20 insertions, 7 deletions
diff --git a/recipes-devtools/cmake/cmake_2.8.11.2.bbappend b/recipes-devtools/cmake/cmake_2.8.11.2.bbappend
deleted file mode 100644
index 0ad2d2fb..00000000
--- a/recipes-devtools/cmake/cmake_2.8.11.2.bbappend
+++ /dev/null
@@ -1,7 +0,0 @@
-# Ugly hack to work around undefined OE_QMAKE_PATH_EXTERNAL_HOST_BINS variable
-# and possibly missing qmake binary (qtbase-native can be removed from sysroot
-# e.g. in order to upgrade it, even when there is target qtbase)
-
-do_configure_prepend() {
- sed -i 's/^find_package(Qt5Core QUIET)$/#find_package(Qt5Core QUIET)/g' ${S}/Tests/RunCMake/CMakeLists.txt
-}
diff --git a/recipes-devtools/cmake/cmake_2.8.12.bbappend b/recipes-devtools/cmake/cmake_2.8.12.bbappend
new file mode 100644
index 00000000..ebacf720
--- /dev/null
+++ b/recipes-devtools/cmake/cmake_2.8.12.bbappend
@@ -0,0 +1,20 @@
+# Ugly hack to work around undefined OE_QMAKE_PATH_EXTERNAL_HOST_BINS variable
+# and possibly missing qmake binary (qtbase-native can be removed from sysroot
+# e.g. in order to upgrade it, even when there is target qtbase)
+
+#| -- Performing Test run_pic_test - Success
+#| CMake Error at tmp-eglibc/sysroots/qemuarm/usr/lib/cmake/Qt5Core/Qt5CoreConfig.cmake:27 (message):
+#| The imported target "Qt5::Core" references the file
+#|
+#| "/qmake"
+#|
+#| but this file does not exist. Possible reasons include:
+
+do_configure_prepend() {
+ sed -i 's/^find_package(Qt5Core QUIET)$/#find_package(Qt5Core QUIET)/g' ${S}/Tests/RunCMake/CMakeLists.txt
+ sed -i 's/^find_package(Qt5Core REQUIRED)/#find_package(Qt5Core REQUIRED)/g' ${S}/Tests/RunCMake/IncompatibleQt/IncompatibleQt.cmake
+ sed -i 's/^ find_package(Qt5Widgets REQUIRED)/# find_package(Qt5Widgets REQUIRED)/g' ${S}/Tests/QtAutomoc/CMakeLists.txt
+ sed -i 's/^find_package(Qt5Core REQUIRED)/#find_package(Qt5Core REQUIRED)/g' ${S}/Tests/Qt4And5Automoc/CMakeLists.txt
+ sed -i 's/^ find_package(Qt5Widgets QUIET NO_MODULE)/# find_package(Qt5Widgets QUIET NO_MODULE)/g' ${S}/Tests/CMakeLists.txt
+ sed -i 's/^find_package(Qt5Widgets QUIET)/#find_package(Qt5Widgets QUIET)/g' ${S}/Source/QtDialog/CMakeLists.txt
+}