aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-09-05 15:16:37 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-09-13 14:57:24 +0200
commit671313d0b5e09e0b49a90ed944cd33fb3d6457b0 (patch)
treecc2c0fe7ae1bc9970751c03db729091c50bddad8 /recipes-devtools
parent2340ce8714f2a50e459c80a6aab51dad37378303 (diff)
cmake: disable test for Qt5Core
| CMake Error at tmp-eglibc/sysroots/qemuarm/usr/lib/cmake/Qt5Core/Qt5CoreConfig.cmake:27 (message): | The imported target "Qt5::Core" references the file | | "/qmake" | | but this file does not exist. Possible reasons include: | | * The file was deleted, renamed, or moved to another location. | | * An install or uninstall procedure did not complete successfully. | | * The installation package was faulty and contained | | "tmp-eglibc/sysroots/qemuarm/usr/lib/cmake/Qt5Core/Qt5CoreConfigExtras.cmake" | | but not all the files it references. | | Call Stack (most recent call first): | tmp-eglibc/sysroots/qemuarm/usr/lib/cmake/Qt5Core/Qt5CoreConfigExtras.cmake:6 (_qt5_Core_check_file_exists) | tmp-eglibc/sysroots/qemuarm/usr/lib/cmake/Qt5Core/Qt5CoreConfig.cmake:130 (include) | Tests/RunCMake/CMakeLists.txt:80 (find_package) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/cmake/cmake_2.8.11.2.bbappend7
1 files changed, 7 insertions, 0 deletions
diff --git a/recipes-devtools/cmake/cmake_2.8.11.2.bbappend b/recipes-devtools/cmake/cmake_2.8.11.2.bbappend
new file mode 100644
index 00000000..0ad2d2fb
--- /dev/null
+++ b/recipes-devtools/cmake/cmake_2.8.11.2.bbappend
@@ -0,0 +1,7 @@
+# Ugly hack to work around undefined OE_QMAKE_PATH_EXTERNAL_HOST_BINS variable
+# and possibly missing qmake binary (qtbase-native can be removed from sysroot
+# e.g. in order to upgrade it, even when there is target qtbase)
+
+do_configure_prepend() {
+ sed -i 's/^find_package(Qt5Core QUIET)$/#find_package(Qt5Core QUIET)/g' ${S}/Tests/RunCMake/CMakeLists.txt
+}