aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorCarlos Rafael Giani <dv@pseudoterminal.org>2017-08-11 23:42:19 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-13 13:32:36 +0200
commit1619723dfc0cdc831b71bf7ab09c4227ea544255 (patch)
tree5c54f20bffdc9b1bb26f5409a02a04634ab3f5de /recipes-multimedia
parentc74e5b8a816e145381e0a214df0f86400bbb9c7d (diff)
gstreamer1.0-plugins-bad: add qt5 packageconfig
This adds a new command line switch to the configure script to make sure the right paths to moc, uic, rcc are used. It also makes sure OpenGL is enabled if the qt5 packageconfig is in use. Note that the moc/uic/rcc path configure switches were introduced in GStreamer 1.12.2, so this version is a requirement. Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend15
1 files changed, 15 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
new file mode 100644
index 00000000..b1866778
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
@@ -0,0 +1,15 @@
+inherit qmake5_paths
+
+PACKAGECONFIG[qt5] = '--enable-qt \
+ --with-moc="${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/moc" \
+ --with-uic="${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/uic" \
+ --with-rcc="${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/rcc" \
+ ,--disable-qt,qtbase qtdeclarative qtbase-native'
+
+# The GStreamer Qt5 plugin needs desktop OpenGL or OpenGL ES to work, so make sure it is enabled
+python() {
+ cur_packageconfig = d.getVar('PACKAGECONFIG').split()
+ if 'qt5' in cur_packageconfig and not (('opengl' in cur_packageconfig) or ('gles2' in cur_packageconfig)):
+ gl_packageconfig = d.getVar('PACKAGECONFIG_GL')
+ d.appendVar('PACKAGECONFIG', ' ' + gl_packageconfig)
+}