aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-multimedia
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-11-10 09:11:19 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-12-20 08:21:07 +0000
commitf3e0cef1ed853c5030b07c0247395ecf67eeeff7 (patch)
treeb7e3aee68d77213d2710bc59972b1a24df370a67 /recipes-multimedia
parent507e54ddacab0897fff93a1cd86e134af391f8b9 (diff)
gstreamer1.0-plugins-bad: add expansion parameter
The expansion is now again optional, but for brief time it was required. Add the default value (True) so that the layer can be used also with older oe-core versions. Signed-off-by: Samuli Piippo <samuli.piippo@qt.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-multimedia')
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
index b1866778..b42338ab 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
@@ -8,8 +8,8 @@ PACKAGECONFIG[qt5] = '--enable-qt \
# The GStreamer Qt5 plugin needs desktop OpenGL or OpenGL ES to work, so make sure it is enabled
python() {
- cur_packageconfig = d.getVar('PACKAGECONFIG').split()
+ cur_packageconfig = d.getVar('PACKAGECONFIG',True).split()
if 'qt5' in cur_packageconfig and not (('opengl' in cur_packageconfig) or ('gles2' in cur_packageconfig)):
- gl_packageconfig = d.getVar('PACKAGECONFIG_GL')
+ gl_packageconfig = d.getVar('PACKAGECONFIG_GL',True)
d.appendVar('PACKAGECONFIG', ' ' + gl_packageconfig)
}