aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-python
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-11-09 11:55:19 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2019-11-20 13:51:18 +0100
commit02715fff5ee26e8baa03420083f6aa60b45c13ea (patch)
treef435c999d539acb009241bad96162fc1e7e41ff9 /recipes-python
parent432ad2aa6c3a13253fefc909faba368851d21fb1 (diff)
pyqt5: Upgrade to 5.13.2
Blacklist py2 version, it does not build and py2 is on its way out in Jan 2020 anyway Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes-python')
-rw-r--r--recipes-python/pyqt5/python-pyqt5.inc9
-rw-r--r--recipes-python/pyqt5/python-pyqt5_5.13.2.bb (renamed from recipes-python/pyqt5/python-pyqt5_5.12.1.bb)1
-rw-r--r--recipes-python/pyqt5/python3-pyqt5_5.13.2.bb (renamed from recipes-python/pyqt5/python3-pyqt5_5.12.1.bb)0
3 files changed, 6 insertions, 4 deletions
diff --git a/recipes-python/pyqt5/python-pyqt5.inc b/recipes-python/pyqt5/python-pyqt5.inc
index bbeb75af..b830c9a9 100644
--- a/recipes-python/pyqt5/python-pyqt5.inc
+++ b/recipes-python/pyqt5/python-pyqt5.inc
@@ -7,11 +7,12 @@ LIC_FILES_CHKSUM = "\
file://LICENSE;md5=d32239bcb673463ab874e80d47fae504 \
"
SRC_URI = "\
- https://www.riverbankcomputing.com/static/Downloads/PyQt5/${PV}/PyQt5_gpl-${PV}.tar.gz \
+ https://www.riverbankcomputing.com/static/Downloads/PyQt5/${PV}/PyQt5-${PV}.tar.gz \
"
-SRC_URI[md5sum] = "67508b652098d2e05c4c2b5baeb170cc"
-SRC_URI[sha256sum] = "3718ce847d824090fd5f95ff3f13847ee75c2507368d4cbaeb48338f506e59bf"
-S = "${WORKDIR}/PyQt5_gpl-${PV}"
+SRC_URI[md5sum] = "c1023cb9c3d29a89fc109b163a0175c0"
+SRC_URI[sha256sum] = "adc17c077bf233987b8e43ada87d1e0deca9bd71a13e5fd5fc377482ed69c827"
+
+S = "${WORKDIR}/PyQt5-${PV}"
inherit qmake5
DEPENDS = "qtbase qtdeclarative qtquickcontrols2"
diff --git a/recipes-python/pyqt5/python-pyqt5_5.12.1.bb b/recipes-python/pyqt5/python-pyqt5_5.13.2.bb
index 6b1b5701..b8b1d086 100644
--- a/recipes-python/pyqt5/python-pyqt5_5.12.1.bb
+++ b/recipes-python/pyqt5/python-pyqt5_5.13.2.bb
@@ -6,3 +6,4 @@ DEPENDS += "sip sip-native python"
RDEPENDS_${PN} += "python-core python-sip"
+PNBLACKLIST[python-pyqt5] = "Sip fails in do_configure sip: QOpenGLFramebufferObject is undefined"
diff --git a/recipes-python/pyqt5/python3-pyqt5_5.12.1.bb b/recipes-python/pyqt5/python3-pyqt5_5.13.2.bb
index 200a8154..200a8154 100644
--- a/recipes-python/pyqt5/python3-pyqt5_5.12.1.bb
+++ b/recipes-python/pyqt5/python3-pyqt5_5.13.2.bb