aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-python
diff options
context:
space:
mode:
authorDiego Rondini <diego.rondini@kynetics.com>2017-07-20 14:07:01 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-21 11:00:47 +0200
commit3c4f2cba1ff6925da20bcf4469526aceee80ad90 (patch)
tree1cc1e71fdf4581e3dd07d739f010671ae4c947f2 /recipes-python
parent045e39b7d487733b03dc54590702e4c9373ed0f1 (diff)
python-pyqt5: include QtWidgets module
Signed-off-by: Diego Rondini <diego.rondini@kynetics.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-python')
-rw-r--r--recipes-python/pyqt5/files/0001-qtabbar.sip-fix-build-with-accessibility-disabled.patch35
-rw-r--r--recipes-python/pyqt5/python-pyqt5_5.8.2.bb5
2 files changed, 38 insertions, 2 deletions
diff --git a/recipes-python/pyqt5/files/0001-qtabbar.sip-fix-build-with-accessibility-disabled.patch b/recipes-python/pyqt5/files/0001-qtabbar.sip-fix-build-with-accessibility-disabled.patch
new file mode 100644
index 00000000..7e1c7bf4
--- /dev/null
+++ b/recipes-python/pyqt5/files/0001-qtabbar.sip-fix-build-with-accessibility-disabled.patch
@@ -0,0 +1,35 @@
+From 8a2f852417414e19d060da66cd7c5cba76e43c7d Mon Sep 17 00:00:00 2001
+From: Diego Rondini <diego.rondini@kynetics.com>
+Date: Wed, 19 Jul 2017 14:17:51 +0200
+Subject: [PATCH] qtabbar.sip: fix build with accessibility disabled
+
+Upstream-Status: Submitted
+
+Signed-off-by: Diego Rondini <diego.rondini@kynetics.com>
+---
+ sip/QtWidgets/qtabbar.sip | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/sip/QtWidgets/qtabbar.sip b/sip/QtWidgets/qtabbar.sip
+index ffe2d3b..80ad816 100644
+--- a/sip/QtWidgets/qtabbar.sip
++++ b/sip/QtWidgets/qtabbar.sip
+@@ -166,11 +166,15 @@ protected:
+
+ public:
+ %If (Qt_5_8_0 -)
++%If (PyQt_Accessibility)
+ QString accessibleTabName(int index) const;
+ %End
++%End
+ %If (Qt_5_8_0 -)
++%If (PyQt_Accessibility)
+ void setAccessibleTabName(int index, const QString &name);
+ %End
++%End
+
+ private:
+ QTabBar(const QTabBar &);
+--
+2.7.4
+
diff --git a/recipes-python/pyqt5/python-pyqt5_5.8.2.bb b/recipes-python/pyqt5/python-pyqt5_5.8.2.bb
index 3fa3d644..fdfa1205 100644
--- a/recipes-python/pyqt5/python-pyqt5_5.8.2.bb
+++ b/recipes-python/pyqt5/python-pyqt5_5.8.2.bb
@@ -11,6 +11,7 @@ DEPENDS = "sip sip-native qtbase python"
SRC_URI = "\
${SOURCEFORGE_MIRROR}/pyqt/PyQt5_gpl-${PV}.tar.gz \
file://fix-sm.patch \
+ file://0001-qtabbar.sip-fix-build-with-accessibility-disabled.patch \
"
SRC_URI[md5sum] = "c3048e9d242f3e72fd393630da1d971a"
SRC_URI[sha256sum] = "ebd70515b30bbd6098fee29e6271a6696b1183c5530ee30e6ba9aaab195536e8"
@@ -31,8 +32,8 @@ DISABLED_FEATURES = "PyQt_Desktop_OpenGL PyQt_Accessibility PyQt_SessionManager"
DISABLED_FEATURES_append_arm = " PyQt_qreal_double"
-PYQT_MODULES = "QtCore QtGui QtNetwork"
-PYQT_MODULES_aarch64 = "QtCore QtGui QtNetwork"
+PYQT_MODULES = "QtCore QtGui QtNetwork QtWidgets"
+PYQT_MODULES_aarch64 = "QtCore QtGui QtNetwork QtWidgets"
do_configure_prepend() {
cd ${S}