aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-python
diff options
context:
space:
mode:
authorDiego Rondini <diego.rondini@kynetics.com>2018-05-10 08:36:06 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2018-06-21 18:37:08 +0000
commite199d801f8a5bd06b2bee3ab9ef89ea9271c902d (patch)
treef6a491e755d1939e6d38296d3f148e74168665cf /recipes-python
parent65db89eb7b6a9b53f7877d6e16bc4deeb367c285 (diff)
python-pyqt5: update recipe to 5.10.1
Update recipe to version 5.10.1, removing upstreamed patches in the process. Signed-off-by: Diego Rondini <diego.rondini@kynetics.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-python')
-rw-r--r--recipes-python/pyqt5/files/0001-qtabbar.sip-fix-build-with-accessibility-disabled.patch35
-rw-r--r--recipes-python/pyqt5/files/fix-sm.patch17
-rw-r--r--recipes-python/pyqt5/python-pyqt5_5.10.1.bb (renamed from recipes-python/pyqt5/python-pyqt5_5.8.2.bb)8
3 files changed, 3 insertions, 57 deletions
diff --git a/recipes-python/pyqt5/files/0001-qtabbar.sip-fix-build-with-accessibility-disabled.patch b/recipes-python/pyqt5/files/0001-qtabbar.sip-fix-build-with-accessibility-disabled.patch
deleted file mode 100644
index 7e1c7bf4..00000000
--- a/recipes-python/pyqt5/files/0001-qtabbar.sip-fix-build-with-accessibility-disabled.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 8a2f852417414e19d060da66cd7c5cba76e43c7d Mon Sep 17 00:00:00 2001
-From: Diego Rondini <diego.rondini@kynetics.com>
-Date: Wed, 19 Jul 2017 14:17:51 +0200
-Subject: [PATCH] qtabbar.sip: fix build with accessibility disabled
-
-Upstream-Status: Submitted
-
-Signed-off-by: Diego Rondini <diego.rondini@kynetics.com>
----
- sip/QtWidgets/qtabbar.sip | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/sip/QtWidgets/qtabbar.sip b/sip/QtWidgets/qtabbar.sip
-index ffe2d3b..80ad816 100644
---- a/sip/QtWidgets/qtabbar.sip
-+++ b/sip/QtWidgets/qtabbar.sip
-@@ -166,11 +166,15 @@ protected:
-
- public:
- %If (Qt_5_8_0 -)
-+%If (PyQt_Accessibility)
- QString accessibleTabName(int index) const;
- %End
-+%End
- %If (Qt_5_8_0 -)
-+%If (PyQt_Accessibility)
- void setAccessibleTabName(int index, const QString &name);
- %End
-+%End
-
- private:
- QTabBar(const QTabBar &);
---
-2.7.4
-
diff --git a/recipes-python/pyqt5/files/fix-sm.patch b/recipes-python/pyqt5/files/fix-sm.patch
deleted file mode 100644
index f2936a23..00000000
--- a/recipes-python/pyqt5/files/fix-sm.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- PyQt5_gpl-5.8.2/sip/QtGui/qguiapplication.sip.orig 2017-05-13 13:28:42.523392315 -0400
-+++ PyQt5_gpl-5.8.2/sip/QtGui/qguiapplication.sip 2017-05-13 13:30:08.081207211 -0400
-@@ -270,12 +270,14 @@
- %End
-
- public:
-+%If (PyQt_SessionManager)
- %If (Qt_5_6_0 -)
- static bool isFallbackSessionManagementEnabled();
- %End
- %If (Qt_5_6_0 -)
- static void setFallbackSessionManagementEnabled(bool);
- %End
-+%End
-
- signals:
- %If (Qt_5_6_0 -)
diff --git a/recipes-python/pyqt5/python-pyqt5_5.8.2.bb b/recipes-python/pyqt5/python-pyqt5_5.10.1.bb
index fdfa1205..9a0f8499 100644
--- a/recipes-python/pyqt5/python-pyqt5_5.8.2.bb
+++ b/recipes-python/pyqt5/python-pyqt5_5.10.1.bb
@@ -10,11 +10,9 @@ DEPENDS = "sip sip-native qtbase python"
SRC_URI = "\
${SOURCEFORGE_MIRROR}/pyqt/PyQt5_gpl-${PV}.tar.gz \
- file://fix-sm.patch \
- file://0001-qtabbar.sip-fix-build-with-accessibility-disabled.patch \
"
-SRC_URI[md5sum] = "c3048e9d242f3e72fd393630da1d971a"
-SRC_URI[sha256sum] = "ebd70515b30bbd6098fee29e6271a6696b1183c5530ee30e6ba9aaab195536e8"
+SRC_URI[md5sum] = "be36c2abaffc9daa8b993f1ca982968f"
+SRC_URI[sha256sum] = "9932e971e825ece4ea08f84ad95017837fa8f3f29c6b0496985fa1093661e9ef"
S = "${WORKDIR}/PyQt5_gpl-${PV}"
@@ -63,7 +61,7 @@ do_install() {
oe_runmake install
}
-RDEPENDS_${PN} = "python-core python-sip"
+RDEPENDS_${PN} = "python-core python-sip qtbase"
FILES_${PN} += "${libdir}/${PYTHON_DIR}/site-packages ${datadir}/sip/PyQt5/"
FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/*/.debug/"