aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-python
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-09-14 12:24:57 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2018-09-19 16:36:36 +0000
commit03b4c7b669b84b03d44f7fc622e00a447223fb9c (patch)
tree285da7806f378863ce0488044a2b88c5c7468e0d /recipes-python
parent5164f84bd6f136e6438eb5847bab08e65d2320b7 (diff)
qt: remove unnecessary FILES.*-dbg variables for packaging .debug files
* package.bbclass can do it automatically since: commit da5ec06814e105451cca11cce76b5c5231110524 Author: Richard Purdie <richard.purdie@linuxfoundation.org> Date: Tue Dec 15 15:38:54 2015 +0000 package: Add auto package splitting of .debug files * .debug files for examples were incorrectly picked by qtbase-qmlplugins-dbg causing following QE error, because unlike qtbase-examples-dbg we don't have libdir in INSANE_SKIP. ERROR: qtbase-5.11.2+gitAUTOINC+49efea26a5-r0 do_package_qa: QA Issue: qtbase-qmlplugins-dbg: found library in wrong location: /usr/share/qt5/examples/widgets/tools/plugandpaint/plugins/.debug/libpnp_extrafilters.so qtbase-qmlplugins-dbg: found library in wrong location: /usr/share/qt5/examples/widgets/tools/styleplugin/styles/.debug/libsimplestyleplugin.so qtbase-qmlplugins-dbg: found library in wrong location: /usr/share/qt5/examples/widgets/tools/echoplugin/plugins/.debug/libechoplugin.so [libdir] ERROR: qtbase-5.11.2+gitAUTOINC+49efea26a5-r0 do_package_qa: QA run found fatal errors. Please consider fixing them. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-python')
-rw-r--r--recipes-python/pyqt5/python-pyqt5_5.10.1.bb1
1 files changed, 0 insertions, 1 deletions
diff --git a/recipes-python/pyqt5/python-pyqt5_5.10.1.bb b/recipes-python/pyqt5/python-pyqt5_5.10.1.bb
index 9a0f8499..a9b52d9a 100644
--- a/recipes-python/pyqt5/python-pyqt5_5.10.1.bb
+++ b/recipes-python/pyqt5/python-pyqt5_5.10.1.bb
@@ -64,5 +64,4 @@ do_install() {
RDEPENDS_${PN} = "python-core python-sip qtbase"
FILES_${PN} += "${libdir}/${PYTHON_DIR}/site-packages ${datadir}/sip/PyQt5/"
-FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/*/.debug/"