aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/examples
diff options
context:
space:
mode:
authorNeena Busireddy <neena.busireddy@freescale.com>2015-04-08 15:30:47 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2015-04-15 17:37:57 -0300
commit831c66e4c2c1cdf8656723de1bd4171e2db78015 (patch)
tree23e9e2f3ca7f642ef9923ce80613973efb5ae0ad /recipes-qt/examples
parent87235825459d376bf4537c9523eb2496e15893aa (diff)
qt5nmapper: Fix compatibility issue
qt5nmapper app fails to run with the following error: file:///usr/share/qt5nmapper-1.0/Qt5_NMapper.qml:34:5: Type Panel unavailable Panel { ^ file:///usr/share/qt5nmapper-1.0/content/Panel.qml:118:9: Type Switch unavailable Switch { ^ file:///usr/share/qt5nmapper-1.0/content/Switch.qml:8:21: Cannot assign a value to a signal (expecting a script to be run) property string onText: "On" This patch changes the string from onText to onTextstring which was introduced with Qt 5.3 Signed-off-by: Neena Busireddy <neena.busireddy@freescale.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Diffstat (limited to 'recipes-qt/examples')
-rw-r--r--recipes-qt/examples/qt5nmapper/change-property-string.patch26
-rw-r--r--recipes-qt/examples/qt5nmapper_1.0.bb3
2 files changed, 28 insertions, 1 deletions
diff --git a/recipes-qt/examples/qt5nmapper/change-property-string.patch b/recipes-qt/examples/qt5nmapper/change-property-string.patch
new file mode 100644
index 00000000..dae2fdcc
--- /dev/null
+++ b/recipes-qt/examples/qt5nmapper/change-property-string.patch
@@ -0,0 +1,26 @@
+qt5nmapper: Change property string to onTextString
+
+Upstream-Status: Pending
+
+diff --git a/content_org/Switch.qml b/content/Switch.qml
+index 08a2cba..a8b8b26 100644
+--- a/content_org/Switch.qml
++++ b/content/Switch.qml
+@@ -5,7 +5,7 @@ Item {
+
+ property alias text: textItem.text
+ property bool checked: false
+- property string onText: "On"
++ property string onTextString: "On"
+ property string offText: "Off"
+
+ QtObject {
+@@ -76,7 +76,7 @@ Item {
+ color: "#000000"
+ font.pixelSize: 18
+ font.bold: true
+- text: onText
++ text: onTextString
+ }
+ Text {
+ anchors.verticalCenter: parent.verticalCenter
diff --git a/recipes-qt/examples/qt5nmapper_1.0.bb b/recipes-qt/examples/qt5nmapper_1.0.bb
index 9b1b7278..77cb067c 100644
--- a/recipes-qt/examples/qt5nmapper_1.0.bb
+++ b/recipes-qt/examples/qt5nmapper_1.0.bb
@@ -6,7 +6,8 @@ LIC_FILES_CHKSUM = "file://README;beginline=47;endline=58;md5=9fb5bf76d564bc5381
DEPENDS = "qtdeclarative qtgraphicaleffects"
-SRC_URI = "http://quitcoding.com/download/Qt5_NMapper_1.0.tgz"
+SRC_URI = "http://quitcoding.com/download/Qt5_NMapper_1.0.tgz \
+ file://change-property-string.patch"
SRC_URI[md5sum] = "dafc425280144d8e286788e75a0dba0f"
SRC_URI[sha256sum] = "607fbf4c448f00d3c563f9ef8a582bcb6e8fe550e80b56bf8d9127a417faa53b"