aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/maliit
diff options
context:
space:
mode:
authorAdam YH Lee <adam.yh.lee@gmail.com>2015-09-04 17:28:30 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2015-09-21 11:56:52 +0200
commit6f0dd9f7cb4166f22b78c0813819c636f6382e4f (patch)
tree4f179da50a054af9c93ea201f4173fc1a5d4160a /recipes-qt/maliit
parent001ee936e9f4f3123a4f7b948bad111acdac740d (diff)
Remove double slash when QT_DIR_NAME is empty
When `QT_DIR_NAME` is defined as an empty string (default is "qt5"), package.bbclass will throw lots of QA warnings because now the paths contain double slashes ("//"). We can address these warnings by explicitly defining a slash in the variable itself. Signed-off-by: Adam YH Lee <adam.yh.lee@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/maliit')
-rw-r--r--recipes-qt/maliit/maliit-framework-qt5_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-qt/maliit/maliit-framework-qt5_git.bb b/recipes-qt/maliit/maliit-framework-qt5_git.bb
index 490670d9..83da8cad 100644
--- a/recipes-qt/maliit/maliit-framework-qt5_git.bb
+++ b/recipes-qt/maliit/maliit-framework-qt5_git.bb
@@ -63,8 +63,8 @@ EXTRA_OEMAKE += "INSTALL_ROOT=${D}"
do_install_append() {
#Fix absolute paths
- sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ${D}/${libdir}/${QT_DIR_NAME}/mkspecs/features/maliit-framework.prf
- sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ${D}/${libdir}/${QT_DIR_NAME}/mkspecs/features/maliit-plugins.prf
+ sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ${D}/${libdir}${QT_DIR_NAME}/mkspecs/features/maliit-framework.prf
+ sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ${D}/${libdir}${QT_DIR_NAME}/mkspecs/features/maliit-plugins.prf
install -d ${D}${datadir}/applications
install -m 644 ${WORKDIR}/maliit-server.desktop ${D}${datadir}/applications