aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qmllive
diff options
context:
space:
mode:
authorSeokha Ko <sukdo399@daum.net>2018-12-02 16:20:53 +0900
committerOtavio Salvador <otavio@ossystems.com.br>2018-12-07 06:37:33 -0200
commit010a29e0ab5eb2a7efde98ee0a4f78884281bc09 (patch)
tree8a2e98773eacc9edb24edd65baa3d59a0e664efb /recipes-qt/qmllive
parentf22750291b224a3ee68456f0319ba18d428e197a (diff)
qmllive: add new recipe
qmlLive is a live reloader environment for rapid UI development Change-Id: Icc29a45ed488a95257625122107b83cbe746c755 Signed-off-by: Seokha Ko <sukdo399@daum.net>
Diffstat (limited to 'recipes-qt/qmllive')
-rw-r--r--recipes-qt/qmllive/qmllive_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-qt/qmllive/qmllive_git.bb b/recipes-qt/qmllive/qmllive_git.bb
new file mode 100644
index 00000000..bc9a3784
--- /dev/null
+++ b/recipes-qt/qmllive/qmllive_git.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "QmlLive is a live reloader environment for rapid UI development"
+HOMEPAGE = "https://github.com/qtproject/qt-apps-qmllive"
+LICENSE = "GPL-3.0"
+LIC_FILES_CHKSUM = "file://LICENSE.GPL3;md5=75cd0dbc6f2d24e7eeb128ff59b74f4c"
+DEPENDS = "qtbase qtdeclarative"
+
+PV = "5.12+git${SRCPV}"
+
+QT_GIT_PROJECT = "qt-apps"
+SRC_URI = "${QT_GIT}/qmllive.git;branch=dev"
+SRCREV = "0c7bf141b08aa9e757e91a4a05769257d043eab2"
+S = "${WORKDIR}/git"
+
+inherit pkgconfig qmake5
+
+EXTRA_QMAKEVARS_POST = "QMAKE_RPATHDIR="
+
+FILES_${PN}-dev += "${datadir}"