aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/nativesdk-qtbase_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-10-19 15:26:34 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-11-11 13:24:53 +0100
commit178a817e6f4604e0f4b24a416d5e83b428cbabe7 (patch)
tree52cbe707471b8ca0002d315c9b970e994854b498 /recipes-qt/qt5/nativesdk-qtbase_git.bb
parentf39bc18eae46e0df30580f0e5992d069f9c881be (diff)
qt5: upgrade to latest revision in 5.6 branch (5.6.0-alpha1+)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/nativesdk-qtbase_git.bb')
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb24
1 files changed, 8 insertions, 16 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index e7879934..f712af72 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -26,9 +26,9 @@ SRC_URI += "\
file://0002-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch \
file://0003-Add-external-hostbindir-option.patch \
file://0004-qt_module-Fix-pkgconfig-and-libtool-replacements.patch \
- file://0005-qeglplatformintegration-Undefine-CursorShape-from-X..patch \
- file://0006-configure-bump-path-length-from-256-to-512-character.patch \
- file://0007-QOpenGLPaintDevice-sub-area-support.patch \
+ file://0005-configure-bump-path-length-from-256-to-512-character.patch \
+ file://0006-QOpenGLPaintDevice-sub-area-support.patch \
+ file://0007-linux-oe-g-Invert-conditional-for-defining-QT_SOCKLE.patch \
"
# common for qtbase-native and nativesdk-qtbase
@@ -37,11 +37,6 @@ SRC_URI += " \
file://0009-Add-external-hostbindir-option-for-native-sdk.patch \
"
-# specific for nativesdk-qtbase
-SRC_URI += " \
- file://0010-configure-preserve-built-qmake-and-swap-with-native-.patch \
-"
-
# CMake's toolchain configuration of nativesdk-qtbase
SRC_URI += " \
file://OEQt5Toolchain.cmake \
@@ -149,10 +144,9 @@ OE_QMAKE_QMAKE = "bin/qmake"
do_configure() {
# we need symlink in path relative to source, because
# EffectivePaths:Prefix is relative to qmake location
- # Also, configure expects qmake-native to swap with real one
- if [ ! -e ${B}/bin/qmake-native ]; then
- mkdir ${B}/bin
- ln -sf ${OE_QMAKE_QMAKE_ORIG} ${B}/bin/qmake-native
+ if [ ! -e ${B}/bin/qmake ]; then
+ mkdir -p ${B}/bin
+ ln -sf ${OE_QMAKE_QMAKE_ORIG} ${B}/bin/qmake
fi
${S}/configure -v \
@@ -223,9 +217,7 @@ do_install() {
oe_runmake install INSTALL_ROOT=${D}
- # replace the native qmake installed above with nativesdk version
- rm -rf ${D}${OE_QMAKE_PATH_HOST_BINS}/qmake
- install -m 755 ${B}/bin/qmake-real ${D}${OE_QMAKE_PATH_HOST_BINS}/qmake
+ install -m 755 ${B}/bin/qmake-target ${D}${OE_QMAKE_PATH_HOST_BINS}/qmake
# for modules which are still using syncqt and call qtPrepareTool(QMAKE_SYNCQT, syncqt)
# e.g. qt3d, qtwayland
@@ -278,4 +270,4 @@ fakeroot do_generate_qt_environment_file() {
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "5afc431323454225363dae30e67a1cb909086bf9"
+SRCREV = "f7f4dde80e13ff1c05a9399297ffb746ab505e62"