aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/nativesdk-qtbase_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@theqtcompany.com>2016-02-12 18:04:55 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-14 18:54:55 +0100
commit7ac1481d0a5b702af5ebedd1ac035bd5b67d666f (patch)
treea4a9eb093efe70b4e0dfeccaf58c98878026ce0a /recipes-qt/qt5/nativesdk-qtbase_git.bb
parentfd8fc6ffdb2e34b2921f06644264c405eee94f5d (diff)
qt5: add Qml support to lupdate
Add dependency to qtdeclarative to qttools' native and nativesdk builds. This gives us lupdate with a support for Qml files. The nativesdk builds of qtdeclarative depend on more modules (Xml, Sql) from nativesdk-qtbase, so preserve all libs that are already built. This brings few extra libs to the package that might not be needed, but keeps the recipe simpler. Signed-off-by: Samuli Piippo <samuli.piippo@theqtcompany.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/nativesdk-qtbase_git.bb')
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb19
1 files changed, 2 insertions, 17 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 3d4900eb..4ac80be4 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -49,6 +49,7 @@ PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src"
FILES_${PN}-tools-dev = " \
${includedir} \
${FILES_SOLIBSDEV} ${libdir}/*.la \
+ ${libdir}/*.prl \
${OE_QMAKE_PATH_ARCHDATA}/mkspecs \
"
@@ -201,16 +202,6 @@ do_configure() {
bin/qmake ${OE_QMAKE_DEBUG_OUTPUT} ${S} -o Makefile || die "Configuring qt with qmake failed. EXTRA_OECONF was ${EXTRA_OECONF}"
}
-# Set the EXTRA_QTLIB variable to e.g. Xml, in order to not remove libQt5Xml.so.*
-EXTRA_QTLIB ?= ""
-
-python __anonymous () {
- templibs = ""
- for e in d.getVar("EXTRA_QTLIB", True).split():
- templibs = "%s -not -name 'libQt5%s.so*' -and" % (templibs, e)
- d.setVar("QTLIBSPRESERVE", templibs)
-}
-
do_install() {
# Fix install paths for all
find -name "Makefile*" | xargs sed -i "s,(INSTALL_ROOT)${STAGING_DIR_NATIVE}${STAGING_DIR_NATIVE},(INSTALL_ROOT)${STAGING_DIR_NATIVE},g"
@@ -223,17 +214,11 @@ do_install() {
# e.g. qt3d, qtwayland
ln -sf syncqt.pl ${D}${OE_QMAKE_PATH_QT_BINS}/syncqt
- # remove things unused in nativesdk, we need the headers, Qt5Core
- # and Qt5Bootstrap.
+ # remove things unused in nativesdk, we need the headers and libs
rm -rf ${D}${datadir} \
${D}/${OE_QMAKE_PATH_PLUGINS} \
${D}${libdir}/cmake \
${D}${libdir}/pkgconfig
- find ${D}${libdir} -maxdepth 1 -name 'lib*' -and -not -type d -and \
- -not -name 'libQt5Core.so*' -and \
- ${QTLIBSPRESERVE} \
- -not -name 'libQt5Bootstrap.a' \
- -exec rm '{}' ';'
# Install CMake's toolchain configuration
mkdir -p ${D}${datadir}/cmake/OEToolchainConfig.cmake.d/