aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/nativesdk-qtbase_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-02-27 23:05:26 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-04-20 10:49:26 +0200
commit9dc60fe10fe812eb4d722d81351c74ec598cb114 (patch)
treeaa2544f28a1e8af088ab92e8cbb9cbb490e9436e /recipes-qt/qt5/nativesdk-qtbase_git.bb
parentd6fe20e6083d421cc6091892e1d302c46e2d075d (diff)
recipes: use new PACKAGECONFIG_CONFARGS instead of EXTRA_OECONF
* this fixes builds for DISTROs which include no-static-libraries.inc * this change depends on oe-core change: http://patchwork.openembedded.org/patch/116719/ which was merged in this form: http://patchwork.openembedded.org/patch/120513/ to Yocto 2.1, if you want to use latest meta-qt5 with older oe-core you need to append EXTRA_OECONF to PACKAGECONFIG_CONFARGS Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/nativesdk-qtbase_git.bb')
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 35d922e4..0bdfde57 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -82,7 +82,7 @@ QT_CONFIG_FLAGS += " \
-no-pch \
-no-rpath \
-pkg-config \
- ${EXTRA_OECONF} \
+ ${PACKAGECONFIG_CONFARGS} \
"
# qtbase is exception, as these are used as install path for sysroots
@@ -201,7 +201,7 @@ do_configure() {
-xplatform linux-oe-g++ \
${QT_CONFIG_FLAGS}
- bin/qmake ${OE_QMAKE_DEBUG_OUTPUT} ${S} -o Makefile || die "Configuring qt with qmake failed. EXTRA_OECONF was ${EXTRA_OECONF}"
+ bin/qmake ${OE_QMAKE_DEBUG_OUTPUT} ${S} -o Makefile || die "Configuring qt with qmake failed. PACKAGECONFIG_CONFARGS was ${PACKAGECONFIG_CONFARGS}"
}
do_install() {