aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/nativesdk-qtbase_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2019-11-26 16:07:49 +0200
committerSamuli Piippo <samuli.piippo@qt.io>2019-11-27 07:38:23 +0200
commit3bd81f1997683774dd28e6b8673c9b19b66a73ec (patch)
tree368a37454e3d7031b33a609ef9a428fa43c73880 /recipes-qt/qt5/nativesdk-qtbase_git.bb
parent08cc9ad2579f897b84d4fb430d898103dc568d26 (diff)
parent929b2ef266c6eb4cc1f5500f421fda449cd8900b (diff)
Merge remote-tracking branch 'qt/5.14' into 5.15
* qt/5.14: (22 commits) qtwebengine: add clang fix qt5: update submodules qt5: use PACKAGECONFIG to disable tests and examples qt5: update submodules qt5: update submodules qt5: update submodules qt5: update submodules ogl-runtime: update to v2.5.0 release qttools: don't install tst_qtattributionsscanner qt5: Upgrade to Qt 5.13.2 python(3)-pyqt5: add qml support libqofono: bump SRCREV and add a fix for voicecall qt5: update submodules qt5: update submodules qtbase: add openssl PACKAGECONFIG for native nativesdk ogl-runtime: update to 2.5 qtbase: Add PACKAGECONFIG for lttng layer: Mark zeus as compatible release ogl-runtime: Fix build on x86_64 README.md: Document need for 32bit host compiler ... Change-Id: I3892eef7a2ee02cde0f493df7aa1a27f683f1799
Diffstat (limited to 'recipes-qt/qt5/nativesdk-qtbase_git.bb')
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 9ce48a1f..caadb1d9 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -22,8 +22,8 @@ require qt5-git.inc
FILESEXTRAPATHS =. "${FILE_DIRNAME}/qtbase:"
# common for qtbase-native, qtbase-nativesdk and qtbase
-# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-shared
-# 5.12.meta-qt5-shared.8
+# Patches from https://github.com/meta-qt5/qtbase/commits/b5.13-shared
+# 5.13.meta-qt5-shared.1
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -41,11 +41,12 @@ SRC_URI += "\
file://0014-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch \
file://0015-corelib-Include-sys-types.h-for-uint32_t.patch \
file://0016-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
+ file://0017-qfloat16-check-for-__ARM_FP-2.patch \
"
# common for qtbase-native and nativesdk-qtbase
-# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-native
-# 5.12.meta-qt5-native.8
+# Patches from https://github.com/meta-qt5/qtbase/commits/b5.13-native
+# 5.13.meta-qt5-native.1
SRC_URI += " \
file://0018-Always-build-uic-and-qvkgen.patch \
file://0019-Avoid-renameeat2-for-native-sdk-builds.patch \
@@ -77,6 +78,7 @@ DEBIAN_NOAUTONAME_${PN} = "1"
PACKAGECONFIG ?= ""
PACKAGECONFIG[gui] = "-gui -qpa offscreen,-no-gui,"
PACKAGECONFIG[imageformats] = "-qt-libpng -qt-libjpeg -gif -ico, -no-libpng -no-libjpeg -no-ico -no-gif,"
+PACKAGECONFIG[openssl] = "-openssl,-no-openssl,openssl,libssl"
QT_CONFIG_FLAGS += " \
-shared \
@@ -111,7 +113,6 @@ do_configure() {
-no-sql-mysql \
-no-sql-sqlite \
-no-opengl \
- -no-openssl \
-no-xcb \
-no-feature-bearermanagement \
-no-icu \