aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/nativesdk-qtbase_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-05-09 12:31:58 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2018-06-21 18:36:32 +0000
commit3b278969696f54b305eb5d878a87f8e81b38257b (patch)
treeb9a7525ef0eba0a8a61fd3be1ca699d694bcd54d /recipes-qt/qt5/nativesdk-qtbase_git.bb
parenta36cc5f0e9b8f3a652ce769401f76ee637886a16 (diff)
nativesdk-qtbase: add quotes to CC and CXX in environment file
CC and CXX include sysroot as argument to compiler and therefore includes spaces, which need to be quoted to work e.g., with dash. Signed-off-by: Samuli Piippo <samuli.piippo@qt.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/nativesdk-qtbase_git.bb')
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index a52d31ef..5971eeb4 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -185,9 +185,9 @@ fakeroot do_generate_qt_environment_file() {
echo 'export OE_QMAKE_CFLAGS="$CFLAGS"' >> $script
echo 'export OE_QMAKE_CXXFLAGS="$CXXFLAGS"' >> $script
echo 'export OE_QMAKE_LDFLAGS="$LDFLAGS"' >> $script
- echo 'export OE_QMAKE_CC=$CC' >> $script
- echo 'export OE_QMAKE_CXX=$CXX' >> $script
- echo 'export OE_QMAKE_LINK=$CXX' >> $script
+ echo 'export OE_QMAKE_CC="$CC"' >> $script
+ echo 'export OE_QMAKE_CXX="$CXX"' >> $script
+ echo 'export OE_QMAKE_LINK="$CXX"' >> $script
echo 'export OE_QMAKE_AR=$AR' >> $script
echo 'export OE_QMAKE_STRIP=$STRIP' >> $script
echo 'export QT_CONF_PATH=${OE_QMAKE_PATH_HOST_BINS}/qt.conf' >> $script