aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/nativesdk-qtbase_git.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2019-05-30 12:01:42 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2019-05-30 12:01:43 +0000
commit2a5f9415e48a38f6f4eb0cf375737a2d8438e2fe (patch)
tree580a9b9acedd1b8d0b88642c85756e78ba633912 /recipes-qt/qt5/nativesdk-qtbase_git.bb
parent8bc72a78b13f2f4c5e1cebebaef9e98b9abbb056 (diff)
qtbase: fix build with gcc-9
* some components which use Werror started to fail with gcc-9, because of new warning: https://gcc.gnu.org/gcc-9/changes.html New warnings: -Wdeprecated-copy, implied by -Wextra, warns about the C++11 deprecation of implicitly declared copy constructor and assignment operator if one of them is user-provided. -Wdeprecated-copy-dtor also warns if the destructor is user-provided, as specified in C++11. * e.g. maliit-framework-qt5 was now failing with: maliit-framework-qt5/0.99.0+gitAUTOINC+62bd54bcde-r0/recipe-sysroot/usr/include/QtCore/qvariant.h:273:25: error: implicitly-declared 'constexpr QVariant::Private& QVariant::Private::operator=(const QVariant::Private&)' is deprecated [-Werror=deprecated-copy] 273 | { other.d = Private(); } | ^ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/nativesdk-qtbase_git.bb')
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb9
1 files changed, 5 insertions, 4 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 82b6da92..3c4f31cc 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -23,7 +23,7 @@ FILESEXTRAPATHS =. "${FILE_DIRNAME}/qtbase:"
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-shared
-# 5.12.meta-qt5-shared.7
+# 5.12.meta-qt5-shared.8
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -41,14 +41,15 @@ SRC_URI += "\
file://0014-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch \
file://0015-corelib-Include-sys-types.h-for-uint32_t.patch \
file://0016-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
+ file://0017-Fix-Wdeprecated-copy-warnings.patch \
"
# common for qtbase-native and nativesdk-qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-native
-# 5.12.meta-qt5-native.7
+# 5.12.meta-qt5-native.8
SRC_URI += " \
- file://0017-Always-build-uic-and-qvkgen.patch \
- file://0018-Avoid-renameeat2-for-native-sdk-builds.patch \
+ file://0018-Always-build-uic-and-qvkgen.patch \
+ file://0019-Avoid-renameeat2-for-native-sdk-builds.patch \
"
# CMake's toolchain configuration of nativesdk-qtbase